- update to 1.3.6

This commit is contained in:
Dan Horák 2010-03-31 12:25:04 +00:00
parent c77656d5d0
commit e15e3bc3f7
5 changed files with 22 additions and 34 deletions

View File

@ -1 +1 @@
scribus-1.3.5.1.tar.bz2
scribus-1.3.6.tar.bz2

View File

@ -1,26 +0,0 @@
From dedea3f94802f0f9d9adef4c48f8061282baf776 Mon Sep 17 00:00:00 2001
From: =?utf-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Mon, 23 Nov 2009 10:13:48 +0100
Subject: [PATCH] check hdict value before freeing the hyphenator
---
Scribus/scribus/hyphenator.cpp | 3 ++-
1 files changed, 2 insertions(+), 1 deletions(-)
diff --git a/Scribus/scribus/hyphenator.cpp b/Scribus/scribus/hyphenator.cpp
index 614db47..4da4467 100644
--- a/Scribus/scribus/hyphenator.cpp
+++ b/Scribus/scribus/hyphenator.cpp
@@ -90,7 +90,8 @@ Hyphenator::Hyphenator(QWidget* parent, ScribusDoc *dok) : QObject( parent ),
Hyphenator::~Hyphenator()
{
- hnj_hyphen_free(hdict);
+ if (hdict)
+ hnj_hyphen_free(hdict);
}
void Hyphenator::NewDict(const QString& name)
--
1.6.3.3

View File

@ -0,0 +1,12 @@
diff -up scribus-1.3.6/CMakeLists.txt.version scribus-1.3.6/CMakeLists.txt
--- scribus-1.3.6/CMakeLists.txt.version 2010-03-30 11:54:53.000000000 +0200
+++ scribus-1.3.6/CMakeLists.txt 2010-03-30 11:55:15.000000000 +0200
@@ -79,7 +79,7 @@ SET (VERSION_MAJOR "1")
SET (VERSION_MINOR "3")
SET (VERSION_PATCH "6")
SET (VERSION_SUFFIX "")
-SET (VERSION ${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_PATCH}.${VERSION_SUFFIX})
+SET (VERSION ${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_PATCH}${VERSION_SUFFIX})
MESSAGE(STATUS "Scribus ${VERSION} will be built to install into ${CMAKE_INSTALL_PREFIX}")
#Set the permissions to be used when installing plugins

View File

@ -1,6 +1,6 @@
Name: scribus
Version: 1.3.5.1
Release: 2%{?dist}
Version: 1.3.6
Release: 1%{?dist}
Summary: DeskTop Publishing application written in Qt
@ -8,9 +8,8 @@ Group: Applications/Productivity
License: GPLv2+
URL: http://www.scribus.net/
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
# https://bugzilla.redhat.com/show_bug.cgi?id=537677
# http://bugs.scribus.net/view.php?id=8595
Patch0: %{name}-1.3.5-check-hdict.patch
# fix version variable for buildsystem
Patch0: %{name}-1.3.6-version.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: cmake
@ -75,7 +74,7 @@ Obsoletes: %{name}-doc < 1.3.5-0.12.beta
%prep
%setup -q
%patch0 -p2 -b .check-hdict
%patch0 -p1 -b .version
# recode man page to UTF-8
pushd scribus/manpages
@ -170,6 +169,9 @@ update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
%changelog
* Wed Mar 31 2010 Dan Horák <dan[AT]danny.cz> - 1.3.6-1
- update to 1.3.6
* Wed Nov 25 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5.1-2
- fixed a crash when closing a hyphenator object (#537677)

View File

@ -1 +1 @@
4cadca0c780491ad61dc2d815776f10b scribus-1.3.5.1.tar.bz2
2d653c8371d198b5d8321e9ba5e0142d scribus-1.3.6.tar.bz2