- update to final 1.3.7

This commit is contained in:
Dan Horák 2010-06-04 09:58:21 +00:00
parent 52534a6a60
commit b3285111aa
8 changed files with 63 additions and 161 deletions

View File

@ -1 +1 @@
scribus-1.3.6.tar.bz2
scribus-1.3.7.tar.bz2

View File

@ -1,15 +0,0 @@
diff -up scribus-1.3.6/scribus/CMakeLists.txt.linker scribus-1.3.6/scribus/CMakeLists.txt
--- scribus-1.3.6/scribus/CMakeLists.txt.linker 2010-03-31 11:52:41.000000000 +0200
+++ scribus-1.3.6/scribus/CMakeLists.txt 2010-03-31 11:56:16.000000000 +0200
@@ -761,6 +761,11 @@ TARGET_LINK_LIBRARIES(${EXE_NAME}
${WIN32_ONLY_LIBS}
)
+# required to resolve symbols from libdl when ld is called with --no-add-needed
+IF(UNIX)
+ TARGET_LINK_LIBRARIES(${EXE_NAME} dl)
+ENDIF(UNIX)
+
IF(WIN32)
TARGET_LINK_LIBRARIES(${EXE_NAME} ${QT_QTMAIN_LIBRARY})
ENDIF(WIN32)

View File

@ -1,60 +0,0 @@
commit bc55f2b3d31111a4c95372b6ad1ae139d29f3076
Author: jghali <jghali@11d20701-8431-0410-a711-e3c959e3b870>
Date: Mon Apr 26 21:31:23 2010 +0000
some fixes for building with podofo 0.8.0
git-svn-id: svn://scribus.info/Scribus/branches/Version135@15016 11d20701-8431-0410-a711-e3c959e3b870
diff --git a/Scribus/scribus/pdflib_core.cpp b/Scribus/scribus/pdflib_core.cpp
index bc25070..cbf637c 100644
--- a/Scribus/scribus/pdflib_core.cpp
+++ b/Scribus/scribus/pdflib_core.cpp
@@ -6364,7 +6364,9 @@ bool PDFLibCore::PDF_EmbeddedPDF(PageItem* c, const QString& fn, double sx, doub
}
*/
char * mbuffer = NULL;
-#if defined(pdf_long)
+#if (PODOFO_MAJOR == 0 && PODOFO_MINOR >= 8)
+ PoDoFo::pdf_long mlen = 0;
+#elif defined(pdf_long)
pdf_long mlen = 0;
#else
long mlen = 0;
@@ -6631,7 +6633,9 @@ void PDFLibCore::copyPoDoFoObject(const PoDoFo::PdfObject* obj, uint scObjID, QM
if (obj->HasStream())
{
char * mbuffer = NULL;
-#if defined(pdf_long)
+#if (PODOFO_MAJOR == 0 && PODOFO_MINOR >= 8)
+ PoDoFo::pdf_long mlen = 0;
+#elif defined(pdf_long)
pdf_long mlen = 0;
#else
long mlen = 0;
diff --git a/Scribus/scribus/plugins/import/ai/importai.cpp b/Scribus/scribus/plugins/import/ai/importai.cpp
index 287f508..482962f 100644
--- a/Scribus/scribus/plugins/aiimplugin/importai.cpp
+++ b/Scribus/scribus/plugins/aiimplugin/importai.cpp
@@ -413,7 +413,9 @@ bool AIPlug::extractFromPDF(QString infile, QString outfile)
data = priv->GetIndirectKey(PoDoFo::PdfName(Key.toUtf8().data()));
PoDoFo::PdfStream const *stream = data->GetStream();
char *Buffer;
-#if defined(pdf_long)
+#if (PODOFO_MAJOR == 0 && PODOFO_MINOR >= 8)
+ PoDoFo::pdf_long bLen = 0;
+#elif defined(pdf_long)
pdf_long bLen = 0;
#else
long bLen = 0;
@@ -432,7 +434,9 @@ bool AIPlug::extractFromPDF(QString infile, QString outfile)
break;
PoDoFo::PdfStream const *stream = data->GetStream();
char *Buffer;
-#if defined(pdf_long)
+#if (PODOFO_MAJOR == 0 && PODOFO_MINOR >= 8)
+ PoDoFo::pdf_long bLen = 0;
+#elif defined(pdf_long)
pdf_long bLen = 0;
#else
long bLen = 0;

View File

@ -1,24 +0,0 @@
diff -up scribus-1.3.6/scribus/plugins/barcodegenerator/barcodegenerator.h.qstring scribus-1.3.6/scribus/plugins/barcodegenerator/barcodegenerator.h
--- scribus-1.3.6/scribus/plugins/barcodegenerator/barcodegenerator.h.qstring 2010-03-30 15:38:04.000000000 +0200
+++ scribus-1.3.6/scribus/plugins/barcodegenerator/barcodegenerator.h 2010-03-30 15:39:46.000000000 +0200
@@ -100,7 +100,7 @@ class BarcodeGenerator : public QDialog
\param dpi optional DPI value. Default is 72 for preview.
\retval bool true on success.
*/
- bool paintBarcode(QString fileName = 0, int dpi = 72);
+ bool paintBarcode(QString fileName = QString::null, int dpi = 72);
/*! \brief Create color preview.
Used for Color box feedback.
\param l A pointer to the sample QLabel
diff -up scribus-1.3.6/scribus/scribusdoc.cpp.qstring scribus-1.3.6/scribus/scribusdoc.cpp
--- scribus-1.3.6/scribus/scribusdoc.cpp.qstring 2010-03-31 11:41:08.000000000 +0200
+++ scribus-1.3.6/scribus/scribusdoc.cpp 2010-03-31 11:40:45.000000000 +0200
@@ -189,7 +189,7 @@ ScribusDoc::ScribusDoc() : UndoObject( t
pageSets(prefsData.pageSets),
PageSp(1), PageSpa(0),
currentPageLayout(0),
- PageOri(0), m_pageSize(0),
+ PageOri(0), m_pageSize(QString::null),
FirstPnum(1),
useRaster(false),
PageColors(this, true),

View File

@ -1,12 +0,0 @@
diff -up scribus-1.3.6/CMakeLists.txt.version scribus-1.3.6/CMakeLists.txt
--- scribus-1.3.6/CMakeLists.txt.version 2010-03-30 11:54:53.000000000 +0200
+++ scribus-1.3.6/CMakeLists.txt 2010-03-30 11:55:15.000000000 +0200
@@ -79,7 +79,7 @@ SET (VERSION_MAJOR "1")
SET (VERSION_MINOR "3")
SET (VERSION_PATCH "6")
SET (VERSION_SUFFIX "")
-SET (VERSION ${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_PATCH}.${VERSION_SUFFIX})
+SET (VERSION ${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_PATCH}${VERSION_SUFFIX})
MESSAGE(STATUS "Scribus ${VERSION} will be built to install into ${CMAKE_INSTALL_PREFIX}")
#Set the permissions to be used when installing plugins

View File

@ -1,6 +1,42 @@
diff -Nrup scribus-1.3.5.rc3.orig/cmake/modules/FindHYPHEN.cmake scribus-1.3.5.rc3/cmake/modules/FindHYPHEN.cmake
--- scribus-1.3.5.rc3.orig/cmake/modules/FindHYPHEN.cmake 1970-01-01 01:00:00.000000000 +0100
+++ scribus-1.3.5.rc3/cmake/modules/FindHYPHEN.cmake 2009-07-02 14:23:26.000000000 +0200
From 714923566c62dbe89991ca8e100d9c47e9aa38fc Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Tue, 1 Jun 2010 10:54:50 +0200
Subject: [PATCH] use system hyphen library
---
Scribus/CMakeLists.txt | 10 ++++++++++
Scribus/cmake/modules/FindHYPHEN.cmake | 28 ++++++++++++++++++++++++++++
Scribus/scribus/CMakeLists.txt | 16 ++++++++++++++--
Scribus/scribus/hyphenator.h | 2 +-
4 files changed, 53 insertions(+), 3 deletions(-)
create mode 100644 Scribus/cmake/modules/FindHYPHEN.cmake
diff --git a/Scribus/CMakeLists.txt b/Scribus/CMakeLists.txt
index 482fb4c..2547d3b 100644
--- a/Scribus/CMakeLists.txt
+++ b/Scribus/CMakeLists.txt
@@ -684,6 +684,16 @@ IF (WITH_PODOFO)
ENDIF (WITH_PODOFO)
#>>PoDoFo for AI PDF import
+#<<HYPHEN for system hyphenation library
+FIND_PACKAGE(HYPHEN)
+IF(HYPHEN_FOUND)
+ MESSAGE("system hyphenation library found OK")
+ SET(HAVE_HYPHEN 1)
+ELSE(HYPHEN_FOUND)
+ MESSAGE("system hyphenation library NOT found - will use internal one")
+ENDIF(HYPHEN_FOUND)
+#>>HYPHEN for system hyphenation library
+
##############################################################################################################
########## Include Setup ##########
diff --git a/Scribus/cmake/modules/FindHYPHEN.cmake b/Scribus/cmake/modules/FindHYPHEN.cmake
new file mode 100644
index 0000000..d67bd59
--- /dev/null
+++ b/Scribus/cmake/modules/FindHYPHEN.cmake
@@ -0,0 +1,28 @@
+# - Find HYPHEN library
+# Find the native HYPHEN includes and library
@ -30,29 +66,11 @@ diff -Nrup scribus-1.3.5.rc3.orig/cmake/modules/FindHYPHEN.cmake scribus-1.3.5.r
+IF(HYPHEN_FOUND)
+ SET( HYPHEN_LIBRARIES ${HYPHEN_LIBRARY} )
+ENDIF(HYPHEN_FOUND)
--- scribus-1.3.5.rc3.orig/CMakeLists.txt 2009-05-30 14:38:09.000000000 +0200
+++ scribus-1.3.5.rc3/CMakeLists.txt 2009-07-02 14:32:24.000000000 +0200
@@ -638,6 +638,16 @@ ELSE(LIBPODOFO_FOUND)
ENDIF(LIBPODOFO_FOUND)
#>>PoDoFo for AI PDF import
+#<<HYPHEN for system hyphenation library
+FIND_PACKAGE(HYPHEN)
+IF(HYPHEN_FOUND)
+ MESSAGE("system hyphenation library found OK")
+ SET(HAVE_HYPHEN 1)
+ELSE(HYPHEN_FOUND)
+ MESSAGE("system hyphenation library NOT found - will use internal one")
+ENDIF(HYPHEN_FOUND)
+#>>HYPHEN for system hyphenation library
+
##############################################################################################################
########## Include Setup ##########
diff -Nrup -x CMakeFiles -x Makefile -x FindHYPHEN.cmake scribus-1.3.5.rc3.orig/scribus/CMakeLists.txt scribus-1.3.5.rc3/scribus/CMakeLists.txt
--- scribus-1.3.5.rc3.orig/scribus/CMakeLists.txt 2009-06-07 09:05:54.000000000 +0200
+++ scribus-1.3.5.rc3/scribus/CMakeLists.txt 2009-07-02 15:22:52.000000000 +0200
@@ -403,10 +403,8 @@ SET(SCRIBUS_SOURCES
diff --git a/Scribus/scribus/CMakeLists.txt b/Scribus/scribus/CMakeLists.txt
index e856781..49da5f6 100644
--- a/Scribus/scribus/CMakeLists.txt
+++ b/Scribus/scribus/CMakeLists.txt
@@ -396,10 +396,8 @@ SET(SCRIBUS_SOURCES
guidesdelegate.cpp
guidesmodel.cpp
helpbrowser.cpp
@ -63,7 +81,7 @@ diff -Nrup -x CMakeFiles -x Makefile -x FindHYPHEN.cmake scribus-1.3.5.rc3.orig/
hyphenator.cpp
hysettings.cpp
imageinfodialog.cpp
@@ -641,6 +639,14 @@ SET(SCRIBUS_SOURCES
@@ -634,6 +632,14 @@ SET(SCRIBUS_SOURCES
vruler.cpp
)
@ -78,7 +96,7 @@ diff -Nrup -x CMakeFiles -x Makefile -x FindHYPHEN.cmake scribus-1.3.5.rc3.orig/
IF(WIN32)
SET(SCRIBUS_MOC_WIN32_ONLY_CLASSES scprintengine_gdi.h)
SET(SCRIBUS_WIN32_ONLY_SOURCES
@@ -785,6 +791,12 @@ IF(HAVE_PODOFO)
@@ -783,6 +789,12 @@ IF(HAVE_PODOFO)
)
ENDIF(HAVE_PODOFO)
@ -91,10 +109,11 @@ diff -Nrup -x CMakeFiles -x Makefile -x FindHYPHEN.cmake scribus-1.3.5.rc3.orig/
# Now build plugins
SET(PLUGIN_LIBRARIES)
IF(WIN32)
diff -Nrup -x CMakeFiles -x Makefile -x '*.cmake' scribus-1.3.5.rc3.orig/scribus/hyphenator.h scribus-1.3.5.rc3/scribus/hyphenator.h
--- scribus-1.3.5.rc3.orig/scribus/hyphenator.h 2007-07-10 22:33:09.000000000 +0200
+++ scribus-1.3.5.rc3/scribus/hyphenator.h 2009-07-02 14:03:11.000000000 +0200
@@ -13,7 +13,7 @@ for which a new license (GPL+exception)
diff --git a/Scribus/scribus/hyphenator.h b/Scribus/scribus/hyphenator.h
index 7712c37..1312950 100644
--- a/Scribus/scribus/hyphenator.h
+++ b/Scribus/scribus/hyphenator.h
@@ -13,7 +13,7 @@ for which a new license (GPL+exception) is in place.
#include <QSet>
#include "scribusapi.h"
@ -103,3 +122,6 @@ diff -Nrup -x CMakeFiles -x Makefile -x '*.cmake' scribus-1.3.5.rc3.orig/scribus
class ScribusDoc;
class ScribusMainWindow;
class PageItem;
--
1.6.6.1

View File

@ -1,6 +1,6 @@
Name: scribus
Version: 1.3.6
Release: 4%{?dist}
Version: 1.3.7
Release: 1%{?dist}
Summary: DeskTop Publishing application written in Qt
@ -10,15 +10,7 @@ URL: http://www.scribus.net/
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
# https://bugzilla.redhat.com/show_bug.cgi?id=506074
# http://bugs.scribus.net/view.php?id=8232
Patch0: %{name}-1.3.5-system-hyphen.patch
# fix version variable for buildsystem
Patch1: %{name}-1.3.6-version.patch
# fix QString initialization in Qt 4.7
Patch2: %{name}-1.3.6-qstring.patch
# fix linking with --no-add-needed
Patch3: %{name}-1.3.6-linker.patch
# fix build with podofo 0.8.0
Patch4: %{name}-1.3.6-podofo-0.8.0.patch
Patch0: %{name}-1.3.7-system-hyphen.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: cmake
@ -85,11 +77,7 @@ Obsoletes: %{name}-doc < 1.3.5-0.12.beta
%prep
%setup -q -n %{name}-%{version}
%patch0 -p1 -b .system-hyphen
%patch1 -p1 -b .version
%patch2 -p1 -b .qstring
%patch3 -p1 -b .linker
%patch4 -p2 -b .podofo
%patch0 -p2 -b .system-hyphen
# recode man page to UTF-8
pushd scribus/manpages
@ -197,6 +185,9 @@ update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
%changelog
* Tue Jun 1 2010 Dan Horák <dan[AT]danny.cz> - 1.3.7-1
- update to final 1.3.7
* Thu Apr 29 2010 Dan Horák <dan[AT]danny.cz> - 1.3.6-4
- fix build with podofo 0.8.0

View File

@ -1 +1 @@
2d653c8371d198b5d8321e9ba5e0142d scribus-1.3.6.tar.bz2
2c486389172c053ff4da38960e412690 scribus-1.3.7.tar.bz2