- update to 1.3.9

- filter unwanted Provides

Conflicts:

	scribus.spec
This commit is contained in:
Dan Horák 2010-11-30 12:56:14 +01:00
parent 2a249ac3ea
commit afa7b122e9
5 changed files with 50 additions and 24 deletions

1
.gitignore vendored
View File

@ -1,2 +1,3 @@
scribus-1.3.7.tar.bz2
scribus-1.3.8.tar.bz2
/scribus-1.3.9.tar.bz2

25
scribus-1.3.9-rpath.patch Normal file
View File

@ -0,0 +1,25 @@
From a39803f21ffec3c94a0151bf5c17180e3fb54e65 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Tue, 30 Nov 2010 11:53:22 +0100
Subject: [PATCH] fix rpath injection
---
.../plugins/tools/2geomtools/CMakeLists.txt | 2 --
1 files changed, 0 insertions(+), 2 deletions(-)
diff --git a/Scribus/scribus/plugins/tools/2geomtools/CMakeLists.txt b/Scribus/scribus/plugins/tools/2geomtools/CMakeLists.txt
index a283288..59bc9c3 100644
--- a/Scribus/scribus/plugins/tools/2geomtools/CMakeLists.txt
+++ b/Scribus/scribus/plugins/tools/2geomtools/CMakeLists.txt
@@ -22,8 +22,6 @@ IF(Boost_FOUND)
MESSAGE(STATUS "Boost: FOUND, building 2geomtools")
INCLUDE_DIRECTORIES( ${Boost_INCLUDE_DIR} )
ADD_SUBDIRECTORY (lib2geom)
- SET(GEOMLIB ${CMAKE_CURRENT_BINARY_DIR}/lib2geom/2geom)
- LINK_DIRECTORIES(${PLUGIN_LIBRARIES} ${GEOMLIB})
ADD_SUBDIRECTORY (meshdistortion)
ADD_SUBDIRECTORY (pathalongpath)
ELSE(Boost_FOUND)
--
1.7.3.2

View File

@ -1,4 +1,4 @@
From 714923566c62dbe89991ca8e100d9c47e9aa38fc Mon Sep 17 00:00:00 2001
From d3dfe80d0a9892236cbbe14b68fe301b93e90a6f Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Tue, 1 Jun 2010 10:54:50 +0200
Subject: [PATCH] use system hyphen library
@ -12,10 +12,10 @@ Subject: [PATCH] use system hyphen library
create mode 100644 Scribus/cmake/modules/FindHYPHEN.cmake
diff --git a/Scribus/CMakeLists.txt b/Scribus/CMakeLists.txt
index 482fb4c..2547d3b 100644
index 6f37f5f..09396f3 100644
--- a/Scribus/CMakeLists.txt
+++ b/Scribus/CMakeLists.txt
@@ -684,6 +684,16 @@ IF (WITH_PODOFO)
@@ -678,6 +678,16 @@ IF (WITH_PODOFO)
ENDIF (WITH_PODOFO)
#>>PoDoFo for AI PDF import
@ -67,10 +67,10 @@ index 0000000..d67bd59
+ SET( HYPHEN_LIBRARIES ${HYPHEN_LIBRARY} )
+ENDIF(HYPHEN_FOUND)
diff --git a/Scribus/scribus/CMakeLists.txt b/Scribus/scribus/CMakeLists.txt
index e856781..49da5f6 100644
index 8663f39..5ab1762 100644
--- a/Scribus/scribus/CMakeLists.txt
+++ b/Scribus/scribus/CMakeLists.txt
@@ -396,10 +396,8 @@ SET(SCRIBUS_SOURCES
@@ -397,10 +397,8 @@ SET(SCRIBUS_SOURCES
guidesdelegate.cpp
guidesmodel.cpp
helpbrowser.cpp
@ -81,7 +81,7 @@ index e856781..49da5f6 100644
hyphenator.cpp
hysettings.cpp
imageinfodialog.cpp
@@ -634,6 +632,14 @@ SET(SCRIBUS_SOURCES
@@ -635,6 +633,14 @@ SET(SCRIBUS_SOURCES
vruler.cpp
)
@ -96,7 +96,7 @@ index e856781..49da5f6 100644
IF(WIN32)
SET(SCRIBUS_MOC_WIN32_ONLY_CLASSES scprintengine_gdi.h)
SET(SCRIBUS_WIN32_ONLY_SOURCES
@@ -783,6 +789,12 @@ IF(HAVE_PODOFO)
@@ -800,6 +806,12 @@ IF(HAVE_PODOFO)
)
ENDIF(HAVE_PODOFO)
@ -107,8 +107,8 @@ index e856781..49da5f6 100644
+ENDIF(HAVE_HYPHEN)
+
# Now build plugins
SET(PLUGIN_LIBRARIES)
IF(WIN32)
SET(PLUGIN_LIBRARIES
${QT_QTCORE_LIBRARY} ${QT_QTGUI_LIBRARY} ${QT_QTXML_LIBRARY}
diff --git a/Scribus/scribus/hyphenator.h b/Scribus/scribus/hyphenator.h
index 7712c37..1312950 100644
--- a/Scribus/scribus/hyphenator.h
@ -123,5 +123,5 @@ index 7712c37..1312950 100644
class ScribusMainWindow;
class PageItem;
--
1.6.6.1
1.7.3.2

View File

@ -1,5 +1,5 @@
Name: scribus
Version: 1.3.8
Version: 1.3.9
Release: 1%{?dist}
Summary: DeskTop Publishing application written in Qt
@ -10,7 +10,9 @@ URL: http://www.scribus.net/
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
# https://bugzilla.redhat.com/show_bug.cgi?id=506074
# http://bugs.scribus.net/view.php?id=8232
Patch0: %{name}-1.3.7-system-hyphen.patch
Patch0: %{name}-1.3.9-system-hyphen.patch
# fix rpath injection
Patch1: %{name}-1.3.9-rpath.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: cmake
@ -42,6 +44,9 @@ Requires: tkinter
Requires: shared-mime-info
Requires: %{name}-doc = %{version}-%{release}
%filter_provides_in %{_libdir}/%{name}/plugins
%filter_setup
%description
Scribus is an desktop open source page layout program with
@ -79,6 +84,7 @@ Obsoletes: %{name}-doc < 1.3.5-0.12.beta
%prep
%setup -q -n %{name}-%{version}
%patch0 -p2 -b .system-hyphen
%patch1 -p2 -b .rpath
# recode man page to UTF-8
pushd scribus/manpages
@ -102,15 +108,9 @@ done
%build
mkdir build
pushd build
%cmake ..
%cmake -DWANT_DISTROBUILD=YES ..
%ifnarch s390x
make VERBOSE=1 %{?_smp_mflags}
%else
# we can't use parallel build on s390x, because g++ eats almost all memory
# in the builder (2+0.5 GB) when compiling scribus134format.cpp
make VERBOSE=1
%endif
popd
@ -172,11 +172,7 @@ update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
%files doc
%defattr(-,root,root,-)
%dir %{_datadir}/doc/%{name}-%{version}
%lang(cs) %{_datadir}/doc/%{name}-%{version}/cs
%lang(de) %{_datadir}/doc/%{name}-%{version}/de
%lang(en) %{_datadir}/doc/%{name}-%{version}/en
%lang(fr) %{_datadir}/doc/%{name}-%{version}/fr
%lang(pl) %{_datadir}/doc/%{name}-%{version}/pl
%{_datadir}/doc/%{name}-%{version}/BUILDING
%{_datadir}/doc/%{name}-%{version}/NEWS
%{_datadir}/doc/%{name}-%{version}/README*
@ -186,6 +182,10 @@ update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
%changelog
* Tue Nov 30 2010 Dan Horák <dan[AT]danny.cz> - 1.3.9-1
- update to 1.3.9
- filter unwanted Provides
* Mon Aug 16 2010 Dan Horák <dan[AT]danny.cz> - 1.3.8-1
- update to 1.3.8

View File

@ -1 +1 @@
660b946ea3ba19e894fb5701832a6b54 scribus-1.3.8.tar.bz2
a54dbf2e10cd88d683d0d34565d29378 scribus-1.3.9.tar.bz2