Merge branch 'master' into epel7
This commit is contained in:
commit
95a6a0c453
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@ scribus-1.3.8.tar.bz2
|
|||||||
/scribus-1.4.1.tar.xz.asc
|
/scribus-1.4.1.tar.xz.asc
|
||||||
/scribus-1.4.2-free.tar.xz
|
/scribus-1.4.2-free.tar.xz
|
||||||
/scribus-1.4.3-free.tar.xz
|
/scribus-1.4.3-free.tar.xz
|
||||||
|
/scribus-1.4.4-free.tar.xz
|
||||||
|
3
make-free-archive.sh
Normal file → Executable file
3
make-free-archive.sh
Normal file → Executable file
@ -34,6 +34,9 @@ rm resources/swatches/givelife_colors_license.rtf
|
|||||||
|
|
||||||
rm resources/swatches/Federal_Identity_Program.xml
|
rm resources/swatches/Federal_Identity_Program.xml
|
||||||
|
|
||||||
|
# Remove non-free (CC-BY-SA-NC) dot files
|
||||||
|
rm resources/editorconfig/dot.*
|
||||||
|
|
||||||
popd
|
popd
|
||||||
|
|
||||||
echo "Creating sources ..."
|
echo "Creating sources ..."
|
||||||
|
@ -35,3 +35,14 @@ Index: scribus-1.4.2/scribus/profiles/CMakeLists.txt
|
|||||||
-srgb.license
|
-srgb.license
|
||||||
DESTINATION ${SHAREDIR}profiles
|
DESTINATION ${SHAREDIR}profiles
|
||||||
)
|
)
|
||||||
|
diff -up scribus-1.4.4/resources/editorconfig/CMakeLists.txt.no-dot scribus-1.4.4/resources/editorconfig/CMakeLists.txt
|
||||||
|
--- scribus-1.4.4/resources/editorconfig/CMakeLists.txt.no-dot 2014-06-06 17:22:12.258966553 -0400
|
||||||
|
+++ scribus-1.4.4/resources/editorconfig/CMakeLists.txt 2014-06-06 17:22:16.326936717 -0400
|
||||||
|
@@ -12,7 +12,6 @@ gnuplot.png
|
||||||
|
300_lilypond.xml
|
||||||
|
lilypond.png
|
||||||
|
400_dot.xml
|
||||||
|
-dot.svg
|
||||||
|
500_povray.xml
|
||||||
|
povray_32.png
|
||||||
|
|
||||||
|
@ -1,49 +0,0 @@
|
|||||||
diff -up scribus-1.4.3/scribus/ui/modetoolbar.cpp.double scribus-1.4.3/scribus/ui/modetoolbar.cpp
|
|
||||||
--- scribus-1.4.3/scribus/ui/modetoolbar.cpp.double 2012-05-21 18:00:08.000000000 +0200
|
|
||||||
+++ scribus-1.4.3/scribus/ui/modetoolbar.cpp 2013-09-19 21:50:48.000000000 +0200
|
|
||||||
@@ -40,7 +40,7 @@ ModeToolBar::ModeToolBar(ScribusMainWind
|
|
||||||
{
|
|
||||||
SubMode = 0;
|
|
||||||
ValCount = 32;
|
|
||||||
- static qreal AutoShapes0[] = {0.0, 0.0, 0.0, 0.0, 100.0, 0.0, 100.0, 0.0, 100.0, 0.0, 100.0, 0.0,
|
|
||||||
+ static double AutoShapes0[] = {0.0, 0.0, 0.0, 0.0, 100.0, 0.0, 100.0, 0.0, 100.0, 0.0, 100.0, 0.0,
|
|
||||||
100.0, 100.0, 100.0, 100.0, 100.0, 100.0, 100.0, 100.0, 0.0, 100.0, 0.0, 100.0,
|
|
||||||
0.0, 100.0, 0.0, 100.0, 0.0, 0.0, 0.0, 0.0};
|
|
||||||
ShapeVals = AutoShapes0;
|
|
||||||
@@ -84,7 +84,7 @@ ModeToolBar::ModeToolBar(ScribusMainWind
|
|
||||||
this->addAction(m_ScMW->scrActions["toolsEyeDropper"]);
|
|
||||||
|
|
||||||
languageChange();
|
|
||||||
- connect(Rechteck, SIGNAL(FormSel(int, int, qreal *)), this, SLOT(SelShape(int, int, qreal *)));
|
|
||||||
+ connect(Rechteck, SIGNAL(FormSel(int, int, qreal *)), this, SLOT(SelShape(int, int, double *)));
|
|
||||||
}
|
|
||||||
|
|
||||||
void ModeToolBar::GetPolyProps()
|
|
||||||
@@ -98,7 +98,7 @@ void ModeToolBar::GetPolyProps()
|
|
||||||
delete dia;
|
|
||||||
}
|
|
||||||
|
|
||||||
-void ModeToolBar::SelShape(int s, int c, qreal *vals)
|
|
||||||
+void ModeToolBar::SelShape(int s, int c, double *vals)
|
|
||||||
{
|
|
||||||
m_ScMW->scrActions["toolsInsertShape"]->setIcon(QIcon(Rechteck->getIconPixmap(s,16)));
|
|
||||||
// insertShapeButtonMenu->hide();
|
|
||||||
diff -up scribus-1.4.3/scribus/ui/modetoolbar.h.double scribus-1.4.3/scribus/ui/modetoolbar.h
|
|
||||||
--- scribus-1.4.3/scribus/ui/modetoolbar.h.double 2012-02-14 23:57:05.000000000 +0100
|
|
||||||
+++ scribus-1.4.3/scribus/ui/modetoolbar.h 2013-08-19 17:13:59.000000000 +0200
|
|
||||||
@@ -51,13 +51,13 @@ public:
|
|
||||||
|
|
||||||
int SubMode;
|
|
||||||
int ValCount;
|
|
||||||
- qreal *ShapeVals;
|
|
||||||
+ double *ShapeVals;
|
|
||||||
|
|
||||||
virtual void changeEvent(QEvent *e);
|
|
||||||
|
|
||||||
public slots:
|
|
||||||
void GetPolyProps();
|
|
||||||
- void SelShape(int s, int c, qreal *vals);
|
|
||||||
+ void SelShape(int s, int c, double *vals);
|
|
||||||
void languageChange();
|
|
||||||
|
|
||||||
protected:
|
|
138
scribus-1.4.4-qreal_double.patch
Normal file
138
scribus-1.4.4-qreal_double.patch
Normal file
@ -0,0 +1,138 @@
|
|||||||
|
Description: Avoid qreal/double type clashes on ARM
|
||||||
|
Author: Colin Watson <cjwatson@ubuntu.com>
|
||||||
|
Forwarded: no
|
||||||
|
Last-Update: 2013-05-16
|
||||||
|
|
||||||
|
--- scribus-1.4.2.dfsg+r18267.orig/scribus/scribus.h
|
||||||
|
+++ scribus-1.4.2.dfsg+r18267/scribus/scribus.h
|
||||||
|
@@ -466,7 +466,7 @@ public slots:
|
||||||
|
/** Fragt nach den Farben */
|
||||||
|
// void GetBrushPen();
|
||||||
|
/** Erzeugt einen Rahmen */
|
||||||
|
- void MakeFrame(int f, int c, double *vals);
|
||||||
|
+ void MakeFrame(int f, int c, qreal *vals);
|
||||||
|
//** Loescht ein Element */
|
||||||
|
//void DeleteObjekt();
|
||||||
|
/** Duplicate current item */
|
||||||
|
--- scribus-1.4.2.dfsg+r18267.orig/scribus/pageitem.cpp
|
||||||
|
+++ scribus-1.4.2.dfsg+r18267/scribus/pageitem.cpp
|
||||||
|
@@ -4597,7 +4597,7 @@ void PageItem::copyToCopyPasteBuffer(str
|
||||||
|
|
||||||
|
|
||||||
|
//Moved from View
|
||||||
|
-void PageItem::SetFrameShape(int count, double *vals)
|
||||||
|
+void PageItem::SetFrameShape(int count, qreal *vals)
|
||||||
|
{
|
||||||
|
PoLine.resize(0);
|
||||||
|
for (int a = 0; a < count-3; a += 4)
|
||||||
|
@@ -4620,7 +4620,7 @@ void PageItem::SetFrameShape(int count,
|
||||||
|
|
||||||
|
void PageItem::SetRectFrame()
|
||||||
|
{
|
||||||
|
- static double rect[] = { 0.0, 0.0, 0.0, 0.0,
|
||||||
|
+ static qreal rect[] = { 0.0, 0.0, 0.0, 0.0,
|
||||||
|
100.0, 0.0, 100.0, 0.0,
|
||||||
|
100.0, 0.0, 100.0, 0.0,
|
||||||
|
100.0, 100.0, 100.0, 100.0,
|
||||||
|
@@ -4635,7 +4635,7 @@ void PageItem::SetRectFrame()
|
||||||
|
|
||||||
|
void PageItem::SetOvalFrame()
|
||||||
|
{
|
||||||
|
- static double rect[] = { 100.0, 50.0, 100.0, 77.615235,
|
||||||
|
+ static qreal rect[] = { 100.0, 50.0, 100.0, 77.615235,
|
||||||
|
50.0, 100.0, 77.615235, 100.0,
|
||||||
|
50.0, 100.0, 22.385765, 100.0,
|
||||||
|
0.0, 50.0, 0.0, 77.615235,
|
||||||
|
--- scribus-1.4.2.dfsg+r18267.orig/scribus/pageitem.h
|
||||||
|
+++ scribus-1.4.2.dfsg+r18267/scribus/pageitem.h
|
||||||
|
@@ -298,7 +298,7 @@ protected:
|
||||||
|
void DrawObj_PathText(ScPainter *p, double sc);
|
||||||
|
public:
|
||||||
|
void DrawObj_Embedded(ScPainter *p, QRectF e, const CharStyle& style, PageItem* cembedded);
|
||||||
|
- void SetFrameShape(int count, double *vals);
|
||||||
|
+ void SetFrameShape(int count, qreal *vals);
|
||||||
|
void SetRectFrame();
|
||||||
|
void SetOvalFrame();
|
||||||
|
void SetFrameRound();
|
||||||
|
--- scribus-1.4.2.dfsg+r18267.orig/scribus/propertiespalette.cpp
|
||||||
|
+++ scribus-1.4.2.dfsg+r18267/scribus/propertiespalette.cpp
|
||||||
|
@@ -4622,7 +4622,7 @@ void PropertiesPalette::MakeIrre(int f,
|
||||||
|
doc->setRedrawBounding(CurItem);
|
||||||
|
break;
|
||||||
|
default:
|
||||||
|
- CurItem->SetFrameShape(c, (double*)vals);
|
||||||
|
+ CurItem->SetFrameShape(c, vals);
|
||||||
|
doc->setRedrawBounding(CurItem);
|
||||||
|
CurItem->FrameType = f+2;
|
||||||
|
break;
|
||||||
|
--- scribus-1.4.2.dfsg+r18267.orig/scribus/scribusdoc.h
|
||||||
|
+++ scribus-1.4.2.dfsg+r18267/scribus/scribusdoc.h
|
||||||
|
@@ -1005,7 +1005,7 @@ public: // Public attributes
|
||||||
|
DocumentInformation documentInfo;
|
||||||
|
int appMode;
|
||||||
|
int SubMode;
|
||||||
|
- double *ShapeValues;
|
||||||
|
+ qreal *ShapeValues;
|
||||||
|
int ValCount;
|
||||||
|
QString DocName;
|
||||||
|
QMap<QString,int> UsedFonts;
|
||||||
|
--- scribus-1.4.2.dfsg+r18267.orig/scribus/canvasmode_create.cpp
|
||||||
|
+++ scribus-1.4.2.dfsg+r18267/scribus/canvasmode_create.cpp
|
||||||
|
@@ -122,7 +122,7 @@ void CreateMode::drawControls(QPainter*
|
||||||
|
{
|
||||||
|
FPointArray poly;
|
||||||
|
int valCount = m_doc->ValCount;
|
||||||
|
- double *vals = m_doc->ShapeValues;
|
||||||
|
+ qreal *vals = m_doc->ShapeValues;
|
||||||
|
for (int a = 0; a < valCount-3; a += 4)
|
||||||
|
{
|
||||||
|
if (vals[a] < 0)
|
||||||
|
--- scribus-1.4.2.dfsg+r18267.orig/scribus/scribus.cpp
|
||||||
|
+++ scribus-1.4.2.dfsg+r18267/scribus/scribus.cpp
|
||||||
|
@@ -7599,7 +7599,7 @@ void ScribusMainWindow::GetBrushPen()
|
||||||
|
}
|
||||||
|
*/
|
||||||
|
//CB-->??
|
||||||
|
-void ScribusMainWindow::MakeFrame(int f, int c, double *vals)
|
||||||
|
+void ScribusMainWindow::MakeFrame(int f, int c, qreal *vals)
|
||||||
|
{
|
||||||
|
PageItem *currItem = doc->m_Selection->itemAt(0);
|
||||||
|
switch (f)
|
||||||
|
--- scribus-1.4.2.dfsg+r18267.orig/scribus/plugins/imposition/imposition.cpp
|
||||||
|
+++ scribus-1.4.2.dfsg+r18267/scribus/plugins/imposition/imposition.cpp
|
||||||
|
@@ -542,7 +542,7 @@ void Imposition::booklet4p(QList<int>* p
|
||||||
|
}
|
||||||
|
groupcontrol->SetRectFrame();
|
||||||
|
|
||||||
|
- double points[32] = {
|
||||||
|
+ qreal points[32] = {
|
||||||
|
//left upper corner - left lower corner
|
||||||
|
targetDoc->Pages->at(0)->guides.vertical(1,targetDoc->Pages->at(0)->guides.Standard),
|
||||||
|
targetDoc->Pages->at(0)->guides.horizontal(0,targetDoc->Pages->at(i)->guides.Standard),
|
||||||
|
@@ -730,7 +730,7 @@ void Imposition::booklet4p(QList<int>* p
|
||||||
|
}
|
||||||
|
groupcontrol->SetRectFrame();
|
||||||
|
|
||||||
|
- double points[32] = {
|
||||||
|
+ qreal points[32] = {
|
||||||
|
//left upper corner - left lower corner
|
||||||
|
0,
|
||||||
|
0,
|
||||||
|
@@ -893,7 +893,7 @@ void Imposition::booklet4p(QList<int>* p
|
||||||
|
}
|
||||||
|
groupcontrol->SetRectFrame();
|
||||||
|
|
||||||
|
- double points[32] = {
|
||||||
|
+ qreal points[32] = {
|
||||||
|
//left upper corner - left lower corner
|
||||||
|
0,
|
||||||
|
0,
|
||||||
|
@@ -1047,7 +1047,7 @@ void Imposition::booklet4p(QList<int>* p
|
||||||
|
}
|
||||||
|
groupcontrol->SetRectFrame();
|
||||||
|
|
||||||
|
- double points[32] = {
|
||||||
|
+ qreal points[32] = {
|
||||||
|
//left upper corner - left lower corner
|
||||||
|
targetDoc->Pages->at(0)->guides.vertical(1,targetDoc->Pages->at(0)->guides.Standard),
|
||||||
|
targetDoc->Pages->at(0)->guides.horizontal(0,targetDoc->Pages->at(i)->guides.Standard),
|
38
scribus.spec
38
scribus.spec
@ -1,6 +1,6 @@
|
|||||||
Name: scribus
|
Name: scribus
|
||||||
Version: 1.4.3
|
Version: 1.4.4
|
||||||
Release: 2%{?dist}
|
Release: 5%{?dist}
|
||||||
|
|
||||||
Summary: DeskTop Publishing application written in Qt
|
Summary: DeskTop Publishing application written in Qt
|
||||||
|
|
||||||
@ -11,7 +11,7 @@ URL: http://www.scribus.net/
|
|||||||
Source0: %{name}-%{version}-free.tar.xz
|
Source0: %{name}-%{version}-free.tar.xz
|
||||||
#Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.xz
|
#Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.xz
|
||||||
#Source1: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.xz.asc
|
#Source1: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.xz.asc
|
||||||
Patch1: %{name}-1.4.3-to-double.patch
|
Patch1: %{name}-1.4.4-qreal_double.patch
|
||||||
# fix build with non-free content removed
|
# fix build with non-free content removed
|
||||||
Patch2: %{name}-1.4.2-nonfree.patch
|
Patch2: %{name}-1.4.2-nonfree.patch
|
||||||
|
|
||||||
@ -117,13 +117,19 @@ rm -rf ${RPM_BUILD_ROOT}%{_defaultdocdir}/%{name}
|
|||||||
|
|
||||||
|
|
||||||
%post
|
%post
|
||||||
update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
|
touch --no-create %{_datadir}/mime/packages &> /dev/null || :
|
||||||
update-desktop-database &> /dev/null || :
|
|
||||||
|
|
||||||
|
|
||||||
%postun
|
%postun
|
||||||
update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
|
if [ $1 -eq 0 ] ; then
|
||||||
|
touch --no-create %{_datadir}/mime/packages &> /dev/null || :
|
||||||
update-desktop-database &> /dev/null || :
|
update-desktop-database &> /dev/null || :
|
||||||
|
update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
|
||||||
|
fi
|
||||||
|
|
||||||
|
%posttrans
|
||||||
|
update-desktop-database &> /dev/null || :
|
||||||
|
update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
@ -142,6 +148,24 @@ update-desktop-database &> /dev/null || :
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Aug 28 2014 Dan Horák <dan[at]danny.cz> - 1.4.4-5
|
||||||
|
- switch to Debian patch for the qreal vs double conflict on ARM (fixes #1076885)
|
||||||
|
|
||||||
|
* Wed Aug 20 2014 Kevin Fenzi <kevin@scrye.com> - 1.4.4-4
|
||||||
|
- Rebuild for rpm bug 1131892
|
||||||
|
|
||||||
|
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.4-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Aug 09 2014 Rex Dieter <rdieter@fedoraproject.org> 1.4.4-2
|
||||||
|
- optimize/update scriptlets
|
||||||
|
|
||||||
|
* Fri Jun 6 2014 Tom Callaway <spot@fedoraproject.org> - 1.4.4-1
|
||||||
|
- update to 1.4.4, drop non-free dot files
|
||||||
|
|
||||||
|
* Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 1.4.3-3
|
||||||
|
- Rebuild for boost 1.55.0
|
||||||
|
|
||||||
* Thu Sep 19 2013 Dan Horák <dan[at]danny.cz> - 1.4.3-2
|
* Thu Sep 19 2013 Dan Horák <dan[at]danny.cz> - 1.4.3-2
|
||||||
- fix the double patch (#1009979)
|
- fix the double patch (#1009979)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user