- added 2 patches for rawhide

This commit is contained in:
Dan Horák 2010-03-31 10:43:04 +00:00
parent cff28c5019
commit 86c4206389
7 changed files with 70 additions and 34 deletions

View File

@ -1 +1 @@
scribus-1.3.5.1.tar.bz2
scribus-1.3.6.tar.bz2

View File

@ -1,26 +0,0 @@
From dedea3f94802f0f9d9adef4c48f8061282baf776 Mon Sep 17 00:00:00 2001
From: =?utf-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Mon, 23 Nov 2009 10:13:48 +0100
Subject: [PATCH] check hdict value before freeing the hyphenator
---
Scribus/scribus/hyphenator.cpp | 3 ++-
1 files changed, 2 insertions(+), 1 deletions(-)
diff --git a/Scribus/scribus/hyphenator.cpp b/Scribus/scribus/hyphenator.cpp
index 614db47..4da4467 100644
--- a/Scribus/scribus/hyphenator.cpp
+++ b/Scribus/scribus/hyphenator.cpp
@@ -90,7 +90,8 @@ Hyphenator::Hyphenator(QWidget* parent, ScribusDoc *dok) : QObject( parent ),
Hyphenator::~Hyphenator()
{
- hnj_hyphen_free(hdict);
+ if (hdict)
+ hnj_hyphen_free(hdict);
}
void Hyphenator::NewDict(const QString& name)
--
1.6.3.3

View File

@ -0,0 +1,15 @@
diff -up scribus-1.3.6/scribus/CMakeLists.txt.linker scribus-1.3.6/scribus/CMakeLists.txt
--- scribus-1.3.6/scribus/CMakeLists.txt.linker 2010-03-31 11:52:41.000000000 +0200
+++ scribus-1.3.6/scribus/CMakeLists.txt 2010-03-31 11:56:16.000000000 +0200
@@ -761,6 +761,11 @@ TARGET_LINK_LIBRARIES(${EXE_NAME}
${WIN32_ONLY_LIBS}
)
+# required to resolve symbols from libdl when ld is called with --no-add-needed
+IF(UNIX)
+ TARGET_LINK_LIBRARIES(${EXE_NAME} dl)
+ENDIF(UNIX)
+
IF(WIN32)
TARGET_LINK_LIBRARIES(${EXE_NAME} ${QT_QTMAIN_LIBRARY})
ENDIF(WIN32)

View File

@ -0,0 +1,24 @@
diff -up scribus-1.3.6/scribus/plugins/barcodegenerator/barcodegenerator.h.qstring scribus-1.3.6/scribus/plugins/barcodegenerator/barcodegenerator.h
--- scribus-1.3.6/scribus/plugins/barcodegenerator/barcodegenerator.h.qstring 2010-03-30 15:38:04.000000000 +0200
+++ scribus-1.3.6/scribus/plugins/barcodegenerator/barcodegenerator.h 2010-03-30 15:39:46.000000000 +0200
@@ -100,7 +100,7 @@ class BarcodeGenerator : public QDialog
\param dpi optional DPI value. Default is 72 for preview.
\retval bool true on success.
*/
- bool paintBarcode(QString fileName = 0, int dpi = 72);
+ bool paintBarcode(QString fileName = QString::null, int dpi = 72);
/*! \brief Create color preview.
Used for Color box feedback.
\param l A pointer to the sample QLabel
diff -up scribus-1.3.6/scribus/scribusdoc.cpp.qstring scribus-1.3.6/scribus/scribusdoc.cpp
--- scribus-1.3.6/scribus/scribusdoc.cpp.qstring 2010-03-31 11:41:08.000000000 +0200
+++ scribus-1.3.6/scribus/scribusdoc.cpp 2010-03-31 11:40:45.000000000 +0200
@@ -189,7 +189,7 @@ ScribusDoc::ScribusDoc() : UndoObject( t
pageSets(prefsData.pageSets),
PageSp(1), PageSpa(0),
currentPageLayout(0),
- PageOri(0), m_pageSize(0),
+ PageOri(0), m_pageSize(QString::null),
FirstPnum(1),
useRaster(false),
PageColors(this, true),

View File

@ -0,0 +1,12 @@
diff -up scribus-1.3.6/CMakeLists.txt.version scribus-1.3.6/CMakeLists.txt
--- scribus-1.3.6/CMakeLists.txt.version 2010-03-30 11:54:53.000000000 +0200
+++ scribus-1.3.6/CMakeLists.txt 2010-03-30 11:55:15.000000000 +0200
@@ -79,7 +79,7 @@ SET (VERSION_MAJOR "1")
SET (VERSION_MINOR "3")
SET (VERSION_PATCH "6")
SET (VERSION_SUFFIX "")
-SET (VERSION ${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_PATCH}.${VERSION_SUFFIX})
+SET (VERSION ${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_PATCH}${VERSION_SUFFIX})
MESSAGE(STATUS "Scribus ${VERSION} will be built to install into ${CMAKE_INSTALL_PREFIX}")
#Set the permissions to be used when installing plugins

View File

@ -1,6 +1,6 @@
Name: scribus
Version: 1.3.5.1
Release: 5%{?dist}
Version: 1.3.6
Release: 2%{?dist}
Summary: DeskTop Publishing application written in Qt
@ -11,9 +11,12 @@ Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.
# https://bugzilla.redhat.com/show_bug.cgi?id=506074
# http://bugs.scribus.net/view.php?id=8232
Patch0: %{name}-1.3.5-system-hyphen.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=537677
# http://bugs.scribus.net/view.php?id=8595
Patch1: %{name}-1.3.5-check-hdict.patch
# fix version variable for buildsystem
Patch1: %{name}-1.3.6-version.patch
# fix QString initialization in Qt 4.7
Patch2: %{name}-1.3.6-qstring.patch
# fix linking with --no-add-needed
Patch3: %{name}-1.3.6-linker.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: cmake
@ -81,7 +84,9 @@ Obsoletes: %{name}-doc < 1.3.5-0.12.beta
%prep
%setup -q -n %{name}-%{version}
%patch0 -p1 -b .system-hyphen
%patch1 -p2 -b .check-hdict
%patch1 -p1 -b .version
%patch2 -p1 -b .qstring
%patch3 -p1 -b .linker
# recode man page to UTF-8
pushd scribus/manpages
@ -189,6 +194,12 @@ update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
%changelog
* Wed Mar 31 2010 Dan Horák <dan[AT]danny.cz> - 1.3.6-2
- added 2 patches for rawhide
* Mon Mar 29 2010 Dan Horák <dan[AT]danny.cz> - 1.3.6-1
- update to final 1.3.6
* Wed Nov 25 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5.1-5
- fixed a crash when closing a hyphenator object (#537677)

View File

@ -1 +1 @@
4cadca0c780491ad61dc2d815776f10b scribus-1.3.5.1.tar.bz2
2d653c8371d198b5d8321e9ba5e0142d scribus-1.3.6.tar.bz2