- added 2 patches for rawhide

This commit is contained in:
Dan Horák 2010-03-31 10:36:36 +00:00
parent ec1d93f275
commit 4a3a639a37
3 changed files with 49 additions and 1 deletions

View File

@ -0,0 +1,15 @@
diff -up scribus-1.3.6/scribus/CMakeLists.txt.linker scribus-1.3.6/scribus/CMakeLists.txt
--- scribus-1.3.6/scribus/CMakeLists.txt.linker 2010-03-31 11:52:41.000000000 +0200
+++ scribus-1.3.6/scribus/CMakeLists.txt 2010-03-31 11:56:16.000000000 +0200
@@ -761,6 +761,11 @@ TARGET_LINK_LIBRARIES(${EXE_NAME}
${WIN32_ONLY_LIBS}
)
+# required to resolve symbols from libdl when ld is called with --no-add-needed
+IF(UNIX)
+ TARGET_LINK_LIBRARIES(${EXE_NAME} dl)
+ENDIF(UNIX)
+
IF(WIN32)
TARGET_LINK_LIBRARIES(${EXE_NAME} ${QT_QTMAIN_LIBRARY})
ENDIF(WIN32)

View File

@ -0,0 +1,24 @@
diff -up scribus-1.3.6/scribus/plugins/barcodegenerator/barcodegenerator.h.qstring scribus-1.3.6/scribus/plugins/barcodegenerator/barcodegenerator.h
--- scribus-1.3.6/scribus/plugins/barcodegenerator/barcodegenerator.h.qstring 2010-03-30 15:38:04.000000000 +0200
+++ scribus-1.3.6/scribus/plugins/barcodegenerator/barcodegenerator.h 2010-03-30 15:39:46.000000000 +0200
@@ -100,7 +100,7 @@ class BarcodeGenerator : public QDialog
\param dpi optional DPI value. Default is 72 for preview.
\retval bool true on success.
*/
- bool paintBarcode(QString fileName = 0, int dpi = 72);
+ bool paintBarcode(QString fileName = QString::null, int dpi = 72);
/*! \brief Create color preview.
Used for Color box feedback.
\param l A pointer to the sample QLabel
diff -up scribus-1.3.6/scribus/scribusdoc.cpp.qstring scribus-1.3.6/scribus/scribusdoc.cpp
--- scribus-1.3.6/scribus/scribusdoc.cpp.qstring 2010-03-31 11:41:08.000000000 +0200
+++ scribus-1.3.6/scribus/scribusdoc.cpp 2010-03-31 11:40:45.000000000 +0200
@@ -189,7 +189,7 @@ ScribusDoc::ScribusDoc() : UndoObject( t
pageSets(prefsData.pageSets),
PageSp(1), PageSpa(0),
currentPageLayout(0),
- PageOri(0), m_pageSize(0),
+ PageOri(0), m_pageSize(QString::null),
FirstPnum(1),
useRaster(false),
PageColors(this, true),

View File

@ -1,6 +1,6 @@
Name: scribus
Version: 1.3.6
Release: 1%{?dist}
Release: 2%{?dist}
Summary: DeskTop Publishing application written in Qt
@ -13,6 +13,10 @@ Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.
Patch0: %{name}-1.3.5-system-hyphen.patch
# fix version variable for buildsystem
Patch1: %{name}-1.3.6-version.patch
# fix QString initialization in Qt 4.7
Patch2: %{name}-1.3.6-qstring.patch
# fix linking with --no-add-needed
Patch3: %{name}-1.3.6-linker.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: cmake
@ -81,6 +85,8 @@ Obsoletes: %{name}-doc < 1.3.5-0.12.beta
%setup -q -n %{name}-%{version}
%patch0 -p1 -b .system-hyphen
%patch1 -p1 -b .version
%patch2 -p1 -b .qstring
%patch3 -p1 -b .linker
# recode man page to UTF-8
pushd scribus/manpages
@ -188,6 +194,9 @@ update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
%changelog
* Wed Mar 31 2010 Dan Horák <dan[AT]danny.cz> - 1.3.6-2
- added 2 patches for rawhide
* Mon Mar 29 2010 Dan Horák <dan[AT]danny.cz> - 1.3.6-1
- update to final 1.3.6