parent
ddfc0d2225
commit
0a4506f8b7
1
.gitignore
vendored
1
.gitignore
vendored
@ -34,3 +34,4 @@ scipy-0.7.2.tar.gz
|
||||
/scipy-1.5.4.tar.gz
|
||||
/scipy-1.6.0.tar.gz
|
||||
/scipy-1.6.1.tar.gz
|
||||
/scipy-1.6.2.tar.gz
|
||||
|
25
scipy.spec
25
scipy.spec
@ -14,7 +14,7 @@
|
||||
|
||||
Summary: Scientific Tools for Python
|
||||
Name: scipy
|
||||
Version: 1.6.1
|
||||
Version: 1.6.2
|
||||
Release: 1%{?dist}
|
||||
|
||||
# BSD -- whole package except:
|
||||
@ -125,6 +125,25 @@ for PY in %{python3_version}; do
|
||||
%endif
|
||||
done
|
||||
|
||||
# FIXME: shared objects built from Fortran sources contain RPATH, find a way to prevent that
|
||||
# scipy/integrate/_odepack
|
||||
# scipy/integrate/_quadpack
|
||||
# scipy/integrate/_test_odeint_banded
|
||||
# scipy/integrate/lsoda
|
||||
# scipy/integrate/vode
|
||||
# scipy/linalg/_fblas
|
||||
# scipy/linalg/_flapack
|
||||
# scipy/linalg/_flinalg
|
||||
# scipy/linalg/_interpolative
|
||||
# scipy/linalg/cython_blas
|
||||
# scipy/linalg/cython_lapack
|
||||
# scipy/odr/__odrpack
|
||||
# scipy/optimize/_lbfgsb
|
||||
# scipy/sparse/linalg/eigen/arpack/_arpack
|
||||
# scipy/sparse/linalg/isolve/_iterative
|
||||
# scipy/special/_ufuncs
|
||||
# scipy/special/cython_special
|
||||
|
||||
%install
|
||||
%py3_install
|
||||
# Some files got ambiguous python shebangs, we fix them after everything else is done
|
||||
@ -174,6 +193,10 @@ popd
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Mar 25 2021 Nikola Forró <nforro@redhat.com> - 1.6.2-1
|
||||
- New upstream release 1.6.2
|
||||
resolves: #1942896
|
||||
|
||||
* Thu Feb 18 2021 Nikola Forró <nforro@redhat.com> - 1.6.1-1
|
||||
- New upstream release 1.6.1
|
||||
resolves: #1929994
|
||||
|
@ -1,47 +0,0 @@
|
||||
From ea0a77cf8761a8b8636b93314139ed0fc0a9d1db Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Nikola=20Forr=C3=B3?= <nforro@redhat.com>
|
||||
Date: Wed, 30 Sep 2020 11:44:25 +0200
|
||||
Subject: [PATCH] TST: make a couple of tests expected to fail on 32-bit
|
||||
architectures
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
In TestConstructUtils.test_concatenate_int32_overflow
|
||||
and test_nnz_overflow, on a 32-bit architecture, in case
|
||||
check_free_memory() passes, ValueError is raised on an attempt
|
||||
to create a numpy array too large for a 32-bit architecture.
|
||||
|
||||
Signed-off-by: Nikola Forró <nforro@redhat.com>
|
||||
---
|
||||
scipy/sparse/tests/test_construct.py | 1 +
|
||||
scipy/sparse/tests/test_sparsetools.py | 1 +
|
||||
2 files changed, 2 insertions(+)
|
||||
|
||||
diff --git a/scipy/sparse/tests/test_construct.py b/scipy/sparse/tests/test_construct.py
|
||||
index 3a882c6cc..5a2b92667 100644
|
||||
--- a/scipy/sparse/tests/test_construct.py
|
||||
+++ b/scipy/sparse/tests/test_construct.py
|
||||
@@ -378,6 +378,7 @@ class TestConstructUtils(object):
|
||||
excinfo.match(r'Got blocks\[0,1\]\.shape\[0\] == 1, expected 2')
|
||||
|
||||
@pytest.mark.slow
|
||||
+ @pytest.mark.xfail_on_32bit("Can't create large array for test")
|
||||
def test_concatenate_int32_overflow(self):
|
||||
""" test for indptr overflow when concatenating matrices """
|
||||
check_free_memory(30000)
|
||||
diff --git a/scipy/sparse/tests/test_sparsetools.py b/scipy/sparse/tests/test_sparsetools.py
|
||||
index 0c208ef44..e95df1ba0 100644
|
||||
--- a/scipy/sparse/tests/test_sparsetools.py
|
||||
+++ b/scipy/sparse/tests/test_sparsetools.py
|
||||
@@ -61,6 +61,7 @@ def test_regression_std_vector_dtypes():
|
||||
|
||||
|
||||
@pytest.mark.slow
|
||||
+@pytest.mark.xfail_on_32bit("Can't create large array for test")
|
||||
def test_nnz_overflow():
|
||||
# Regression test for gh-7230 / gh-7871, checking that coo_todense
|
||||
# with nnz > int32max doesn't overflow.
|
||||
--
|
||||
2.26.2
|
||||
|
@ -1,40 +0,0 @@
|
||||
From eabd8ea25fe291665f37fd069a1c574cd30d12cc Mon Sep 17 00:00:00 2001
|
||||
From: Victor Stinner <vstinner@python.org>
|
||||
Date: Wed, 25 Nov 2020 11:41:15 +0100
|
||||
Subject: [PATCH] GH-13122: Skip factorial() float tests on Python 3.10
|
||||
|
||||
special.factorial() argument should be an array of integers.
|
||||
On Python 3.10, math.factorial() reject float.
|
||||
On Python 3.9, a DeprecationWarning is emitted.
|
||||
A numpy array casts all integers to float if the array contains a
|
||||
single NaN.
|
||||
---
|
||||
scipy/special/tests/test_basic.py | 8 ++++++++
|
||||
1 file changed, 8 insertions(+)
|
||||
|
||||
diff --git a/scipy/special/tests/test_basic.py b/scipy/special/tests/test_basic.py
|
||||
index 9b7260e8435..e2ae29812a5 100644
|
||||
--- a/scipy/special/tests/test_basic.py
|
||||
+++ b/scipy/special/tests/test_basic.py
|
||||
@@ -19,6 +19,7 @@
|
||||
|
||||
import itertools
|
||||
import platform
|
||||
+import sys
|
||||
|
||||
import numpy as np
|
||||
from numpy import (array, isnan, r_, arange, finfo, pi, sin, cos, tan, exp,
|
||||
@@ -1822,6 +1823,13 @@ def test_nan_inputs(self, x, exact):
|
||||
result = special.factorial(x, exact=exact)
|
||||
assert_(np.isnan(result))
|
||||
|
||||
+ # GH-13122: special.factorial() argument should be an array of integers.
|
||||
+ # On Python 3.10, math.factorial() reject float.
|
||||
+ # On Python 3.9, a DeprecationWarning is emitted.
|
||||
+ # A numpy array casts all integers to float if the array contains a
|
||||
+ # single NaN.
|
||||
+ @pytest.mark.skipif(sys.version_info >= (3, 10),
|
||||
+ reason="Python 3.10+ math.factorial() requires int")
|
||||
def test_mixed_nan_inputs(self):
|
||||
x = np.array([np.nan, 1, 2, 3, np.nan])
|
||||
with suppress_warnings() as sup:
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (scipy-1.6.1.tar.gz) = 778a7bca15bb880a3fd1c3d46ef753920335eca95fe5f2b8512883a2aec1bb8e9d8a8fdbf4fee90e823e31980408a51451cc53d4f10c632cd72faf2856c868c8
|
||||
SHA512 (scipy-1.6.2.tar.gz) = 18b03f32e8343c5a6c6148ac0bfd4b5f2cc9ff5f74d5d41761ae9e773d6af8774c7b09a3fcc47122864eccce1dbbc17e9325819885d3fc3ab2baf98e7d3befa4
|
||||
|
Loading…
Reference in New Issue
Block a user