Add latest patches from Debian

This commit is contained in:
Sérgio M. Basto 2020-08-05 01:07:50 +01:00
parent b3e0f475c4
commit bd4f8a8d08
7 changed files with 7819 additions and 4 deletions

46
cross.patch Normal file
View File

@ -0,0 +1,46 @@
--- schroot-1.6.10.orig/CMakeLists.txt
+++ schroot-1.6.10/CMakeLists.txt
@@ -96,7 +96,7 @@
# Configure testing
SET(CMAKE_REQUIRED_LIBRARIES_SAVE ${CMAKE_REQUIRED_LIBRARIES})
SET(CMAKE_REQUIRED_LIBRARIES ${CMAKE_REQUIRED_LIBRARIES} cppunit)
-check_cxx_source_runs(
+check_cxx_source_compiles(
"#include <cppunit/ui/text/TestRunner.h>
int main() {
--- schroot-1.6.10.orig/cmake/regex-checks.cmake
+++ schroot-1.6.10/cmake/regex-checks.cmake
@@ -3,7 +3,23 @@
function(regex_test namespace header library outvar outlib)
set(CMAKE_REQUIRED_LIBRARIES_SAVE ${CMAKE_REQUIRED_LIBRARIES})
set(CMAKE_REQUIRED_LIBRARIES ${CMAKE_REQUIRED_LIBRARIES} ${library})
- check_cxx_source_runs(
+
+ if (CMAKE_CROSSCOMPILING)
+ message(WARNING "Using simplified regex check for cross compilation. Assuming that regex implementations work correctly.")
+ check_cxx_source_compiles(
+"#include <${header}>
+
+int main() {
+ ${namespace} foo(\"x\");
+ ${namespace} bar(\"x\", ${namespace}::extended);
+ std::string test(\"x\");
+ ${namespace}_search(test, foo);
+ ${namespace}_match(test, foo);
+ return 0;
+}"
+${outvar})
+ else(CMAKE_CROSSCOMPILING)
+ check_cxx_source_runs(
"#include <${header}>
#include <iostream>
@@ -43,6 +59,7 @@
return 0;
}"
${outvar})
+ endif(CMAKE_CROSSCOMPILING)
set(CMAKE_REQUIRED_LIBRARIES ${CMAKE_REQUIRED_LIBRARIES_SAVE})

View File

@ -0,0 +1,119 @@
From: Chris Leick <c.leick@vollbio.de>
Date: Tue, 25 Nov 2014 21:34:20 +0100
Subject: schroot: [INTL:de] Updated German PO translation
There's a typo (marked with »FIXME« in the po file).
Date: Wed, 26 Nov 2014 15:26:13 +0000
From: Roger Leigh <rleigh@codelibre.net>
Many thanks, much appreciated!
I've committed this including the typo fix--thanks for pointing it out.
Bug-Debian: http://bugs.debian.org/771001
Origin: upstream
Index: schroot-1.6.10/man/dchroot.1.man
===================================================================
--- schroot-1.6.10.orig/man/dchroot.1.man
+++ schroot-1.6.10/man/dchroot.1.man
@@ -277,11 +277,11 @@ original \fBdchroot\fP by David Kimdon \
independent implementation.
.so copyright.man
.SH SEE ALSO
-.BR schroot (1),
.BR sbuild (1),
+.BR schroot (1),
.BR chroot (2),
-.BR schroot-setup (5),
.BR schroot.conf (5).
+.BR schroot-setup (5),
.\"#
.\"# The following sets edit modes for GNU EMACS
.\"# Local Variables:
Index: schroot-1.6.10/man/schroot.1.man
===================================================================
--- schroot-1.6.10.orig/man/schroot.1.man
+++ schroot-1.6.10/man/schroot.1.man
@@ -695,10 +695,10 @@ Directory used for unpacking file chroot
.BR dchroot (1),
.BR sbuild (1),
.BR chroot (2),
-.BR run\-parts (8),
+.BR schroot.conf (5).
.BR schroot\-setup (5),
.BR schroot\-faq (7),
-.BR schroot.conf (5).
+.BR run\-parts (8),
.\"#
.\"# The following sets edit modes for GNU EMACS
.\"# Local Variables:
Index: schroot-1.6.10/man/schroot.conf.5.man
===================================================================
--- schroot-1.6.10.orig/man/schroot.conf.5.man
+++ schroot-1.6.10/man/schroot.conf.5.man
@@ -154,7 +154,7 @@ Note that the script will be sourced onc
and must be idempotent.
.IP
All the default settings in this file are now settable using configuration keys
-in \fIschroot.conf\fP, as detailed below. Existing configuration should be
+in \fIschroot.conf\fP, as detailed below. Existing configurations should be
modified to use these keys in place of this file. See
.BR schroot-script-config (5)
for further details. This type of setup script configuration file is no longer
@@ -272,7 +272,7 @@ of updating. These additional options ar
\f[CBI]file=\fP\f[CI]filename\fP
The file containing the archived chroot environment (mandatory). This must be
a tar (tape archive), optionally compressed with gzip, bzip2, xz, lzop or lz4.
-The file extensions used to determine the type are are \fI.tar\fP,
+The file extensions used to determine the type are \fI.tar\fP,
\fI.tar.gz\fP, \fI.tar.bz2\fP, \fI.tar.xz\fP, \fI.tar.lzop\fP, \fI.tar.lz4\fP,
\fI.tgz\fP, \fI.tbz\fP, \fI.txz\fP, \fI.tzo\fP and \fI.tlz4\fP. This file must
be owned by the root user, and not be writable by other. Note that zip
Index: schroot-1.6.10/man/schroot-faq.7.man
===================================================================
--- schroot-1.6.10.orig/man/schroot-faq.7.man
+++ schroot-1.6.10/man/schroot-faq.7.man
@@ -104,7 +104,7 @@ In consequence, it's not possible to run
schroot. You can however do it if you create a session with
\fI\-\-begin\-session\fP and then run the d\[ae]mon with
\fI\-\-run\-session\fP. It's your responsibility to end the session with
-\fI\-\-end\-session\fP when the daemon has terminated or you no longer need it.
+\fI\-\-end\-session\fP when the d\[ae]mon has terminated or you no longer need it.
.SS How do I manually cleaning up a broken session?
Occasionally, it may be necessary to manually clean up sessions. If something
changes on your system which causes the setup scripts to fail when ending a
@@ -255,10 +255,10 @@ the schroot-1.4 branch.
.so copyright.man
.SH SEE ALSO
.BR dchroot (1),
-.BR schroot (1),
.BR sbuild (1),
-.BR schroot\-setup (5),
+.BR schroot (1),
.BR schroot.conf (5).
+.BR schroot\-setup (5),
.\"#
.\"# The following sets edit modes for GNU EMACS
.\"# Local Variables:
Index: schroot-1.6.10/man/schroot-setup.5.man
===================================================================
--- schroot-1.6.10.orig/man/schroot-setup.5.man
+++ schroot-1.6.10/man/schroot-setup.5.man
@@ -143,7 +143,6 @@ These variables are only set for directl
.TP
CHROOT_MOUNT_DEVICE
The device to mount containing the chroot.
-mounting.
.TP
CHROOT_MOUNT_OPTIONS
Options to pass to
@@ -169,7 +168,7 @@ Union filesystem underlay directory (rea
.TP
CHROOT_DEVICE
The device containing the chroot root filesystem. This is usually, but not
-necessarily, the device which will be mounted. For example, an LVM snapshot
+necessarily, the device which will be mounted. For example, for a LVM snapshot
this will be the original logical volume.
.SS LVM snapshot variables
.TP

View File

@ -2,7 +2,7 @@
Name: schroot
Version: 1.6.10
Release: 14%{?dist}
Release: 15%{?dist}
Summary: Execute commands in a chroot environment
License: GPLv3+
Url: https://tracker.debian.org/pkg/schroot
@ -25,6 +25,13 @@ Patch17: fix-test-suite-with-usrmerge.patch
Patch18: Unmount-everything-that-we-can-instead-of-giving-up.patch
Patch19: fix-killprocs.patch
Patch20: fix-bash-completion.patch
Patch21: fix_typos_in_schroot_manpage.patch
Patch22: update_czech_schroot_translation.patch
Patch23: update_french_schroot_manpage_translation_2018.patch
Patch24: update_german_schroot_manpage_translation_2018.patch
Patch25: zfs-snapshot-support.patch
Patch26: cross.patch
BuildRequires: gcc-c++
BuildRequires: pam-devel
@ -41,9 +48,9 @@ BuildRequires: groff
# from Debian control
BuildRequires: cmake3
BuildRequires: po4a >= 0.40
#BuildRequires: doxygen
#BuildRequires: graphviz
#BuildRequires: gtest
BuildRequires: doxygen
BuildRequires: graphviz
BuildRequires: gtest
%description
schroot allows users to execute commands or interactive shells in
@ -90,6 +97,12 @@ more functionality.
%patch18 -p1
%patch19 -p1
%patch20 -p1
%patch21 -p1
%patch22 -p1
%patch23 -p1
%patch24 -p1
%patch25 -p1
%patch26 -p1
%build
@ -191,6 +204,9 @@ fakeroot %ctest || :
%{_unitdir}/schroot.service
%changelog
* Wed Aug 05 2020 Sérgio Basto <sergio@serjux.com> - 1.6.10-15
- Add latest patches from Debian
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.10-14
- Second attempt - Rebuilt for
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

1194
zfs-snapshot-support.patch Normal file

File diff suppressed because it is too large Load Diff