Add more 2 patches from debian

Clean old files
This commit is contained in:
Sérgio M. Basto 2021-03-07 00:38:48 +00:00
parent 2b4a1aef43
commit 51e421d521
6 changed files with 54 additions and 215 deletions

26
binfmt-parent-dir.patch Normal file
View File

@ -0,0 +1,26 @@
Date: Sun, 28 Feb 2021 13:31:10 +0300
From: Michael Tokarev <mjt@tls.msk.ru>
Subject: schroot-setup: create parent directory for binfmt interpreter (#983087)
Bug-Debian: http://bugs.debian.org/983087
Currently schroot-setu (/etc/setup.d/15binfmt) mounts foreign binfmt
interpreter from host into the chroot. The problem is that the interpreter
could be in a directory which is not present in the chroot being created.
Ensure the parent directory exists before trying to bind-mount the
interpreter.
For qemu-based foreign chroots this whole thing isn't necessary with
the introduction of the F binfmt-misc flag (fix_binary), but it wont
hurt anyway. Also, the current method only works for binfmt-support
package and not for other ways to register binfmt-misc interpreters,
such as systemd way or direct/manual registration.
diff --git a/etc/setup.d/15binfmt b/etc/setup.d/15binfmt
index ad1776b2..ccd3776d 100644
--- a/etc/setup.d/15binfmt
+++ b/etc/setup.d/15binfmt
@@ -42,3 +42,3 @@ for emulator in $(update-binfmts --find "$shell"); do
else
- [ -e "$dst" ] || touch "$dst"
+ [ -e "$dst" ] || { mkdir -p "$(dirname "$dst")"; touch "$dst"; }
mount --bind "$emulator" "$dst"

20
reproducible-build.patch Normal file
View File

@ -0,0 +1,20 @@
From: Chris Lamb <lamby@debian.org>
Date: Thu, 24 Sep 2020 10:42:22 +0100
Subject: Make the documentation build reproducibly
---
man/CMakeLists.txt | 1 +
1 file changed, 1 insertion(+)
diff --git a/man/CMakeLists.txt b/man/CMakeLists.txt
index 44958cb..ecdd0fc 100644
--- a/man/CMakeLists.txt
+++ b/man/CMakeLists.txt
@@ -150,6 +150,7 @@ foreach(manpage_source ${manpage_sources})
add_custom_command(OUTPUT ${manpage}
COMMAND ${SOELIM_EXECUTABLE}
+ -r
${manpage_includes}
< "${manpage_source_file}"
> "${manpage}"

View File

@ -1,172 +0,0 @@
diff -Naur schroot-1.4.23.orig/sbuild/sbuild-custom-error.h schroot-1.4.23/sbuild/sbuild-custom-error.h
--- schroot-1.4.23.orig/sbuild/sbuild-custom-error.h 2011-06-11 17:54:38.186135440 +0200
+++ schroot-1.4.23/sbuild/sbuild-custom-error.h 2012-01-17 16:25:31.343780636 +0100
@@ -41,8 +41,8 @@
* @param error the error code.
*/
custom_error (error_type error):
- sbuild::error<T>(format_error(null(), null(), null(), error, null(), null(), null()),
- format_reason(null(), null(), null(), error, null(), null(), null()))
+ sbuild::error<T>(this->format_error(null(), null(), null(), error, null(), null(), null()),
+ this->format_reason(null(), null(), null(), error, null(), null(), null()))
{
}
@@ -55,8 +55,8 @@
template<typename C>
custom_error (C const& context,
error_type error):
- sbuild::error<T>(format_error(context, null(), null(), error, null(), null(), null()),
- format_reason(context, null(), null(), error, null(), null(), null()))
+ sbuild::error<T>(this->format_error(context, null(), null(), error, null(), null(), null()),
+ this->format_reason(context, null(), null(), error, null(), null(), null()))
{
}
@@ -69,8 +69,8 @@
template<typename D>
custom_error (error_type error,
D const& detail):
- sbuild::error<T>(format_error(null(), null(), null(), error, detail, null(), null()),
- format_reason(null(), null(), null(), error, detail, null(), null()))
+ sbuild::error<T>(this->format_error(null(), null(), null(), error, detail, null(), null()),
+ this->format_reason(null(), null(), null(), error, detail, null(), null()))
{
}
@@ -85,8 +85,8 @@
custom_error (error_type error,
D const& detail,
E const& detail2):
- sbuild::error<T>(format_error(null(), null(), null(), error, detail, detail2, null()),
- format_reason(null(), null(), null(), error, detail, detail2, null()))
+ sbuild::error<T>(this->format_error(null(), null(), null(), error, detail, detail2, null()),
+ this->format_reason(null(), null(), null(), error, detail, detail2, null()))
{
}
@@ -103,8 +103,8 @@
D const& detail,
E const& detail2,
F const& detail3):
- sbuild::error<T>(format_error(null(), null(), null(), error, detail, detail2, detail3),
- format_reason(null(), null(), null(), error, detail, detail2, detail3))
+ sbuild::error<T>(this->format_error(null(), null(), null(), error, detail, detail2, detail3),
+ this->format_reason(null(), null(), null(), error, detail, detail2, detail3))
{
}
@@ -119,8 +119,8 @@
custom_error (C const& context,
error_type error,
D const& detail):
- sbuild::error<T>(format_error(context, null(), null(), error, detail, null(), null()),
- format_reason(context, null(), null(), error, detail, null(), null()))
+ sbuild::error<T>(this->format_error(context, null(), null(), error, detail, null(), null()),
+ this->format_reason(context, null(), null(), error, detail, null(), null()))
{
}
@@ -155,8 +155,8 @@
D const& context2,
error_type error,
E const& detail):
- sbuild::error<T>(format_error(context1, context2, null(), error, detail, null(), null()),
- format_reason(context1, context2, null(), error, detail, null(), null()))
+ sbuild::error<T>(this->format_error(context1, context2, null(), error, detail, null(), null()),
+ this->format_reason(context1, context2, null(), error, detail, null(), null()))
{
}
diff -Naur schroot-1.4.23.orig/sbuild/sbuild-nostream.h schroot-1.4.23/sbuild/sbuild-nostream.h
--- schroot-1.4.23.orig/sbuild/sbuild-nostream.h 2011-05-27 18:01:47.134846621 +0200
+++ schroot-1.4.23/sbuild/sbuild-nostream.h 2012-01-17 15:56:54.369906387 +0100
@@ -58,7 +58,7 @@
std::basic_ios<cT, traits>(&nbuf),
std::basic_ostream<cT, traits>(&nbuf)
{
- init(&nbuf);
+ this->init(&nbuf);
}
private:
diff -Naur schroot-1.4.23.orig/sbuild/sbuild-parse-error.h schroot-1.4.23/sbuild/sbuild-parse-error.h
--- schroot-1.4.23.orig/sbuild/sbuild-parse-error.h 2011-06-11 17:54:38.190135491 +0200
+++ schroot-1.4.23/sbuild/sbuild-parse-error.h 2012-01-17 15:48:44.742942465 +0100
@@ -46,8 +46,8 @@
template<typename C>
parse_error (C const& context,
error_type error):
- sbuild::error<T>(format_error(context, null(), null(), error, null(), null(), null()),
- format_reason(context, null(), null(), error, null(), null(), null()))
+ sbuild::error<T>(this->format_error(context, null(), null(), error, null(), null(), null()),
+ this->format_reason(context, null(), null(), error, null(), null(), null()))
{
}
@@ -60,8 +60,8 @@
template<typename D>
parse_error (error_type error,
D const& detail):
- sbuild::error<T>(format_error(null(), null(), null(), error, detail, null(), null()),
- format_reason(null(), null(), null(), error, detail, null(), null()))
+ sbuild::error<T>(this->format_error(null(), null(), null(), error, detail, null(), null()),
+ this->format_reason(null(), null(), null(), error, detail, null(), null()))
{
}
@@ -76,8 +76,8 @@
parse_error (size_t line,
error_type error,
D const& detail):
- sbuild::error<T>(format_error(line, null(), null(), error, detail, null(), null()),
- format_reason(line, null(), null(), error, detail, null(), null()))
+ sbuild::error<T>(this->format_error(line, null(), null(), error, detail, null(), null()),
+ this->format_reason(line, null(), null(), error, detail, null(), null()))
{
}
@@ -94,8 +94,8 @@
std::string const& group,
error_type error,
D const& detail):
- sbuild::error<T>(format_error(line, group, null(), error, detail, null(), null()),
- format_reason(line, group, null(), error, detail, null(), null()))
+ sbuild::error<T>(this->format_error(line, group, null(), error, detail, null(), null()),
+ this->format_reason(line, group, null(), error, detail, null(), null()))
{
}
@@ -114,8 +114,8 @@
std::string const& key,
error_type error,
D const& detail):
- sbuild::error<T>(format_error(line, group, key, error, detail, null(), null()),
- format_reason(line, group, key, error, detail, null(), null()))
+ sbuild::error<T>(this->format_error(line, group, key, error, detail, null(), null()),
+ this->format_reason(line, group, key, error, detail, null(), null()))
{
}
@@ -130,8 +130,8 @@
parse_error (std::string const& group,
error_type error,
D const& detail):
- sbuild::error<T>(format_error(group, null(), null(), error, detail, null(), null()),
- format_reason(group, null(), null(), error, detail, null(), null()))
+ sbuild::error<T>(this->format_error(group, null(), null(), error, detail, null(), null()),
+ this->format_reason(group, null(), null(), error, detail, null(), null()))
{
}
@@ -148,8 +148,8 @@
std::string const& key,
error_type error,
D const& detail):
- sbuild::error<T>(format_error(group, key, null(), error, detail, null(), null()),
- format_reason(group, key, null(), error, detail, null(), null()))
+ sbuild::error<T>(this->format_error(group, key, null(), error, detail, null(), null()),
+ this->format_reason(group, key, null(), error, detail, null(), null()))
{
}

View File

@ -1,10 +0,0 @@
--- bin/schroot/mount-defaults.orig 2009-05-05 10:26:42.000000000 -0700
+++ bin/schroot/mount-defaults 2009-05-05 10:26:59.000000000 -0700
@@ -5,6 +5,6 @@
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/pts /dev/pts none rw,bind 0 0
-tmpfs /dev/shm tmpfs defaults 0 0
+/dev/shm /dev/shm tmpfs defaults 0 0
/home /home none rw,bind 0 0
/tmp /tmp none rw,bind 0 0

View File

@ -1,31 +0,0 @@
--- configure.orig 2010-07-19 09:35:21.000000000 -0700
+++ configure 2010-07-19 09:36:00.000000000 -0700
@@ -18238,7 +18238,7 @@
int
main ()
{
-boost::program_options::variables_map::variables_map dummy()
+boost::program_options::variables_map dummy()
;
return 0;
}
@@ -18255,7 +18255,7 @@
int
main ()
{
-boost::program_options::variables_map::variables_map dummy()
+boost::program_options::variables_map dummy()
;
return 0;
}
--- configure.ac.orig 2010-07-19 09:35:28.000000000 -0700
+++ configure.ac 2010-07-19 09:36:16.000000000 -0700
@@ -529,7 +529,7 @@
saved_LIBS="${LIBS}"
LIBS="${saved_LIBS} -lboost_program_options"
define([testprog], [AC_LANG_PROGRAM([#include <boost/program_options.hpp>],
- [boost::program_options::variables_map::variables_map dummy()])])
+ [boost::program_options::variables_map dummy()])])
AC_LINK_IFELSE(testprog,
[AC_MSG_RESULT([yes])
BOOST_LIBS="${BOOST_LIBS} -lboost_program_options"],

View File

@ -2,7 +2,7 @@
Name: schroot
Version: 1.6.10
Release: 17%{?dist}
Release: 18%{?dist}
Summary: Execute commands in a chroot environment
License: GPLv3+
Url: https://tracker.debian.org/pkg/schroot
@ -12,6 +12,7 @@ Source2: schroot.default
Patch0: schroot-pam.patch
Patch1: schroot-default-config-path.patch
Patch3: schroot-gcc8-assert-fix.patch
Patch4: schroot-po4a.patch
#Debian patches
Patch10: Add-support-for-more-compression-formats.patch
@ -31,7 +32,8 @@ Patch23: update_french_schroot_manpage_translation_2018.patch
Patch24: update_german_schroot_manpage_translation_2018.patch
Patch25: zfs-snapshot-support.patch
Patch26: cross.patch
Patch27: schroot-po4a.patch
Patch27: binfmt-parent-dir.patch
Patch28: reproducible-build.patch
BuildRequires: gcc-c++
@ -184,6 +186,10 @@ fakeroot %ctest || :
%{_unitdir}/schroot.service
%changelog
* Sun Mar 07 2021 Sérgio Basto <sergio@serjux.com> - 1.6.10-18
- Add more 2 patches from debian
- Clean old files
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.10-17
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild