Add patch from Debian to fix tight loop caused by ncurses 6 honouring
"notimeout" setting, rhbz#1357902
This commit is contained in:
parent
b1f03b195e
commit
32de57fa7c
24
nonotimeout-ncurses6.patch
Normal file
24
nonotimeout-ncurses6.patch
Normal file
@ -0,0 +1,24 @@
|
||||
--- sc/lex.c.orig 2016-07-19 16:34:21.047629536 +0100
|
||||
+++ sc/lex.c 2016-07-19 16:36:20.889308966 +0100
|
||||
@@ -650,21 +650,18 @@
|
||||
initkbd()
|
||||
{
|
||||
keypad(stdscr, TRUE);
|
||||
- notimeout(stdscr,TRUE);
|
||||
}
|
||||
|
||||
void
|
||||
kbd_again()
|
||||
{
|
||||
keypad(stdscr, TRUE);
|
||||
- notimeout(stdscr,TRUE);
|
||||
}
|
||||
|
||||
void
|
||||
resetkbd()
|
||||
{
|
||||
keypad(stdscr, FALSE);
|
||||
- notimeout(stdscr, FALSE);
|
||||
}
|
||||
|
||||
int
|
9
sc.spec
9
sc.spec
@ -1,6 +1,6 @@
|
||||
Name: sc
|
||||
Version: 7.16
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
Summary: Spreadsheet Calculator
|
||||
|
||||
License: Public Domain
|
||||
@ -16,6 +16,9 @@ Patch2: call_function_not_take_its_address.patch
|
||||
# Patch for http://fedoraproject.org/wiki/Changes/FormatSecurity
|
||||
Patch3: format_security_fixes.patch
|
||||
|
||||
# https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg1400274.html
|
||||
Patch4: nonotimeout-ncurses6.patch
|
||||
|
||||
BuildRequires: bison
|
||||
BuildRequires: ncurses-devel
|
||||
|
||||
@ -53,6 +56,10 @@ install -m 0644 tutorial.sc %{buildroot}%{_datadir}/sc
|
||||
%{_datadir}/sc
|
||||
|
||||
%changelog
|
||||
* Tue Jul 19 2016 Mat Booth <mat.booth@redhat.com> - 7.16-4
|
||||
- Add patch from Debian to fix tight loop caused by ncurses 6 honouring
|
||||
"notimeout" setting, rhbz#1357902
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 7.16-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user