Update to Samba 4.7.0rc3
Guenther
This commit is contained in:
parent
88a6ab9186
commit
be2516f82a
2
.gitignore
vendored
2
.gitignore
vendored
@ -95,3 +95,5 @@ samba-3.6.0pre1.tar.gz
|
||||
/samba-4.6.5.tar.asc
|
||||
/samba-4.7.0rc1.tar.xz
|
||||
/samba-4.7.0rc1.tar.asc
|
||||
/samba-4.7.0rc3.tar.xz
|
||||
/samba-4.7.0rc3.tar.asc
|
||||
|
@ -1,47 +0,0 @@
|
||||
From 0d674fcf95399292b4a2003df8e2a28909b562a2 Mon Sep 17 00:00:00 2001
|
||||
From: Andreas Schneider <asn@samba.org>
|
||||
Date: Thu, 6 Jul 2017 07:44:28 +0200
|
||||
Subject: [PATCH] waf: Do not install _ldb_text.py if we have system libldb
|
||||
|
||||
_ldb_text.py is installed as part of the ldb package and also if you
|
||||
compile Samba with the system ldb version. This way we have have the
|
||||
file twice in the same location and run into file confilcts.
|
||||
|
||||
This has already been fixed in the past by
|
||||
60dc26bfe1573265dcbd87b9dd3439f945e57d97
|
||||
|
||||
BUG: https://bugzilla.samba.org/show_bug.cgi?id=12882
|
||||
|
||||
Signed-off-by: Andreas Schneider <asn@samba.org>
|
||||
---
|
||||
lib/ldb/wscript | 13 ++++++++-----
|
||||
1 file changed, 8 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/lib/ldb/wscript b/lib/ldb/wscript
|
||||
index 7f81fe3..b4ae62a 100644
|
||||
--- a/lib/ldb/wscript
|
||||
+++ b/lib/ldb/wscript
|
||||
@@ -177,12 +177,15 @@ def build(bld):
|
||||
realname='ldb.so',
|
||||
cflags='-DPACKAGE_VERSION=\"%s\"' % VERSION)
|
||||
|
||||
- for env in bld.gen_python_environments(['PKGCONFIGDIR']):
|
||||
- bld.SAMBA_SCRIPT('_ldb_text.py',
|
||||
- pattern='_ldb_text.py',
|
||||
- installdir='python')
|
||||
+ # Do only install this file as part of the Samba build if we do not
|
||||
+ # use the system libldb!
|
||||
+ if not bld.CONFIG_SET('USING_SYSTEM_PYLDB_UTIL'):
|
||||
+ for env in bld.gen_python_environments(['PKGCONFIGDIR']):
|
||||
+ bld.SAMBA_SCRIPT('_ldb_text.py',
|
||||
+ pattern='_ldb_text.py',
|
||||
+ installdir='python')
|
||||
|
||||
- bld.INSTALL_FILES('${PYTHONARCHDIR}', '_ldb_text.py')
|
||||
+ bld.INSTALL_FILES('${PYTHONARCHDIR}', '_ldb_text.py')
|
||||
|
||||
if not bld.CONFIG_SET('USING_SYSTEM_LDB'):
|
||||
if bld.is_install:
|
||||
--
|
||||
2.9.4
|
||||
|
@ -1,344 +0,0 @@
|
||||
From 6793948ff3224a23768c4e525867c3201365122e Mon Sep 17 00:00:00 2001
|
||||
From: Alexander Bokovoy <ab@samba.org>
|
||||
Date: Thu, 13 Jul 2017 15:37:47 +0300
|
||||
Subject: [PATCH 1/2] py3: Make sure to specify METH_VARARGS together with
|
||||
METH_KEYWORDS
|
||||
|
||||
A Python 3 bug https://bugs.python.org/issue15657 explains that one should
|
||||
always use METH_VARARGS|METH_KEYWORDS when defining a function rather
|
||||
than a lonely METH_KEYWORDS. We had only one definition like this in
|
||||
Samba and it was the one that affects FreeIPA when running in Python 3
|
||||
mode.
|
||||
|
||||
BUG: https://bugzilla.samba.org/show_bug.cgi?id=12905
|
||||
|
||||
Signed-off-by: Alexander Bokovoy <ab@samba.org>
|
||||
Reviewed-by: Andrew Bartlett <abartlet@samba.org>
|
||||
(cherry picked from commit 303a52d8d48e4f5754448a876fedc98d7829e2bb)
|
||||
---
|
||||
source4/libnet/py_net.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/source4/libnet/py_net.c b/source4/libnet/py_net.c
|
||||
index 78e60f6d6a6..7ddee2df92c 100644
|
||||
--- a/source4/libnet/py_net.c
|
||||
+++ b/source4/libnet/py_net.c
|
||||
@@ -745,7 +745,7 @@ static PyMethodDef net_obj_methods[] = {
|
||||
{"replicate_init", (PyCFunction)py_net_replicate_init, METH_VARARGS|METH_KEYWORDS, py_net_replicate_init_doc},
|
||||
{"replicate_chunk", (PyCFunction)py_net_replicate_chunk, METH_VARARGS|METH_KEYWORDS, py_net_replicate_chunk_doc},
|
||||
{"replicate_decrypt", (PyCFunction)py_net_replicate_decrypt, METH_VARARGS|METH_KEYWORDS, py_net_replicate_decrypt_doc},
|
||||
- {"finddc", (PyCFunction)py_net_finddc, METH_KEYWORDS, py_net_finddc_doc},
|
||||
+ {"finddc", (PyCFunction)py_net_finddc, METH_VARARGS|METH_KEYWORDS, py_net_finddc_doc},
|
||||
{ NULL }
|
||||
};
|
||||
|
||||
--
|
||||
2.13.0
|
||||
|
||||
|
||||
From 02a40c970ccf3d6e9fb3a3c3b2052da93ff118a0 Mon Sep 17 00:00:00 2001
|
||||
From: Alexander Bokovoy <ab@samba.org>
|
||||
Date: Thu, 13 Jul 2017 14:49:12 +0300
|
||||
Subject: [PATCH 2/2] Build py3 versions of other rpc modules
|
||||
|
||||
BUG: https://bugzilla.samba.org/show_bug.cgi?id=12905
|
||||
|
||||
Signed-off-by: Alexander Bokovoy <ab@samba.org>
|
||||
Reviewed-by: Andrew Bartlett <abartlet@samba.org>
|
||||
|
||||
Autobuild-User(master): Alexander Bokovoy <ab@samba.org>
|
||||
Autobuild-Date(master): Fri Jul 14 11:36:53 CEST 2017 on sn-devel-144
|
||||
|
||||
(cherry picked from commit 0ed918ef5276c459d46c9e77c9e9d84bc41d4b14)
|
||||
---
|
||||
source4/librpc/wscript_build | 242 +++++++++++++++++++++----------------------
|
||||
1 file changed, 121 insertions(+), 121 deletions(-)
|
||||
|
||||
diff --git a/source4/librpc/wscript_build b/source4/librpc/wscript_build
|
||||
index a14215bc5ac..e341432fa14 100644
|
||||
--- a/source4/librpc/wscript_build
|
||||
+++ b/source4/librpc/wscript_build
|
||||
@@ -252,159 +252,159 @@ for env in bld.gen_python_environments():
|
||||
realname='samba/dcerpc/ntlmssp.so'
|
||||
)
|
||||
|
||||
-bld.SAMBA_PYTHON('python_srvsvc',
|
||||
- source='../../librpc/gen_ndr/py_srvsvc.c',
|
||||
- deps='RPC_NDR_SRVSVC pytalloc-util pyrpc_util',
|
||||
- realname='samba/dcerpc/srvsvc.so'
|
||||
- )
|
||||
-
|
||||
-bld.SAMBA_PYTHON('python_echo',
|
||||
- source='../../librpc/gen_ndr/py_echo.c',
|
||||
- deps='RPC_NDR_ECHO pytalloc-util pyrpc_util',
|
||||
- realname='samba/dcerpc/echo.so'
|
||||
- )
|
||||
+ bld.SAMBA_PYTHON('python_srvsvc',
|
||||
+ source='../../librpc/gen_ndr/py_srvsvc.c',
|
||||
+ deps='RPC_NDR_SRVSVC pytalloc-util pyrpc_util',
|
||||
+ realname='samba/dcerpc/srvsvc.so'
|
||||
+ )
|
||||
+
|
||||
+ bld.SAMBA_PYTHON('python_echo',
|
||||
+ source='../../librpc/gen_ndr/py_echo.c',
|
||||
+ deps='RPC_NDR_ECHO pytalloc-util pyrpc_util',
|
||||
+ realname='samba/dcerpc/echo.so'
|
||||
+ )
|
||||
|
||||
-bld.SAMBA_PYTHON('python_dns',
|
||||
- source='../../librpc/gen_ndr/py_dns.c',
|
||||
- deps='NDR_DNS pytalloc-util pyrpc_util',
|
||||
- realname='samba/dcerpc/dns.so'
|
||||
- )
|
||||
+ bld.SAMBA_PYTHON('python_dns',
|
||||
+ source='../../librpc/gen_ndr/py_dns.c',
|
||||
+ deps='NDR_DNS pytalloc-util pyrpc_util',
|
||||
+ realname='samba/dcerpc/dns.so'
|
||||
+ )
|
||||
|
||||
-bld.SAMBA_PYTHON('python_winreg',
|
||||
- source='../../librpc/gen_ndr/py_winreg.c',
|
||||
- deps='RPC_NDR_WINREG pytalloc-util pyrpc_util',
|
||||
- realname='samba/dcerpc/winreg.so'
|
||||
- )
|
||||
+ bld.SAMBA_PYTHON('python_winreg',
|
||||
+ source='../../librpc/gen_ndr/py_winreg.c',
|
||||
+ deps='RPC_NDR_WINREG pytalloc-util pyrpc_util',
|
||||
+ realname='samba/dcerpc/winreg.so'
|
||||
+ )
|
||||
|
||||
|
||||
-bld.SAMBA_PYTHON('python_initshutdown',
|
||||
- source='../../librpc/gen_ndr/py_initshutdown.c',
|
||||
- deps='RPC_NDR_INITSHUTDOWN pytalloc-util pyrpc_util',
|
||||
- realname='samba/dcerpc/initshutdown.so'
|
||||
- )
|
||||
+ bld.SAMBA_PYTHON('python_initshutdown',
|
||||
+ source='../../librpc/gen_ndr/py_initshutdown.c',
|
||||
+ deps='RPC_NDR_INITSHUTDOWN pytalloc-util pyrpc_util',
|
||||
+ realname='samba/dcerpc/initshutdown.so'
|
||||
+ )
|
||||
|
||||
|
||||
-bld.SAMBA_PYTHON('python_epmapper',
|
||||
- source='../../librpc/gen_ndr/py_epmapper.c',
|
||||
- deps='dcerpc pytalloc-util pyrpc_util',
|
||||
- realname='samba/dcerpc/epmapper.so'
|
||||
- )
|
||||
+ bld.SAMBA_PYTHON('python_epmapper',
|
||||
+ source='../../librpc/gen_ndr/py_epmapper.c',
|
||||
+ deps='dcerpc pytalloc-util pyrpc_util',
|
||||
+ realname='samba/dcerpc/epmapper.so'
|
||||
+ )
|
||||
|
||||
|
||||
-bld.SAMBA_PYTHON('python_mgmt',
|
||||
- source='../../librpc/gen_ndr/py_mgmt.c',
|
||||
- deps='pytalloc-util dcerpc pyrpc_util',
|
||||
- realname='samba/dcerpc/mgmt.so'
|
||||
- )
|
||||
+ bld.SAMBA_PYTHON('python_mgmt',
|
||||
+ source='../../librpc/gen_ndr/py_mgmt.c',
|
||||
+ deps='pytalloc-util dcerpc pyrpc_util',
|
||||
+ realname='samba/dcerpc/mgmt.so'
|
||||
+ )
|
||||
|
||||
|
||||
-bld.SAMBA_PYTHON('python_atsvc',
|
||||
- source='../../librpc/gen_ndr/py_atsvc.c',
|
||||
- deps='RPC_NDR_ATSVC pytalloc-util pyrpc_util',
|
||||
- realname='samba/dcerpc/atsvc.so'
|
||||
- )
|
||||
+ bld.SAMBA_PYTHON('python_atsvc',
|
||||
+ source='../../librpc/gen_ndr/py_atsvc.c',
|
||||
+ deps='RPC_NDR_ATSVC pytalloc-util pyrpc_util',
|
||||
+ realname='samba/dcerpc/atsvc.so'
|
||||
+ )
|
||||
|
||||
|
||||
-bld.SAMBA_PYTHON('python_svcctl',
|
||||
- source='../../librpc/gen_ndr/py_svcctl.c',
|
||||
- deps='RPC_NDR_SVCCTL pytalloc-util pyrpc_util',
|
||||
- realname='samba/dcerpc/svcctl.so'
|
||||
- )
|
||||
+ bld.SAMBA_PYTHON('python_svcctl',
|
||||
+ source='../../librpc/gen_ndr/py_svcctl.c',
|
||||
+ deps='RPC_NDR_SVCCTL pytalloc-util pyrpc_util',
|
||||
+ realname='samba/dcerpc/svcctl.so'
|
||||
+ )
|
||||
|
||||
|
||||
-bld.SAMBA_PYTHON('python_wkssvc',
|
||||
- source='../../librpc/gen_ndr/py_wkssvc.c',
|
||||
- deps='RPC_NDR_WKSSVC pytalloc-util pyrpc_util',
|
||||
- realname='samba/dcerpc/wkssvc.so'
|
||||
- )
|
||||
+ bld.SAMBA_PYTHON('python_wkssvc',
|
||||
+ source='../../librpc/gen_ndr/py_wkssvc.c',
|
||||
+ deps='RPC_NDR_WKSSVC pytalloc-util pyrpc_util',
|
||||
+ realname='samba/dcerpc/wkssvc.so'
|
||||
+ )
|
||||
|
||||
|
||||
-bld.SAMBA_PYTHON('python_dfs',
|
||||
- source='../../librpc/gen_ndr/py_dfs.c',
|
||||
- deps='RPC_NDR_DFS pytalloc-util pyrpc_util',
|
||||
- realname='samba/dcerpc/dfs.so'
|
||||
- )
|
||||
+ bld.SAMBA_PYTHON('python_dfs',
|
||||
+ source='../../librpc/gen_ndr/py_dfs.c',
|
||||
+ deps='RPC_NDR_DFS pytalloc-util pyrpc_util',
|
||||
+ realname='samba/dcerpc/dfs.so'
|
||||
+ )
|
||||
|
||||
-bld.SAMBA_PYTHON('python_dcerpc_dcerpc',
|
||||
- source='../../librpc/gen_ndr/py_dcerpc.c',
|
||||
- deps='NDR_DCERPC pytalloc-util pyrpc_util',
|
||||
- realname='samba/dcerpc/dcerpc.so'
|
||||
- )
|
||||
+ bld.SAMBA_PYTHON('python_dcerpc_dcerpc',
|
||||
+ source='../../librpc/gen_ndr/py_dcerpc.c',
|
||||
+ deps='NDR_DCERPC pytalloc-util pyrpc_util',
|
||||
+ realname='samba/dcerpc/dcerpc.so'
|
||||
+ )
|
||||
|
||||
-bld.SAMBA_PYTHON('python_unixinfo',
|
||||
- source='../../librpc/gen_ndr/py_unixinfo.c',
|
||||
- deps='RPC_NDR_UNIXINFO pytalloc-util pyrpc_util',
|
||||
- realname='samba/dcerpc/unixinfo.so'
|
||||
- )
|
||||
+ bld.SAMBA_PYTHON('python_unixinfo',
|
||||
+ source='../../librpc/gen_ndr/py_unixinfo.c',
|
||||
+ deps='RPC_NDR_UNIXINFO pytalloc-util pyrpc_util',
|
||||
+ realname='samba/dcerpc/unixinfo.so'
|
||||
+ )
|
||||
|
||||
|
||||
-bld.SAMBA_PYTHON('python_irpc',
|
||||
- source='gen_ndr/py_irpc.c',
|
||||
- deps='RPC_NDR_IRPC pytalloc-util pyrpc_util',
|
||||
- realname='samba/dcerpc/irpc.so'
|
||||
- )
|
||||
+ bld.SAMBA_PYTHON('python_irpc',
|
||||
+ source='gen_ndr/py_irpc.c',
|
||||
+ deps='RPC_NDR_IRPC pytalloc-util pyrpc_util',
|
||||
+ realname='samba/dcerpc/irpc.so'
|
||||
+ )
|
||||
|
||||
-bld.SAMBA_PYTHON('python_server_id',
|
||||
- source='../../librpc/gen_ndr/py_server_id.c',
|
||||
- deps='RPC_NDR_SERVER_ID pytalloc-util pyrpc_util',
|
||||
- realname='samba/dcerpc/server_id.so'
|
||||
- )
|
||||
+ bld.SAMBA_PYTHON('python_server_id',
|
||||
+ source='../../librpc/gen_ndr/py_server_id.c',
|
||||
+ deps='RPC_NDR_SERVER_ID pytalloc-util pyrpc_util',
|
||||
+ realname='samba/dcerpc/server_id.so'
|
||||
+ )
|
||||
|
||||
-bld.SAMBA_PYTHON('python_winbind',
|
||||
- source='../../librpc/gen_ndr/py_winbind.c',
|
||||
- deps='RPC_NDR_WINBIND pytalloc-util pyrpc_util python_netlogon',
|
||||
- realname='samba/dcerpc/winbind.so'
|
||||
- )
|
||||
+ bld.SAMBA_PYTHON('python_winbind',
|
||||
+ source='../../librpc/gen_ndr/py_winbind.c',
|
||||
+ deps='RPC_NDR_WINBIND pytalloc-util pyrpc_util python_netlogon',
|
||||
+ realname='samba/dcerpc/winbind.so'
|
||||
+ )
|
||||
|
||||
-bld.SAMBA_PYTHON('python_idmap',
|
||||
- source='../../librpc/gen_ndr/py_idmap.c',
|
||||
- deps='NDR_IDMAP pytalloc-util pyrpc_util',
|
||||
- realname='samba/dcerpc/idmap.so'
|
||||
- )
|
||||
+ bld.SAMBA_PYTHON('python_idmap',
|
||||
+ source='../../librpc/gen_ndr/py_idmap.c',
|
||||
+ deps='NDR_IDMAP pytalloc-util pyrpc_util',
|
||||
+ realname='samba/dcerpc/idmap.so'
|
||||
+ )
|
||||
|
||||
|
||||
-bld.SAMBA_PYTHON('python_drsuapi',
|
||||
- source='../../librpc/gen_ndr/py_drsuapi.c',
|
||||
- deps='RPC_NDR_DRSUAPI pytalloc-util pyrpc_util',
|
||||
- realname='samba/dcerpc/drsuapi.so'
|
||||
- )
|
||||
+ bld.SAMBA_PYTHON('python_drsuapi',
|
||||
+ source='../../librpc/gen_ndr/py_drsuapi.c',
|
||||
+ deps='RPC_NDR_DRSUAPI pytalloc-util pyrpc_util',
|
||||
+ realname='samba/dcerpc/drsuapi.so'
|
||||
+ )
|
||||
|
||||
-bld.SAMBA_PYTHON('python_dcerpc_dnsp',
|
||||
- source='../../librpc/gen_ndr/py_dnsp.c',
|
||||
- deps='pytalloc-util pyrpc_util NDR_SECURITY NDR_DNSP',
|
||||
- realname='samba/dcerpc/dnsp.so'
|
||||
- )
|
||||
+ bld.SAMBA_PYTHON('python_dcerpc_dnsp',
|
||||
+ source='../../librpc/gen_ndr/py_dnsp.c',
|
||||
+ deps='pytalloc-util pyrpc_util NDR_SECURITY NDR_DNSP',
|
||||
+ realname='samba/dcerpc/dnsp.so'
|
||||
+ )
|
||||
|
||||
|
||||
-bld.SAMBA_PYTHON('python_dcerpc_xattr',
|
||||
- source='../../librpc/gen_ndr/py_xattr.c',
|
||||
- deps='pytalloc-util pyrpc_util RPC_NDR_XATTR',
|
||||
- realname='samba/dcerpc/xattr.so'
|
||||
- )
|
||||
+ bld.SAMBA_PYTHON('python_dcerpc_xattr',
|
||||
+ source='../../librpc/gen_ndr/py_xattr.c',
|
||||
+ deps='pytalloc-util pyrpc_util RPC_NDR_XATTR',
|
||||
+ realname='samba/dcerpc/xattr.so'
|
||||
+ )
|
||||
|
||||
-bld.SAMBA_PYTHON('python_dcerpc_idmap',
|
||||
- source='../../librpc/gen_ndr/py_idmap.c',
|
||||
- deps='pytalloc-util pyrpc_util RPC_NDR_XATTR',
|
||||
- realname='samba/dcerpc/idmap.so'
|
||||
- )
|
||||
+ bld.SAMBA_PYTHON('python_dcerpc_idmap',
|
||||
+ source='../../librpc/gen_ndr/py_idmap.c',
|
||||
+ deps='pytalloc-util pyrpc_util RPC_NDR_XATTR',
|
||||
+ realname='samba/dcerpc/idmap.so'
|
||||
+ )
|
||||
|
||||
-bld.SAMBA_PYTHON('python_dnsserver',
|
||||
- source='../../librpc/gen_ndr/py_dnsserver.c',
|
||||
- deps='RPC_NDR_DNSSERVER pytalloc-util pyrpc_util',
|
||||
- realname='samba/dcerpc/dnsserver.so'
|
||||
- )
|
||||
+ bld.SAMBA_PYTHON('python_dnsserver',
|
||||
+ source='../../librpc/gen_ndr/py_dnsserver.c',
|
||||
+ deps='RPC_NDR_DNSSERVER pytalloc-util pyrpc_util',
|
||||
+ realname='samba/dcerpc/dnsserver.so'
|
||||
+ )
|
||||
|
||||
-bld.SAMBA_PYTHON('python_dcerpc_smb_acl',
|
||||
- source='../../librpc/gen_ndr/py_smb_acl.c',
|
||||
- deps='pytalloc-util pyrpc_util',
|
||||
- realname='samba/dcerpc/smb_acl.so'
|
||||
- )
|
||||
+ bld.SAMBA_PYTHON('python_dcerpc_smb_acl',
|
||||
+ source='../../librpc/gen_ndr/py_smb_acl.c',
|
||||
+ deps='pytalloc-util pyrpc_util',
|
||||
+ realname='samba/dcerpc/smb_acl.so'
|
||||
+ )
|
||||
|
||||
-bld.SAMBA_PYTHON('dcerpc_python_messaging',
|
||||
- source='../../librpc/gen_ndr/py_messaging.c',
|
||||
- deps='pytalloc-util pyrpc_util',
|
||||
- realname='samba/dcerpc/messaging.so'
|
||||
- )
|
||||
+ bld.SAMBA_PYTHON('dcerpc_python_messaging',
|
||||
+ source='../../librpc/gen_ndr/py_messaging.c',
|
||||
+ deps='pytalloc-util pyrpc_util',
|
||||
+ realname='samba/dcerpc/messaging.so'
|
||||
+ )
|
||||
|
||||
if bld.PYTHON_BUILD_IS_ENABLED():
|
||||
bld.SAMBA_SCRIPT('python_dcerpc_init',
|
||||
--
|
||||
2.13.0
|
||||
|
@ -1,25 +0,0 @@
|
||||
From 26183cf4904d76962b218401fe07a9f7642e05ff Mon Sep 17 00:00:00 2001
|
||||
From: Andreas Schneider <asn@samba.org>
|
||||
Date: Wed, 5 Jul 2017 08:59:23 +0200
|
||||
Subject: [PATCH] unittests: Add missing stdint.h include
|
||||
|
||||
Signed-off-by: Andreas Schneider <asn@samba.org>
|
||||
---
|
||||
testsuite/unittests/test_sambafs_srv_pipe.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/testsuite/unittests/test_sambafs_srv_pipe.c b/testsuite/unittests/test_sambafs_srv_pipe.c
|
||||
index 641e99d..553f530 100644
|
||||
--- a/testsuite/unittests/test_sambafs_srv_pipe.c
|
||||
+++ b/testsuite/unittests/test_sambafs_srv_pipe.c
|
||||
@@ -2,6 +2,7 @@
|
||||
#include <stdarg.h>
|
||||
#include <stddef.h>
|
||||
#include <setjmp.h>
|
||||
+#include <stdint.h>
|
||||
#include <unistd.h>
|
||||
#include <sys/stat.h>
|
||||
#include <cmocka.h>
|
||||
--
|
||||
2.9.4
|
||||
|
@ -1,26 +0,0 @@
|
||||
From 9315278f5f0d94116657caaffe1080804abd7087 Mon Sep 17 00:00:00 2001
|
||||
From: Andreas Schneider <asn@samba.org>
|
||||
Date: Wed, 5 Jul 2017 10:30:35 +0200
|
||||
Subject: [PATCH] unittests: Do not install the test_dummy rpc module
|
||||
|
||||
BUG: https://bugzilla.samba.org/show_bug.cgi?id=12879
|
||||
|
||||
Signed-off-by: Andreas Schneider <asn@samba.org>
|
||||
---
|
||||
testsuite/unittests/wscript | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/testsuite/unittests/wscript b/testsuite/unittests/wscript
|
||||
index ba6ad3c..561cb4b 100644
|
||||
--- a/testsuite/unittests/wscript
|
||||
+++ b/testsuite/unittests/wscript
|
||||
@@ -34,4 +34,5 @@ def build(bld):
|
||||
subsystem='rpc',
|
||||
allow_undefined_symbols=True,
|
||||
init_function='',
|
||||
- internal_module=False)
|
||||
+ internal_module=False,
|
||||
+ install=False)
|
||||
--
|
||||
2.9.4
|
||||
|
@ -1,48 +0,0 @@
|
||||
From bdcd72b80c90cebed8ae04c2cf55add535abb6af Mon Sep 17 00:00:00 2001
|
||||
From: Andreas Schneider <asn@samba.org>
|
||||
Date: Wed, 5 Jul 2017 10:08:49 +0200
|
||||
Subject: [PATCH] waf: Only build unit tests with selftest enabled
|
||||
|
||||
Signed-off-by: Andreas Schneider <asn@samba.org>
|
||||
---
|
||||
wscript | 2 +-
|
||||
wscript_build | 3 ++-
|
||||
2 files changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/wscript b/wscript
|
||||
index 47d020b..e80f766 100644
|
||||
--- a/wscript
|
||||
+++ b/wscript
|
||||
@@ -195,6 +195,7 @@ def configure(conf):
|
||||
if Options.options.with_ntvfs_fileserver == False:
|
||||
if not (Options.options.without_ad_dc):
|
||||
raise Utils.WafError('--without-ntvfs-fileserver conflicts with --enable-selftest while building the AD DC')
|
||||
+ conf.RECURSE('testsuite/unittests')
|
||||
|
||||
if Options.options.with_ntvfs_fileserver == True:
|
||||
if Options.options.without_ad_dc:
|
||||
@@ -214,7 +215,6 @@ def configure(conf):
|
||||
if conf.env.with_ctdb:
|
||||
conf.RECURSE('ctdb')
|
||||
conf.RECURSE('lib/socket')
|
||||
- conf.RECURSE('testsuite/unittests')
|
||||
conf.RECURSE('auth')
|
||||
|
||||
conf.SAMBA_CHECK_UNDEFINED_SYMBOL_FLAGS()
|
||||
diff --git a/wscript_build b/wscript_build
|
||||
index 2ddcdcc..8758b6d 100644
|
||||
--- a/wscript_build
|
||||
+++ b/wscript_build
|
||||
@@ -124,7 +124,8 @@ bld.RECURSE('libcli/samsync')
|
||||
bld.RECURSE('libcli/registry')
|
||||
bld.RECURSE('source4/lib/policy')
|
||||
bld.RECURSE('libcli/named_pipe_auth')
|
||||
-bld.RECURSE('testsuite/unittests')
|
||||
+if bld.CONFIG_GET('ENABLE_SELFTEST'):
|
||||
+ bld.RECURSE('testsuite/unittests')
|
||||
|
||||
if bld.CONFIG_GET('KRB5_VENDOR') in (None, 'heimdal'):
|
||||
if bld.CONFIG_GET("HEIMDAL_KRB5_CONFIG") and bld.CONFIG_GET("USING_SYSTEM_KRB5"):
|
||||
--
|
||||
2.9.4
|
||||
|
21
samba.spec
21
samba.spec
@ -6,15 +6,15 @@
|
||||
# ctdb is enabled by default, you can disable it with: --without clustering
|
||||
%bcond_without clustering
|
||||
|
||||
%define main_release 7
|
||||
%define main_release 0
|
||||
|
||||
%define samba_version 4.7.0
|
||||
%define talloc_version 2.1.9
|
||||
%define tdb_version 1.3.14
|
||||
%define tevent_version 0.9.32
|
||||
%define ldb_version 1.2.0
|
||||
%define tevent_version 0.9.33
|
||||
%define ldb_version 1.2.1
|
||||
# This should be rc1 or nil
|
||||
%define pre_release rc1
|
||||
%define pre_release rc3
|
||||
|
||||
%if "x%{?pre_release}" != "x"
|
||||
%define samba_release 0.%{main_release}.%{pre_release}%{?dist}
|
||||
@ -118,12 +118,6 @@ Source14: samba.pamd
|
||||
Source200: README.dc
|
||||
Source201: README.downgrade
|
||||
|
||||
Patch0: samba-4.7.0-unittests-Add-missing-stdint.h-include.patch
|
||||
Patch1: samba-4.7.0-waf-Only-build-unit-tests-with-selftest-enabled.patch
|
||||
Patch2: samba-4.7.0-unittests-Do-not-install-the-test_dummy-rpc-module.patch
|
||||
Patch3: samba-4.7.0-Do-not-install-_ldb_text.py-if-we-have-system-libldb.patch
|
||||
Patch4: samba-4.7.0-py3-dcerpc-modules.patch
|
||||
|
||||
Requires(pre): /usr/sbin/groupadd
|
||||
Requires(post): systemd
|
||||
Requires(preun): systemd
|
||||
@ -222,7 +216,7 @@ BuildRequires: python3-talloc-devel >= %{libtalloc_version}
|
||||
%endif
|
||||
|
||||
%if ! %with_internal_tevent
|
||||
%global libtevent_version 0.9.32
|
||||
%global libtevent_version 0.9.33
|
||||
|
||||
BuildRequires: libtevent-devel >= %{libtevent_version}
|
||||
BuildRequires: python2-tevent >= %{libtevent_version}
|
||||
@ -230,7 +224,7 @@ BuildRequires: python3-tevent >= %{libtevent_version}
|
||||
%endif
|
||||
|
||||
%if ! %with_internal_ldb
|
||||
%global libldb_version 1.2.0
|
||||
%global libldb_version 1.2.1
|
||||
|
||||
BuildRequires: libldb-devel >= %{libldb_version}
|
||||
BuildRequires: python2-ldb-devel >= %{libldb_version}
|
||||
@ -3330,6 +3324,9 @@ rm -rf %{buildroot}
|
||||
%endif # with_clustering_support
|
||||
|
||||
%changelog
|
||||
* Tue Jul 25 2017 Guenther Deschner <gdeschner@redhat.com> - 4.7.0-0.rc3
|
||||
- Update to Samba 4.7.0rc3
|
||||
|
||||
* Mon Jul 24 2017 Andreas Schneider <asn@redhat.com> - 4.7.0-7.rc1
|
||||
- Rename samba-python to python2-samba
|
||||
- Update build requirement for libcephfs
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (samba-4.7.0rc1.tar.xz) = c11681266374bd031a9617e606fed8000f0483924bfb9aba8836197cef1a1aa078da7598a097822b76761ddc46bd4a8466a09178fff541ce2e21dcbbf32efd3b
|
||||
SHA512 (samba-4.7.0rc1.tar.asc) = a85acceccabdf0fdc25658506e45465f33b670be6f3f56cfeb61a49f80fe9d920a4fb6dc4769e3374b220885a8501bb455eabdc3fb4e3a63573f19f1c438fa7e
|
||||
SHA512 (samba-4.7.0rc3.tar.xz) = 73f7402323c523f6a739a85c24068220e609f5e778869f423bbe7f819eb317319a979b048d2e1d59411397130c930e80fafcb534d01cde023184c6a034a5f8d1
|
||||
SHA512 (samba-4.7.0rc3.tar.asc) = c2f6ac4df71e85a8938ef78ebac2dc43ea0fb5556fc0639f2c6ef4811f3c41a2a67013d56f8de76c2d2c3d71840e38efa5fc69ca95f3f60014df866be2879406
|
||||
|
Loading…
Reference in New Issue
Block a user