parent
81464d9392
commit
b7fe01738a
1
.gitignore
vendored
1
.gitignore
vendored
@ -65,3 +65,4 @@ samba-3.6.0pre1.tar.gz
|
||||
/samba-4.4.0.tar.xz
|
||||
/samba-4.4.2.tar.xz
|
||||
/samba-4.4.3.tar.xz
|
||||
/samba-4.4.4.tar.xz
|
||||
|
@ -1,49 +0,0 @@
|
||||
diff --git samba-4.4.3/lib/util/become_daemon.c~ samba-4.4.3/lib/util/become_daemon.c
|
||||
index 4622971907..04d77da529 100644
|
||||
--- samba-4.4.3/lib/util/become_daemon.c~
|
||||
+++ samba-4.4.3/lib/util/become_daemon.c
|
||||
@@ -24,7 +24,7 @@
|
||||
#include "includes.h"
|
||||
#include "system/filesys.h"
|
||||
#include "system/locale.h"
|
||||
-#if HAVE_LIBSYSTEMD_DAEMON
|
||||
+#if defined(HAVE_LIBSYSTEMD_DAEMON) || defined(HAVE_LIBSYSTEMD)
|
||||
#include <systemd/sd-daemon.h>
|
||||
#endif
|
||||
#include "lib/util/close_low_fd.h"
|
||||
@@ -69,7 +69,7 @@ _PUBLIC_ void become_daemon(bool do_fork, bool no_process_group, bool log_stdout
|
||||
if (do_fork) {
|
||||
newpid = fork();
|
||||
if (newpid) {
|
||||
-#if HAVE_LIBSYSTEMD_DAEMON
|
||||
+#if defined(HAVE_LIBSYSTEMD_DAEMON) || defined(HAVE_LIBSYSTEMD)
|
||||
sd_notifyf(0, "READY=0\nSTATUS=Starting process...\nMAINPID=%lu", (unsigned long) newpid);
|
||||
#endif /* HAVE_LIBSYSTEMD_DAEMON */
|
||||
_exit(0);
|
||||
@@ -98,7 +98,7 @@ _PUBLIC_ void become_daemon(bool do_fork, bool no_process_group, bool log_stdout
|
||||
|
||||
_PUBLIC_ void exit_daemon(const char *msg, int error)
|
||||
{
|
||||
-#ifdef HAVE_LIBSYSTEMD_DAEMON
|
||||
+#if defined(HAVE_LIBSYSTEMD_DAEMON) || defined(HAVE_LIBSYSTEMD)
|
||||
if (msg == NULL) {
|
||||
msg = strerror(error);
|
||||
}
|
||||
@@ -117,7 +117,7 @@ _PUBLIC_ void daemon_ready(const char *name)
|
||||
if (name == NULL) {
|
||||
name = "Samba";
|
||||
}
|
||||
-#ifdef HAVE_LIBSYSTEMD_DAEMON
|
||||
+#if defined(HAVE_LIBSYSTEMD_DAEMON) || defined(HAVE_LIBSYSTEMD)
|
||||
sd_notifyf(0, "READY=1\nSTATUS=%s: ready to serve connections...", name);
|
||||
#endif
|
||||
DEBUG(0, ("STATUS=daemon '%s' finished starting up and ready to serve "
|
||||
@@ -129,7 +129,7 @@ _PUBLIC_ void daemon_status(const char *name, const char *msg)
|
||||
if (name == NULL) {
|
||||
name = "Samba";
|
||||
}
|
||||
-#ifdef HAVE_LIBSYSTEMD_DAEMON
|
||||
+#if defined(HAVE_LIBSYSTEMD_DAEMON) || defined(HAVE_LIBSYSTEMD)
|
||||
sd_notifyf(0, "\nSTATUS=%s: %s", name, msg);
|
||||
#endif
|
||||
DEBUG(0, ("STATUS=daemon '%s' : %s", name, msg));
|
14
samba.spec
14
samba.spec
@ -6,9 +6,9 @@
|
||||
# ctdb is enabled by default, you can disable it with: --without clustering
|
||||
%bcond_without clustering
|
||||
|
||||
%define main_release 2
|
||||
%define main_release 1
|
||||
|
||||
%define samba_version 4.4.3
|
||||
%define samba_version 4.4.4
|
||||
%define talloc_version 2.1.6
|
||||
%define tdb_version 1.3.8
|
||||
%define tevent_version 0.9.28
|
||||
@ -108,7 +108,6 @@ Source200: README.dc
|
||||
Source201: README.downgrade
|
||||
|
||||
Patch0: samba-4.4.2-s3-winbind-make-sure-domain-member-can-talk-to-trust.patch
|
||||
Patch1: samba-use-libsystemd.patch
|
||||
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
|
||||
@ -687,7 +686,6 @@ and use CTDB instead.
|
||||
%setup -q -n samba-%{version}%{pre_release}
|
||||
|
||||
%patch0 -p 1 -b .samba-4.4.2-s3-winbind-make-sure-domain-member-can-talk-to-trust.patch
|
||||
%patch1 -p 1 -b .samba-use-libsystemd.patch
|
||||
|
||||
%build
|
||||
%global _talloc_lib ,talloc,pytalloc,pytalloc-util
|
||||
@ -791,6 +789,7 @@ install -d -m 0755 %{buildroot}/var/spool/samba
|
||||
install -d -m 0755 %{buildroot}/var/run/samba
|
||||
install -d -m 0755 %{buildroot}/var/run/winbindd
|
||||
install -d -m 0755 %{buildroot}/%{_libdir}/samba
|
||||
install -d -m 0755 %{buildroot}/%{_libdir}/samba/ldb
|
||||
install -d -m 0755 %{buildroot}/%{_libdir}/pkgconfig
|
||||
|
||||
# Move libwbclient.so* into private directory, it cannot be just libdir/samba
|
||||
@ -1210,6 +1209,8 @@ rm -rf %{buildroot}
|
||||
%{_mandir}/man8/tdbtool.8*
|
||||
%endif
|
||||
|
||||
%dir %{_libdir}/samba/ldb
|
||||
|
||||
%if %with_internal_ldb
|
||||
%{_bindir}/ldbadd
|
||||
%{_bindir}/ldbdel
|
||||
@ -1218,7 +1219,6 @@ rm -rf %{buildroot}
|
||||
%{_bindir}/ldbrename
|
||||
%{_bindir}/ldbsearch
|
||||
%{_libdir}/samba/libldb-cmdline-samba4.so
|
||||
%dir %{_libdir}/samba/ldb
|
||||
%{_libdir}/samba/ldb/asq.so
|
||||
%{_libdir}/samba/ldb/paged_results.so
|
||||
%{_libdir}/samba/ldb/paged_searches.so
|
||||
@ -1990,6 +1990,10 @@ rm -rf %{buildroot}
|
||||
%endif # with_clustering_support
|
||||
|
||||
%changelog
|
||||
* Tue Jun 07 2016 Guenther Deschner <gdeschner@redhat.com> - 4.4.4-1
|
||||
- Update to Samba 4.4.4
|
||||
- resolves: #1343529
|
||||
|
||||
* Wed May 25 2016 Alexander Bokovoy <abokovoy@redhat.com> - 2:4.4.3-2
|
||||
- Fix libsystemd patch (#1125086) so that it actually works
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user