- Update to 3.4.0

- resolves: #510558

Guenther
This commit is contained in:
Guenther Deschner 2009-07-15 10:21:14 +00:00
parent c1f6a9cc47
commit 4eae2e0f32
8 changed files with 126 additions and 73 deletions

View File

@ -1 +1 @@
samba-3.3.5.tar.gz
samba-3.4.0.tar.gz

View File

@ -1,5 +1,5 @@
--- samba-3.2.0pre1/source/winbindd/winbindd_group.c.star 2007-10-03 17:40:31.000000000 -0400
+++ samba-3.2.0pre1/source/winbindd/winbindd_group.c 2007-10-03 17:40:46.000000000 -0400
--- samba-3.2.0pre1/source3/winbindd/winbindd_group.c.star 2007-10-03 17:40:31.000000000 -0400
+++ samba-3.2.0pre1/source3/winbindd/winbindd_group.c 2007-10-03 17:40:46.000000000 -0400
@@ -215,7 +215,7 @@
/* Group name and password */

View File

@ -1,5 +1,5 @@
--- samba-3.2.0pre1/source/nsswitch/winbind_struct_protocol.h.pipedir 2007-10-03 15:32:23.000000000 -0400
+++ samba-3.2.0pre1/source/nsswitch/winbind_struct_protocol.h 2007-10-03 15:33:13.000000000 -0400
--- samba-3.2.0pre1/nsswitch/winbind_struct_protocol.h.pipedir 2007-10-03 15:32:23.000000000 -0400
+++ samba-3.2.0pre1/nsswitch/winbind_struct_protocol.h 2007-10-03 15:33:13.000000000 -0400
@@ -24,7 +24,7 @@
* is needed for launchd support -- jpeach.
*/

View File

@ -1,6 +1,6 @@
=== modified file 'source/smbd/notify_inotify.c'
--- source/smbd/notify_inotify.c 2007-03-09 12:07:58 +0000
+++ source/smbd/notify_inotify.c 2007-04-10 16:27:47 +0000
--- source3/smbd/notify_inotify.c 2007-03-09 12:07:58 +0000
+++ source3/smbd/notify_inotify.c 2007-04-10 16:27:47 +0000
@@ -66,6 +66,7 @@
struct sys_notify_context *ctx;
int fd;

View File

@ -1,29 +0,0 @@
commit 3815e87f1ffea44c4d76e6c2515ff4894f6896c9
Author: Günther Deschner <gd@samba.org>
AuthorDate: Tue May 5 12:54:21 2009 +0200
Commit: Karolin Seeger <kseeger@samba.org>
CommitDate: Fri Jun 19 08:17:54 2009 +0200
s3-pam_winbind: Fix Bug 6253: Use correct value for password expiry calculation.
Based on patch from Blindauer Emmanuel <samba@mooby.net>.
Guenther
---
source/nsswitch/pam_winbind.c | 3 ++-
1 files changed, 2 insertions(+), 1 deletions(-)
diff --git a/source/nsswitch/pam_winbind.c b/source/nsswitch/pam_winbind.c
index 26ef1d4..1211ffd 100644
--- a/source/nsswitch/pam_winbind.c
+++ b/source/nsswitch/pam_winbind.c
@@ -914,7 +914,8 @@ static void _pam_warn_password_expiry(struct pwb_context *ctx,
/* now check for the global password policy */
/* good catch from Ralf Haferkamp: an expiry of "never" is translated
* to -1 */
- if (policy->expire <= 0) {
+ if ((policy->expire == (int64_t)-1) ||
+ (policy->expire == 0)) {
return;
}

74
samba-3.4.0-build.patch Normal file
View File

@ -0,0 +1,74 @@
commit 3b0bd19570894e5219878102a2564a08095f26cd
Author: Jelmer Vernooij <jelmer@samba.org>
AuthorDate: Thu Jun 11 04:57:58 2009 +0200
Commit: Günther Deschner <gd@samba.org>
CommitDate: Tue Jul 14 23:51:24 2009 +0200
Fix build with external talloc.
---
source3/configure.in | 29 +++++++++++++++++++++++++++--
source3/samba4.m4 | 4 ++++
2 files changed, 31 insertions(+), 2 deletions(-)
diff --git a/source3/configure.in b/source3/configure.in
index 111e89d..fc41b35 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -77,7 +77,6 @@ done
AC_SUBST(LIBTDB_OBJ0)
SAMBA_CPPFLAGS="-Iinclude -I${srcdir-.}/include -I. -I${srcdir-.}"
SAMBA_CPPFLAGS="${SAMBA_CPPFLAGS} -I${srcdir-.}/../lib/replace"
-SAMBA_CPPFLAGS="${SAMBA_CPPFLAGS} ${TALLOC_CFLAGS}"
SAMBA_CPPFLAGS="${SAMBA_CPPFLAGS} ${TEVENT_CFLAGS}"
SAMBA_CPPFLAGS="${SAMBA_CPPFLAGS} ${TDB_CFLAGS}"
SAMBA_CPPFLAGS="${SAMBA_CPPFLAGS} -I${srcdir-.}/libaddns"
@@ -4748,7 +4747,33 @@ LINK_LIBSMBCLIENT=STATIC
# TODO: for talloc and tdb (at least), these should
# be extracted from their respective source directories
#
-SMB_LIBRARY(talloc, 1)
+AC_ARG_ENABLE(external_libtalloc, [AS_HELP_STRING([--enable-external-libtalloc], [Enable external talloc [default=auto]])],
+[ enable_external_libtalloc=$enableval ], [ enable_external_libtalloc=auto ])
+
+if test "x$enable_external_libtalloc" != xno
+then
+ PKG_CHECK_MODULES(LIBTALLOC, talloc >= 1.3.0,
+ [ enable_external_libtalloc=yes ],
+ [ if test x$enable_external_libtalloc = xyes; then
+ AC_MSG_ERROR([Unable to find libtalloc])
+ else
+ enable_external_libtalloc=no
+ fi
+ ])
+fi
+
+if test "x$enable_external_libtalloc" = xno
+then
+ m4_include(../lib/talloc/libtalloc.m4)
+ SMB_LIBRARY(talloc, 1)
+ LIBTALLOC_OBJ0=""
+ for obj in ${TALLOC_OBJ}; do
+ LIBTALLOC_OBJ0="${LIBTALLOC_OBJ0} ${tallocdir}/${obj}"
+ done
+ SAMBA_CPPFLAGS="${SAMBA_CPPFLAGS} ${TALLOC_CFLAGS}"
+ AC_SUBST(LIBTALLOC_OBJ0)
+fi
+
SMB_LIBRARY(tdb, 1)
SMB_LIBRARY(netapi, 0)
SMB_LIBRARY(smbclient, 0)
diff --git a/source3/samba4.m4 b/source3/samba4.m4
index b5c7c74..0ea40db 100644
--- a/source3/samba4.m4
+++ b/source3/samba4.m4
@@ -75,6 +75,10 @@ SMB_EXT_LIB_FROM_PKGCONFIG(LIBTALLOC, talloc >= $TALLOC_MIN_VERSION,
SMB_INCLUDE_MK(../lib/talloc/config.mk)
]
)
+# Tallocdir isn't always set by the Samba3 c
+tallocdir=../lib/talloc
+AC_SUBST(tallocdir)
+CFLAGS="$CFLAGS -I../lib/talloc"
SMB_EXT_LIB_FROM_PKGCONFIG(LIBTDB, tdb >= $TDB_MIN_VERSION,
[],

View File

@ -1,6 +1,6 @@
%define main_release 38
%define samba_version 3.3.5
%define tdb_version 1.1.2
%define main_release 39
%define samba_version 3.4.0
%define tdb_version 1.1.3
%define talloc_version 1.2.0
%define pre_release %nil
@ -9,6 +9,7 @@
%define enable_talloc 0
%define enable_tdb 0
%define samba_source source3
Summary: Server and Client software to interoperate with Windows machines
Name: samba
Epoch: 0
@ -46,7 +47,7 @@ Patch104: samba-3.0.0rc3-nmbd-netbiosname.patch
# The passwd part has been applied, but not the group part
Patch107: samba-3.2.0pre1-grouppwd.patch
Patch200: samba-3.2.5-inotify.patch
Patch201: samba-3.3.5-pam_winbind.diff
Patch201: samba-3.4.0-build.patch
Requires(pre): samba-common = %{epoch}:%{samba_version}-%{release}
Requires: pam >= 0:0.64
@ -56,6 +57,12 @@ Requires(post): /sbin/chkconfig, /sbin/service
Requires(preun): /sbin/chkconfig, /sbin/service
BuildRequires: pam-devel, readline-devel, ncurses-devel, libacl-devel, krb5-devel, openldap-devel, openssl-devel, cups-devel, ctdb-devel
BuildRequires: autoconf, gawk, popt-devel, gtk2-devel, libcap-devel
%if ! %enable_talloc
BuildRequires: libtalloc-devel
%endif
%if ! %enable_tdb
BuildRequires: libtdb-devel
%endif
# Working around perl dependency problem from docs
%define __perl_requires %{SOURCE999}
@ -251,11 +258,11 @@ cp %{SOURCE11} packaging/Fedora/
#%patch104 -p1 -b .nmbd-netbiosname # FIXME: does not apply
%patch107 -p1 -b .grouppwd
%patch200 -p0 -b .inotify
%patch201 -p1 -b .pam_winbind
%patch201 -p1 -b .build
mv source/VERSION source/VERSION.orig
sed -e 's/SAMBA_VERSION_VENDOR_SUFFIX=$/&\"%{samba_release}\"/' < source/VERSION.orig > source/VERSION
cd source
mv %samba_source/VERSION %samba_source/VERSION.orig
sed -e 's/SAMBA_VERSION_VENDOR_SUFFIX=$/&\"%{samba_release}\"/' < %samba_source/VERSION.orig > %samba_source/VERSION
cd %samba_source
script/mkversion.sh
cd ..
@ -264,7 +271,7 @@ rm -fr examples/LDAP/smbldap-tools-*/
%build
cd source
cd %samba_source
sh autogen.sh
%ifarch i386 sparc
RPM_OPT_FLAGS="$RPM_OPT_FLAGS -D_FILE_OFFSET_BITS=64"
@ -306,23 +313,20 @@ CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -DLDAP_DEPRECATED" %configure \
--with-shared-modules=idmap_ad,idmap_rid,idmap_adex,idmap_hash,idmap_tdb2 \
--with-cifsupcall \
--with-cluster-support
# --with-aio-support \
make CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -DLDAP_DEPRECATED" \
pch
make pch
make LD_LIBRARY_PATH=$RPM_BUILD_DIR/%{name}-%{samba_version}/source/bin \
CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -DLDAP_DEPRECATED" %{?_smp_mflags} \
all nsswitch/libnss_wins.so modules test_pam_modules test_nss_modules test_shlibs
make LD_LIBRARY_PATH=$RPM_BUILD_DIR/%{name}-%{samba_version}%{pre_release}/%samba_source/bin \
%{?_smp_mflags} \
all ../nsswitch/libnss_wins.so modules test_pam_modules test_nss_modules test_shlibs
make LD_LIBRARY_PATH=$RPM_BUILD_DIR/%{name}-%{samba_version}/source/bin \
CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -DLDAP_DEPRECATED" %{?_smp_mflags} \
make LD_LIBRARY_PATH=$RPM_BUILD_DIR/%{name}-%{samba_version}%{pre_release}/%samba_source/bin \
%{?_smp_mflags} \
-C lib/netapi/examples
make CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE" \
debug2html smbfilter bin/cifs.upcall
make debug2html smbfilter bin/cifs.upcall
%install
@ -344,7 +348,7 @@ mkdir -p $RPM_BUILD_ROOT/var/run/winbindd
mkdir -p $RPM_BUILD_ROOT/%{_libdir}/samba
mkdir -p $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
cd source
cd %samba_source
%makeinstall \
BINDIR=$RPM_BUILD_ROOT%{_bindir} \
@ -368,7 +372,7 @@ cd ..
# Install other stuff
install -m644 packaging/Fedora/smb.conf.default $RPM_BUILD_ROOT%{_sysconfdir}/samba/smb.conf
install -m755 source/script/mksmbpasswd.sh $RPM_BUILD_ROOT%{_bindir}
install -m755 %samba_source/script/mksmbpasswd.sh $RPM_BUILD_ROOT%{_bindir}
install -m644 packaging/Fedora/smbusers $RPM_BUILD_ROOT%{_sysconfdir}/samba/smbusers
install -m755 packaging/Fedora/smbprint $RPM_BUILD_ROOT%{_bindir}
install -m755 packaging/Fedora/smb.init $RPM_BUILD_ROOT%{_initrddir}/smb
@ -384,39 +388,39 @@ install -m644 examples/LDAP/samba.schema $RPM_BUILD_ROOT%{_sysconfdir}/openldap/
# winbind
mkdir -p $RPM_BUILD_ROOT%{_libdir}
install -m 755 source/nsswitch/libnss_winbind.so $RPM_BUILD_ROOT/%{_lib}/libnss_winbind.so.2
install -m 755 nsswitch/libnss_winbind.so $RPM_BUILD_ROOT/%{_lib}/libnss_winbind.so.2
ln -sf /%{_lib}/libnss_winbind.so.2 $RPM_BUILD_ROOT%{_libdir}/libnss_winbind.so
install -m 755 source/nsswitch/libnss_wins.so $RPM_BUILD_ROOT/%{_lib}/libnss_wins.so.2
install -m 755 nsswitch/libnss_wins.so $RPM_BUILD_ROOT/%{_lib}/libnss_wins.so.2
ln -sf /%{_lib}/libnss_wins.so.2 $RPM_BUILD_ROOT%{_libdir}/libnss_wins.so
# libraries {
mkdir -p $RPM_BUILD_ROOT%{_libdir} $RPM_BUILD_ROOT%{_includedir}
build_libdir="$RPM_BUILD_ROOT%{_libdir}"
%if %enable_talloc
# talloc
cd source/lib/talloc
cd lib/talloc
# just to get the correct .pc file generated
./autogen.sh && ./configure --prefix=%{_prefix} --libdir=%{_libdir}
cd ../../..
install -m 644 source/lib/talloc/talloc.pc $build_libdir/pkgconfig/
cd ../..
install -m 644 lib/talloc/talloc.pc $build_libdir/pkgconfig/
%endif
%if %enable_tdb
# tdb
cd source/lib/tdb
cd lib/tdb
# just to get the correct .pc file generated
./autogen.sh && ./configure --prefix=%{_prefix} --libdir=%{_libdir}
cd ../../..
install -m 644 source/lib/tdb/tdb.pc $build_libdir/pkgconfig/
cd ../..
install -m 644 lib/tdb/tdb.pc $build_libdir/pkgconfig/
%endif
# make install puts libraries in the wrong place
# (but at least gets the versioning right now)
list="smbclient smbsharemodes netapi talloc tdb wbclient"
build_libdir="$RPM_BUILD_ROOT%{_libdir}"
for i in $list; do
install -m 644 source/pkgconfig/$i.pc $build_libdir/pkgconfig/ || true
install -m 644 %samba_source/pkgconfig/$i.pc $build_libdir/pkgconfig/ || true
done
@ -432,11 +436,11 @@ install -m644 %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/samba
install -m755 $RPM_BUILD_ROOT/usr/sbin/mount.cifs $RPM_BUILD_ROOT/sbin/mount.cifs
install -m755 $RPM_BUILD_ROOT/usr/sbin/umount.cifs $RPM_BUILD_ROOT/sbin/umount.cifs
install -m 755 source/lib/netapi/examples/bin/netdomjoin-gui $RPM_BUILD_ROOT/%{_sbindir}/netdomjoin-gui
install -m 755 %samba_source/lib/netapi/examples/bin/netdomjoin-gui $RPM_BUILD_ROOT/%{_sbindir}/netdomjoin-gui
mkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps/%{name}
install -m 644 source/lib/netapi/examples/netdomjoin-gui/samba.ico $RPM_BUILD_ROOT/%{_datadir}/pixmaps/%{name}/samba.ico
install -m 644 source/lib/netapi/examples/netdomjoin-gui/logo.png $RPM_BUILD_ROOT/%{_datadir}/pixmaps/%{name}/logo.png
install -m 644 source/lib/netapi/examples/netdomjoin-gui/logo-small.png $RPM_BUILD_ROOT/%{_datadir}/pixmaps/%{name}/logo-small.png
install -m 644 %samba_source/lib/netapi/examples/netdomjoin-gui/samba.ico $RPM_BUILD_ROOT/%{_datadir}/pixmaps/%{name}/samba.ico
install -m 644 %samba_source/lib/netapi/examples/netdomjoin-gui/logo.png $RPM_BUILD_ROOT/%{_datadir}/pixmaps/%{name}/logo.png
install -m 644 %samba_source/lib/netapi/examples/netdomjoin-gui/logo-small.png $RPM_BUILD_ROOT/%{_datadir}/pixmaps/%{name}/logo-small.png
rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/editreg.1*
rm -f $RPM_BUILD_ROOT%{_mandir}/man1/log2pcap.1*
@ -816,8 +820,8 @@ exit 0
%{_initrddir}/winbind
%{_mandir}/man1/ntlm_auth.1*
%{_mandir}/man1/wbinfo.1*
%{_mandir}/man7/winbind_krb5_locator.7*
%{_mandir}/man8/pam_winbind.8*
%{_mandir}/man7/winbind_krb5_locator.7*
%{_mandir}/man8/winbindd.8*
%{_mandir}/man8/idmap_*.8*
%{_datadir}/locale/*/LC_MESSAGES/pam_winbind.mo
@ -881,6 +885,10 @@ exit 0
%{_datadir}/pixmaps/samba/logo-small.png
%changelog
* Wed Jul 15 2009 Guenther Deschner <gdeschner@redhat.com> - 3.4.0-0.39
- Update to 3.4.0
- resolves: #510558
* Fri Jun 19 2009 Guenther Deschner <gdeschner@redhat.com> - 3.3.5-0.38
- Fix password expiry calculation in pam_winbind

View File

@ -1 +1 @@
8fa0e3c5daaba4c2ce2fb871a5f3157a samba-3.3.5.tar.gz
a7137736379daf9855814ae14c2c5e22 samba-3.4.0.tar.gz