Update to 3.2.0pre3.

Guenther
This commit is contained in:
Guenther Deschner 2008-04-25 19:15:19 +00:00
parent 1738bfcc4b
commit 0516fb63cb
9 changed files with 10 additions and 1508 deletions

View File

@ -1 +1 @@
samba-3.2.0pre2.tar.gz
samba-3.2.0pre3.tar.gz

View File

@ -1,10 +0,0 @@
--- samba-3.2.0pre1.orig/source/client/mount.cifs.c 2007-09-28 11:48:04.000000000 -0400
+++ samba-3.2.0pre1/source/client/mount.cifs.c 2008-02-22 12:48:39.000000000 -0500
@@ -37,6 +37,7 @@
#include <string.h>
#include <mntent.h>
#include <fcntl.h>
+#include <limits.h>
#define MOUNT_CIFS_VERSION_MAJOR "1"
#define MOUNT_CIFS_VERSION_MINOR "10"

File diff suppressed because it is too large Load Diff

View File

@ -1,21 +0,0 @@
commit 9eaaf17d30388ef9446fb18e69197baa699b7eac
Author: Günther Deschner <gd@samba.org>
Date: Thu Mar 6 19:47:28 2008 +0100
Fix the build of cifs.spnego.
Guenther
diff --git a/source/Makefile.in b/source/Makefile.in
index 7dfa312..8ae62fa 100644
--- a/source/Makefile.in
+++ b/source/Makefile.in
@@ -1326,7 +1326,7 @@ bin/umount.cifs@EXEEXT@: $(BINARY_PREREQS) $(CIFS_UMOUNT_OBJ) @BUILD_POPT@
@echo Linking $@
@$(CC) $(FLAGS) -o $@ $(CIFS_UMOUNT_OBJ) $(DYNEXP) $(LDFLAGS) @POPTLIBS@
-bin/cifs.spnego@EXEEXT@: $(BINARY_PREREQS) $(CIFS_SPNEGO_OBJ) $(LIBSMBCLIENT_OBJ0) @BUILD_POPT@ @LIBTALLOC_SHARED@ @LIBTDB_SHARED@
+bin/cifs.spnego@EXEEXT@: $(BINARY_PREREQS) $(CIFS_SPNEGO_OBJ) $(LIBSMBCLIENT_OBJ0) @BUILD_POPT@ @LIBTALLOC_SHARED@ @LIBTDB_SHARED@ @LIBWBCLIENT_SHARED@
@echo Linking $@
@$(CC) $(FLAGS) -o $@ $(CIFS_SPNEGO_OBJ) $(DYNEXP) $(LDFLAGS) \
-lkeyutils $(LIBS) $(LIBSMBCLIENT_OBJ0) $(KRB5LIBS) \

View File

@ -1,81 +0,0 @@
commit 29fca3c0353f2be4577613d7e38fbc51d2a370fa
Author: Günther Deschner <gd@samba.org>
Date: Wed Mar 5 13:20:32 2008 +0100
Add PICFLAG to libnetapi Makefile.
Guenther
diff --git a/source/lib/netapi/examples/Makefile.in b/source/lib/netapi/examples/Makefile.in
index 6de3e65..000eef1 100644
--- a/source/lib/netapi/examples/Makefile.in
+++ b/source/lib/netapi/examples/Makefile.in
@@ -7,6 +7,7 @@ LIBS=@LIBS@ -lnetapi -ltdb -ltalloc
DEVELOPER_CFLAGS=@DEVELOPER_CFLAGS@
FLAGS=-I../ -L../../../bin @CFLAGS@ $(GTK_FLAGS)
CC=@CC@
+PICFLAG=@PICFLAG@
LDFLAGS=@PIE_LDFLAGS@ @LDFLAGS@
DYNEXP=@DYNEXP@
commit d9f4060c660da0ad671e061b123df71d109d51b9
Author: Günther Deschner <gd@samba.org>
Date: Thu Mar 6 00:51:20 2008 +0100
Fix lp_load with an empty registry and "config backend = registry". Michael, please check.
Guenther
diff --git a/source/param/loadparm.c b/source/param/loadparm.c
index 5651a43..25aa48b 100644
--- a/source/param/loadparm.c
+++ b/source/param/loadparm.c
@@ -3404,6 +3404,13 @@ static bool process_registry_globals(bool (*pfunc)(const char *, const char *))
}
}
+ if (!libnet_conf_share_exists(conf_ctx, GLOBAL_NAME)) {
+ /* nothing to read from the registry yet but make sure lp_load
+ * doesn't return false */
+ ret = true;
+ goto done;
+ }
+
werr = libnet_conf_get_share(mem_ctx, conf_ctx, GLOBAL_NAME,
&num_params, &param_names, &param_values);
if (!W_ERROR_IS_OK(werr)) {
commit 1bbbebb7767b8a25532e8be3dbd274c211e34bbd
Author: Günther Deschner <gd@samba.org>
Date: Wed Mar 5 15:21:43 2008 +0100
Give a better error message why NetServerSetInfo() may fail in the gui.
Guenther
diff --git a/source/lib/netapi/examples/netdomjoin-gui/netdomjoin-gui.c b/source/lib/netapi/examples/netdomjoin-gui/netdomjoin-gui.c
index 73b14d4..a3719c7 100644
--- a/source/lib/netapi/examples/netdomjoin-gui/netdomjoin-gui.c
+++ b/source/lib/netapi/examples/netdomjoin-gui/netdomjoin-gui.c
@@ -154,7 +154,7 @@ static void callback_apply_description_change(GtkWidget *widget,
GTK_MESSAGE_ERROR,
GTK_BUTTONS_OK,
"Failed to change computer description: %s.",
- libnetapi_errstr(status));
+ libnetapi_get_error_string(state->ctx, status));
g_signal_connect_swapped(dialog, "response",
G_CALLBACK(gtk_widget_destroy),
dialog);
diff --git a/source/lib/netapi/serverinfo.c b/source/lib/netapi/serverinfo.c
index 5451295..d30e7d9 100644
--- a/source/lib/netapi/serverinfo.c
+++ b/source/lib/netapi/serverinfo.c
@@ -185,6 +185,9 @@ static WERROR NetServerSetInfoLocal_1005(struct libnetapi_ctx *ctx,
}
if (!lp_config_backend_is_registry()) {
+ libnetapi_set_error_string(ctx,
+ "Configuration manipulation requested but not "
+ "supported by backend");
return WERR_NOT_SUPPORTED;
}

View File

@ -1,70 +0,0 @@
commit 38eab68dfb2d8abe8ad00f5a86fc54c778d0d303
Author: Derrell Lipman <derrell.lipman@unwireduniverse.com>
Date: Mon Mar 17 11:34:25 2008 -0400
Fix use of AuthDataWithContext capability
During my initial plans for, and the subsequent discussion of a more
significant change to the API for libsmbclient, I had removed the
AuthDataWithContext usage, in favor of a more generalized planned interface.
When the API returned to its original state, I neglected to reinsert this
code.
Use of an authentication function with the context can be tested using
examples/libsmbclient/testbrowse -C
Derrell
diff --git a/source/libsmb/libsmb_context.c b/source/libsmb/libsmb_context.c
index 3e67943..dd78bce 100644
--- a/source/libsmb/libsmb_context.c
+++ b/source/libsmb/libsmb_context.c
@@ -421,7 +421,8 @@ smbc_init_context(SMBCCTX *context)
return NULL;
}
- if (!smbc_getFunctionAuthData(context) ||
+ if ((!smbc_getFunctionAuthData(context) &&
+ !smbc_getFunctionAuthDataWithContext(context)) ||
smbc_getDebug(context) < 0 ||
smbc_getDebug(context) > 100) {
diff --git a/source/libsmb/libsmb_server.c b/source/libsmb/libsmb_server.c
index 37612c6..7af5ca3 100644
--- a/source/libsmb/libsmb_server.c
+++ b/source/libsmb/libsmb_server.c
@@ -101,15 +101,29 @@ SMBC_call_auth_fn(TALLOC_CTX *ctx,
fstring workgroup;
fstring username;
fstring password;
+ smbc_get_auth_data_with_context_fn auth_with_context_fn;
strlcpy(workgroup, *pp_workgroup, sizeof(workgroup));
strlcpy(username, *pp_username, sizeof(username));
strlcpy(password, *pp_password, sizeof(password));
- smbc_getFunctionAuthData(context)(server, share,
- workgroup, sizeof(workgroup),
- username, sizeof(username),
- password, sizeof(password));
+ /* See if there's an authentication with context function provided */
+ auth_with_context_fn = smbc_getFunctionAuthDataWithContext(context);
+ if (auth_with_context_fn)
+ {
+ (* auth_with_context_fn)(context,
+ server, share,
+ workgroup, sizeof(workgroup),
+ username, sizeof(username),
+ password, sizeof(password));
+ }
+ else
+ {
+ smbc_getFunctionAuthData(context)(server, share,
+ workgroup, sizeof(workgroup),
+ username, sizeof(username),
+ password, sizeof(password));
+ }
TALLOC_FREE(*pp_workgroup);
TALLOC_FREE(*pp_username);

View File

@ -1,33 +0,0 @@
commit 5eb7b7a9db4bda40660df5ab67bfea99e75716f9
Author: Günther Deschner <gd@samba.org>
Date: Thu Mar 6 20:44:28 2008 +0100
Fix _dssetup_DsRoleGetPrimaryDomainInformation().
Guenther
diff --git a/source/rpc_server/srv_dssetup_nt.c b/source/rpc_server/srv_dssetup_nt.c
index ea535a3..2b18e6b 100644
--- a/source/rpc_server/srv_dssetup_nt.c
+++ b/source/rpc_server/srv_dssetup_nt.c
@@ -35,7 +35,7 @@ static WERROR fill_dsrole_dominfo_basic(TALLOC_CTX *ctx,
struct dssetup_DsRolePrimaryDomInfoBasic **info)
{
struct dssetup_DsRolePrimaryDomInfoBasic *basic = NULL;
- fstring dnsdomain;
+ char *dnsdomain = NULL;
DEBUG(10,("fill_dsrole_dominfo_basic: enter\n"));
@@ -71,7 +71,10 @@ static WERROR fill_dsrole_dominfo_basic(TALLOC_CTX *ctx,
/* fill in some additional fields if we are a member of an AD domain */
if (lp_security() == SEC_ADS) {
- fstrcpy(dnsdomain, lp_realm());
+ dnsdomain = talloc_strdup(ctx, lp_realm());
+ if (!dnsdomain) {
+ return WERR_NOMEM;
+ }
strlower_m(dnsdomain);
basic->dns_domain = dnsdomain;

View File

@ -1,5 +1,5 @@
%define main_release 8
%define samba_version 3.2.0pre2
%define main_release 9
%define samba_version 3.2.0pre3
%define tdb_version 1.1.1
%define talloc_version 1.2.0
@ -7,13 +7,13 @@ Summary: The Samba Suite of programs
Name: samba
Epoch: 0
Version: 3.2.0
Release: 1.pre2.%{main_release}%{?dist}
Release: 1.pre3.%{main_release}%{?dist}
License: GPLv3+ and LGPLv3+
Group: System Environment/Daemons
URL: http://www.samba.org/
#TAG: change for non-pre
Source: http://download.samba.org/samba/ftp/pre/%{name}-%{version}pre2.tar.gz
Source: http://download.samba.org/samba/ftp/pre/%{name}-%{version}pre3.tar.gz
#Source: http://www.samba.org/samba/ftp/samba/%{name}-%{version}.tar.gz
# Red Hat specific replacement-files
@ -46,13 +46,7 @@ Patch107: samba-3.2.0pre1-grouppwd.patch
Patch110: samba-3.0.21pre1-smbspool.patch
Patch111: samba-3.0.13-smbclient.patch
Patch200: samba-3.0.25rc1-inotifiy.patch
patch202: samba-3.2.0pre1-buildfix.patch
Patch203: samba-3.2.0pre2-build_fixes.patch
Patch204: samba-3.2.0pre2-libnetapi_fix.diff
Patch205: samba-3.2.0pre2-cifs_spnego.diff
Patch206: samba-3.2.0pre2-msrpc.diff
Patch207: samba-3.2.0pre2-roreloc.diff
Patch208: samba-3.2.0pre2-libsmbclient.diff
Requires(pre): samba-common = %{epoch}:%{version}-%{release}
Requires: pam >= 0:0.64
@ -259,12 +253,7 @@ cp %{SOURCE11} packaging/Fedora/
%patch110 -p1 -b .smbspool
#%patch111 -p1 -b .smbclient # FIXME: does not apply
#%patch200 -p0 -b .inotify # FIXME: does not compile
%patch203 -p1 -b .build_fixes
%patch204 -p1 -b .libnetapi
%patch205 -p1 -b .cifs_spnego
%patch206 -p1 -b .msrpc
%patch207 -p1 -b .roreloc
%patch208 -p1 -b .libsmbclient
mv source/VERSION source/VERSION.orig
sed -e 's/SAMBA_VERSION_VENDOR_SUFFIX=$/&\"%{release}\"/' < source/VERSION.orig > source/VERSION
@ -694,7 +683,6 @@ exit 0
%doc examples/autofs examples/LDAP examples/libsmbclient examples/misc examples/printer-accounting
%doc examples/printing
%doc docs/registry
%files swat
%defattr(-,root,root)
@ -811,7 +799,7 @@ exit 0
%{_libdir}/pkgconfig/wbclient.pc
%files doc
%doc docs/REVISION docs/Samba3-Developers-Guide.pdf docs/Samba3-ByExample.pdf
%doc docs/Samba3-Developers-Guide.pdf docs/Samba3-ByExample.pdf
%doc docs/Samba3-HOWTO.pdf docs/THANKS docs/history
%doc docs/htmldocs
@ -860,6 +848,9 @@ exit 0
%{_datadir}/pixmaps/samba/logo-small.png
%changelog
* Fri Apr 25 2008 Guenther Deschner <gdeschner@redhat.com> - 3.2.0-1.pre3.9
- Update to 3.2.0pre3
* Tue Mar 18 2008 Guenther Deschner <gdeschner@redhat.com> - 3.2.0-1.pre2.8
- Add fixes for libsmbclient and support for r/o relocations

View File

@ -1 +1 @@
a0c3ec481ae86c45680773f7bf9f5872 samba-3.2.0pre2.tar.gz
b8d013bdb8f65f494778ffcb50cf0215 samba-3.2.0pre3.tar.gz