- rebased to 1.39.0

- completed switch to systemd
- further cleanups and consolidation
This commit is contained in:
Dan Horák 2017-08-23 11:49:40 +02:00
parent 630487b266
commit fca7af8cca
6 changed files with 91 additions and 428 deletions

130
cpi.initd
View File

@ -1,130 +0,0 @@
#!/bin/sh
#
# Copyright 2009 Red Hat, Inc.
# License: GPLv2
# Author: Dan Horák <dhorak@redhat.com>
#
# cpi Set Control Program Identification on IBM zSeries
#
# chkconfig: 12345 80 20
# description: Set Control Program Identification on IBM zSeries \
# that's reported on a Linux LPAR
### BEGIN INIT INFO
# Provides: cpi
# Required-Start:
# Required-Stop:
# Should-Start:
# Should-Stop:
# Default-Start: 1 2 3 4 5
# Default-Stop: 0 6
# Short-Description: Set control program identification on IBM zSeries
# Description: Set Control Program Identification on IBM zSeries \
# that's reported on a Linux LPAR
### END INIT INFO
# Source function library.
. /etc/init.d/functions
prog="cpi"
[ -e /etc/sysconfig/$prog ] && . /etc/sysconfig/$prog
cpipath=/sys/firmware/cpi
start() {
[ `id -u` -eq 0 ] || return 4
echo -n $"Starting $prog: "
if [ -d $cpipath ]; then
retval=0
echo LINUX > $cpipath/system_type 2> /dev/null || retval=1
[ $retval -eq 0 ] && echo "$SYSTEM_NAME" > $cpipath/system_name 2> /dev/null || retval=1
[ $retval -eq 0 ] && echo "$SYSPLEX_NAME" > $cpipath/sysplex_name 2> /dev/null || retval=1
level_maj=`uname -r | cut -d '-' -f 1 | cut -d '.' -f 1`
level_min=`uname -r | cut -d '-' -f 1 | cut -d '.' -f 2`
level_mic=`uname -r | cut -d '-' -f 1 | cut -d '.' -f 3`
level=`printf '%02x%02x%02x' $level_maj $level_min $level_mic`
[ $retval -eq 0 ] && echo $level > $cpipath/system_level 2> /dev/null || retval=1
[ $retval -eq 0 ] && echo 1 > $cpipath/set 2> /dev/null || retval=1
else
retval=1
fi
[ $retval -eq 0 ] && success || failure
echo
return $retval
}
stop() {
echo -n $"Stopping $prog: "
# nothing to do
success
echo
return 0
}
restart() {
stop
start
}
reload() {
restart
}
force_reload() {
restart
}
rh_status() {
if [ -d $cpipath ]; then
echo -n "System type: "; cat $cpipath/system_type
echo -n "System level: "; cat $cpipath/system_level
echo -n "System name: "; cat $cpipath/system_name
echo -n "Sysplex name: "; cat $cpipath/sysplex_name
retval=0
else
echo "Control Program Identification system interface doesn't exist."
retval=1
fi
return $retval
}
rh_status_q() {
rh_status >/dev/null 2>&1
}
case "$1" in
start)
$1
;;
stop)
$1
;;
restart)
$1
;;
reload)
rh_status_q || exit 7
$1
;;
force-reload)
force_reload
;;
status)
rh_status
;;
condrestart|try-restart)
rh_status_q || exit 0
restart
;;
*)
echo $"Usage: $0 {start|stop|status|restart|condrestart|try-restart|reload|force-reload}"
exit 2
esac
exit $?

View File

@ -1,5 +0,0 @@
# Define a system name (8 chars maximum)
SYSTEM_NAME=
# Define a sysplex name (8 chars maximum)
SYSPLEX_NAME=

View File

@ -1,172 +0,0 @@
#! /bin/sh
#
# chkconfig: 2345 90 10
# description: Configure the mon_fsstatd and mon_procd daemons.
### BEGIN INIT INFO
# Provides: mon_statd
# Required-Start: $local_fs $remote_fs
# Required-Stop: $local_fs $remote_fs
# Should-Start:
# Should-Stop:
# Default-Start: 2 3 4 5
# Default-Stop: 0 1 6
# Short-Description: Configure the mon_fsstatd and mon_procd daemons.
# Description: Configures the mon_fsstatd and mon_procd daemons. It uses the
# configuration file /etc/sysconfig/mon_statd.
### END INIT INFO
# Source function library.
. /etc/rc.d/init.d/functions
exec_fsstat="/usr/sbin/mon_fsstatd"
prog_fsstat="mon_fsstatd"
exec_proc="/usr/sbin/mon_procd"
prog_proc="mon_procd"
config="/etc/sysconfig/mon_statd"
g_retval=0
lockfile_fsstat=/var/lock/subsys/$prog_fsstat
lockfile_proc=/var/lock/subsys/$prog_proc
[ -e $config ] && . $config || exit 6
load_kernel_module()
{
if [ ! -e /dev/monwriter ]; then
echo "Loading monwriter module..."
modprobe monwriter 2>&1
if [ $? -ne 0 ]; then
exit 1
fi
udevadm settle
if [ $? -ne 0 ]; then
exit 1
fi
fi
}
start_fsstat() {
[ `id -u` -eq 0 ] || exit 4
load_kernel_module
[ -x $exec_fsstat ] || exit 5
echo -n $"Starting $prog_fsstat: "
daemon $exec_fsstat -i $FSSTAT_INTERVAL
retval=$?
echo
[ $retval -eq 0 ] && touch $lockfile_fsstat
return $retval
}
start_proc() {
[ `id -u` -eq 0 ] || exit 4
load_kernel_module
[ -x $exec_proc ] || exit 5
echo -n $"Starting $prog_proc: "
daemon $exec_proc -i $PROC_INTERVAL
retval=$?
echo
[ $retval -eq 0 ] && touch $lockfile_proc
return $retval
}
stop_fsstat() {
[ `id -u` -eq 0 ] || exit 4
echo -n $"Stopping $prog_fsstat: "
killproc $exec_fsstat
retval=$?
echo
[ $retval -eq 0 ] && rm -f $lockfile_fsstat
return $retval
}
stop_proc() {
[ `id -u` -eq 0 ] || exit 4
echo -n $"Stopping $prog_proc: "
killproc $exec_proc
retval=$?
echo
[ $retval -eq 0 ] && rm -f $lockfile_proc
return $retval
}
restart_fsstat() {
stop_fsstat
start_fsstat
}
restart_proc() {
stop_proc
start_proc
}
reload_fsstat() {
restart_fsstat
}
reload_proc() {
restart_proc
}
force_reload_fsstat() {
restart_fsstat
}
force_reload_proc() {
restart_proc
}
rh_status_fsstat() {
# run checks to determine if the service is running or use generic status
status $exec_fsstat
}
rh_status_proc() {
# run checks to determine if the service is running or use generic status
status $exec_proc
}
rh_status_fsstat_q() {
rh_status_fsstat >/dev/null 2>&1
}
rh_status_proc_q() {
rh_status_proc >/dev/null 2>&1
}
case "$1" in
start)
[ $FSSTAT = "yes" ] && { rh_status_fsstat_q || { start_fsstat ; g_retval=$? ; } || { g_retval=0 ; } }
[ $PROC = "yes" ] && { rh_status_proc_q || { start_proc ; g_retval=$? ; } || { g_retval=0 ; } }
;;
stop)
[ $FSSTAT = "yes" ] && { rh_status_fsstat_q && { stop_fsstat ; g_retval=$? ; } || { g_retval=0 ; } }
[ $PROC = "yes" ] && { rh_status_proc_q && { stop_proc ; g_retval=$? ; } || { g_retval=0 ; } }
;;
restart)
[ $FSSTAT = "yes" ] && { restart_fsstat ; g_retval=$? ; }
[ $PROC = "yes" ] && { restart_proc ; g_retval=$? ; }
;;
reload)
[ $FSSTAT = "yes" ] && { rh_status_fsstat_q && { reload_fsstat ; g_retval=$? ; } || { g_retval=7 ; } }
[ $PROC = "yes" ] && { rh_status_proc_q && { reload_proc ; g_retval=$? ; } || { g_retval=7 ; } }
;;
force-reload)
[ $FSSTAT = "yes" ] && { force_reload_fsstat ; g_retval=$? ; }
[ $PROC = "yes" ] && { force_reload_proc ; g_retval=$? ; }
;;
status)
[ $FSSTAT = "yes" ] && { rh_status_fsstat ; g_retval=$? ; }
[ $PROC = "yes" ] && { rh_status_proc ; g_retval=$? ; }
;;
condrestart|try-restart)
[ $FSSTAT = "yes" ] && { rh_status_fsstat_q && { restart_fsstat ; g_retval=$? ; } || { g_retval=0 ; } }
[ $PROC = "yes" ] && { rh_status_proc_q && { restart_proc ; g_retval=$? ; } || { g_retval=0 ; } }
;;
*)
echo $"Usage: $0 {start|stop|status|restart|condrestart|try-restart|reload|force-reload}"
exit 2
esac
exit $g_retval

View File

@ -1,25 +0,0 @@
From 570170919f5f657db3aa0db8e403fe26917c5077 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Fri, 22 Apr 2016 13:21:50 +0200
Subject: [PATCH] zipl: disable strict aliasing for bootloader
---
zipl/boot/Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/zipl/boot/Makefile b/zipl/boot/Makefile
index 4908062..6474aad 100644
--- a/zipl/boot/Makefile
+++ b/zipl/boot/Makefile
@@ -4,7 +4,7 @@ include ../../common.mak
CFLAGS_BOOT = -Os -g -I../include -D__ASSEMBLY__ \
-DS390_TOOLS_RELEASE=$(S390_TOOLS_RELEASE) \
-fno-builtin -ffreestanding -fno-asynchronous-unwind-tables \
- -fno-delete-null-pointer-checks \
+ -fno-delete-null-pointer-checks -fno-strict-aliasing \
-fexec-charset=IBM1047 -m64 -mpacked-stack \
-mstack-size=8192 -mstack-guard=128 -msoft-float \
-W -Wall -Wformat-security
--
2.7.4

View File

@ -2,10 +2,10 @@
%define vipaver 2.1.0
Name: s390utils
Summary: Utilities and daemons for IBM System/z
Summary: Utilities and daemons for IBM z Systems
Group: System Environment/Base
Version: 1.37.1
Release: 4%{?dist}
Version: 1.39.0
Release: 1%{?dist}
Epoch: 2
License: GPLv2 and GPLv2+ and CPL
ExclusiveArch: s390 s390x
@ -19,9 +19,6 @@ Source5: zfcpconf.sh
# http://www.ibm.com/developerworks/linux/linux390/src_vipa-%%{vipaver}.html
Source6: http://download.boulder.ibm.com/ibmdl/pub/software/dw/linux390/ht_src/src_vipa-%{vipaver}.tar.gz
Source7: zfcp.udev
# files for the Control Program Identification (Linux Call Home) feature (#463282)
Source10: cpi.initd
Source11: cpi.sysconfig
# files for DASD initialization
Source12: dasd.udev
Source13: dasdconf.sh
@ -29,11 +26,8 @@ Source14: device_cio_free
Source15: device_cio_free.service
Source16: ccw_init
Source17: ccw.udev
Source19: mon_statd.initd
Source21: normalize_dasd_arg
Patch1: s390-tools-1.37.1-zipl-flags.patch
Patch1000: cmsfs-1.1.8-warnings.patch
Patch1001: cmsfs-1.1.8-kernel26.patch
Patch1002: cmsfs-1.1.8-use-detected-filesystem-block-size-on-FBA-devices.patch
@ -59,7 +53,7 @@ be used together with the zSeries (s390) Linux kernel and device drivers.
%setup -q -n s390-tools-%{version} -a 4 -a 6
# Fedora/RHEL changes
%patch1 -p1 -b .zipl-flags
# none
#
# cmsfs
@ -92,7 +86,7 @@ popd
%build
make \
OPT_FLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" \
OPT_FLAGS="$RPM_OPT_FLAGS" \
BINDIR=/usr/sbin \
DISTRELEASE=%{release} \
V=1
@ -108,9 +102,6 @@ popd
%install
# workaround an issue in the zipl-device-mapper patch
rm -f zipl/src/zipl_helper.device-mapper.*
make install \
DESTDIR=$RPM_BUILD_ROOT \
BINDIR=/usr/sbin \
@ -118,7 +109,7 @@ make install \
DISTRELEASE=%{release} \
V=1
mkdir -p $RPM_BUILD_ROOT{/boot,%{_udevrulesdir},%{_initddir},%{_sysconfdir}/{profile.d,sysconfig}}
mkdir -p $RPM_BUILD_ROOT{/boot,%{_udevrulesdir},%{_sysconfdir}/{profile.d,sysconfig}}
install -p -m 644 zipl/boot/tape0.bin $RPM_BUILD_ROOT/boot/tape0
install -p -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
install -p -m 644 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
@ -130,16 +121,21 @@ install -p -m 644 %{SOURCE12} $RPM_BUILD_ROOT%{_udevrulesdir}/56-dasd.rules
touch $RPM_BUILD_ROOT%{_sysconfdir}/{zfcp.conf,dasd.conf}
install -p -m 644 etc/sysconfig/dumpconf ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig
install -p -m 755 etc/init.d/dumpconf ${RPM_BUILD_ROOT}%{_initddir}/dumpconf
install -p -m 644 etc/sysconfig/dumpconf $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/
install -p -m 644 systemd/dumpconf.service $RPM_BUILD_ROOT%{_unitdir}/
install -p -m 644 etc/sysconfig/mon_statd ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig
install -p -m 755 %{SOURCE19} ${RPM_BUILD_ROOT}%{_initddir}/mon_statd
install -p -m 644 etc/sysconfig/mon_fsstatd $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/
install -p -m 644 etc/sysconfig/mon_procd $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/
install -p -m 644 systemd/mon_fsstatd.service $RPM_BUILD_ROOT%{_unitdir}/
install -p -m 644 systemd/mon_procd.service $RPM_BUILD_ROOT%{_unitdir}/
install -p -m 644 etc/cpuplugd.conf ${RPM_BUILD_ROOT}%{_sysconfdir}/
install -p -m 644 systemd/cpuplugd.service ${RPM_BUILD_ROOT}%{_unitdir}/
install -p -m 644 etc/cpuplugd.conf $RPM_BUILD_ROOT%{_sysconfdir}/
install -p -m 644 systemd/cpuplugd.service $RPM_BUILD_ROOT%{_unitdir}/
install -Dp -m 644 etc/udev/rules.d/*.rules ${RPM_BUILD_ROOT}%{_udevrulesdir}
install -p -m 644 etc/sysconfig/cpi $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/
install -p -m 644 systemd/cpi.service $RPM_BUILD_ROOT%{_unitdir}/
install -Dp -m 644 etc/udev/rules.d/*.rules $RPM_BUILD_ROOT%{_udevrulesdir}
# cmsfs tools must be available in /sbin
for f in cat lst vol cp ck; do
@ -156,30 +152,25 @@ popd
mkdir -p $RPM_BUILD_ROOT%{_includedir}/%{name}
install -p -m 644 include/lib/vtoc.h $RPM_BUILD_ROOT%{_includedir}/%{name}
# CPI
install -p -m 644 %{SOURCE11} ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig/cpi
install -p -m 755 %{SOURCE10} ${RPM_BUILD_ROOT}%{_initddir}/cpi
# device_cio_free
install -p -m 755 %{SOURCE14} ${RPM_BUILD_ROOT}%{_sbindir}
pushd ${RPM_BUILD_ROOT}%{_sbindir}
install -p -m 755 %{SOURCE14} $RPM_BUILD_ROOT%{_sbindir}
pushd $RPM_BUILD_ROOT%{_sbindir}
for lnk in dasd zfcp znet; do
ln -sf device_cio_free ${lnk}_cio_free
done
popd
mkdir -p ${RPM_BUILD_ROOT}/lib/systemd/system
mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/systemd/system/sysinit.target.wants
install -p -m 644 %{SOURCE15} ${RPM_BUILD_ROOT}%{_unitdir}
pushd ${RPM_BUILD_ROOT}%{_sysconfdir}/systemd/system/sysinit.target.wants
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system/sysinit.target.wants
install -p -m 644 %{SOURCE15} $RPM_BUILD_ROOT%{_unitdir}
pushd $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system/sysinit.target.wants
ln -sf %{_unitdir}/device_cio_free.service device_cio_free.service
popd
# ccw
install -p -m 755 %{SOURCE16} ${RPM_BUILD_ROOT}/usr/lib/udev/ccw_init
install -p -m 644 %{SOURCE17} ${RPM_BUILD_ROOT}%{_udevrulesdir}/81-ccw.rules
install -p -m 755 %{SOURCE16} $RPM_BUILD_ROOT/usr/lib/udev/ccw_init
install -p -m 644 %{SOURCE17} $RPM_BUILD_ROOT%{_udevrulesdir}/81-ccw.rules
# zipl.conf to be ghosted
touch ${RPM_BUILD_ROOT}%{_sysconfdir}/zipl.conf
touch $RPM_BUILD_ROOT%{_sysconfdir}/zipl.conf
%files
@ -197,9 +188,7 @@ Requires: perl gawk sed coreutils
Requires: sysfsutils
Requires: sg3_utils
Requires: ethtool
Requires(pre): chkconfig
Requires(preun): chkconfig
Requires(preun): initscripts
%{?systemd_requires}
BuildRequires: ncurses-devel
BuildRequires: libpfm-devel
BuildRequires: glibc-static
@ -333,86 +322,88 @@ For more information refer to the following publications:
* "Using the dump tools"
%post base
/sbin/chkconfig --add dumpconf
/sbin/chkconfig --add cpi
%systemd_post cpi.service
%systemd_post dumpconf.service
%preun base
if [ $1 = 0 ]; then
# not for updates
/sbin/service dumpconf stop > /dev/null 2>&1
/sbin/chkconfig --del dumpconf
/sbin/service cpi stop > /dev/null 2>&1
/sbin/chkconfig --del cpi
fi
:
%systemd_preun cpi.service
%systemd_preun dumpconf.service
%postun base
%systemd_postun_with_restart cpi.service
%systemd_postun_with_restart dumpconf.service
%files base
%doc README zdev/src/*.txt
%doc LICENSE
%{_sbindir}/zipl
%{_sbindir}/chccwdev
%{_sbindir}/chchp
%{_sbindir}/chcpumf
%{_sbindir}/chreipl
%{_sbindir}/chshut
%{_sbindir}/chzcrypt
%{_sbindir}/chzdev
%{_sbindir}/cio_ignore
%{_sbindir}/dasdfmt
%{_sbindir}/dasdinfo
%{_sbindir}/dasdstat
%{_sbindir}/dasdview
%{_sbindir}/dbginfo.sh
%{_sbindir}/fdasd
%{_sbindir}/chccwdev
%{_sbindir}/chchp
%{_sbindir}/chzcrypt
%{_sbindir}/chzdev
%{_sbindir}/cio_ignore
%{_sbindir}/hyptop
%{_sbindir}/ip_watcher.pl
%{_sbindir}/lschp
%{_sbindir}/lscss
%{_sbindir}/lsdasd
%{_sbindir}/lsqeth
%{_sbindir}/lsluns
%{_sbindir}/lsreipl
%{_sbindir}/lsscm
%{_sbindir}/lsshut
%{_sbindir}/lstape
%{_sbindir}/lszcrypt
%{_sbindir}/lszdev
%{_sbindir}/lszfcp
%{_sbindir}/scsi_logging_level
%{_sbindir}/zfcpdbf
%{_sbindir}/qetharp
%{_sbindir}/qethconf
%{_sbindir}/qethqoat
%{_sbindir}/tape390_display
%{_sbindir}/scsi_logging_level
%{_sbindir}/start_hsnc.sh
%{_sbindir}/tape390_crypt
%{_sbindir}/tape390_display
%{_sbindir}/ttyrun
%{_sbindir}/tunedasd
%{_sbindir}/vmcp
%{_sbindir}/zgetdump
%{_sbindir}/znetconf
%{_sbindir}/dbginfo.sh
%{_bindir}/lscpumf
%{_sbindir}/lsluns
%exclude %{_sbindir}/lsmem
%{_sbindir}/lsreipl
%{_sbindir}/lsshut
%{_sbindir}/chcpumf
%exclude %{_sbindir}/chmem
%{_sbindir}/chreipl
%{_sbindir}/chshut
%{_sbindir}/ip_watcher.pl
%{_sbindir}/start_hsnc.sh
%{_sbindir}/vmur
%{_sbindir}/xcec-bridge
%{_sbindir}/hyptop
%{_bindir}/vmconvert
%{_sbindir}/zfcpdbf
%{_sbindir}/zgetdump
%{_sbindir}/zipl
%{_sbindir}/znetconf
%{_bindir}/lscpumf
# provided by util-linux
%exclude %{_sbindir}/lsmem
%exclude %{_sbindir}/chmem
%{_bindir}/dump2tar
%{_initddir}/dumpconf
%{_bindir}/vmconvert
%{_bindir}/zkey
%{_unitdir}/cpi.service
%{_unitdir}/dumpconf.service
%ghost %config(noreplace) %{_sysconfdir}/zipl.conf
%config(noreplace) %{_sysconfdir}/sysconfig/cpi
%config(noreplace) %{_sysconfdir}/sysconfig/dumpconf
/lib/s390-tools
%{_mandir}/man1/dbginfo.sh.1*
%{_mandir}/man1/zfcpdbf.1*
%{_mandir}/man1/dump2tar.1*
%{_mandir}/man1/lscpumf.1*
%{_mandir}/man1/vmconvert.1*
%{_mandir}/man1/dump2tar.1*
%{_mandir}/man1/zfcpdbf.1*
%{_mandir}/man1/zkey.1*
%{_mandir}/man4/prandom.4*
%{_mandir}/man5/zipl.conf.5*
%{_mandir}/man8/chccwdev.8*
%{_mandir}/man8/chchp.8*
%{_mandir}/man8/chcpumf.8*
%exclude %{_mandir}/man8/chmem.8*
%{_mandir}/man8/chreipl.8*
%{_mandir}/man8/chshut.8*
%{_mandir}/man8/chzcrypt.8*
@ -428,7 +419,6 @@ fi
%{_mandir}/man8/lschp.8*
%{_mandir}/man8/lscss.8*
%{_mandir}/man8/lsdasd.8*
%exclude %{_mandir}/man8/lsmem.8*
%{_mandir}/man8/lsluns.8*
%{_mandir}/man8/lsqeth.8*
%{_mandir}/man8/lsreipl.8*
@ -450,6 +440,9 @@ fi
%{_mandir}/man8/zgetdump.8*
%{_mandir}/man8/znetconf.8*
%{_mandir}/man8/zipl.8*
# provided by util-linux
%exclude %{_mandir}/man8/chmem.8*
%exclude %{_mandir}/man8/lsmem.8*
%dir %{_datadir}/s390-tools/
%{_datadir}/s390-tools/cpumf/
@ -459,8 +452,6 @@ fi
%{_sysconfdir}/profile.d/s390.sh
%ghost %config(noreplace) %{_sysconfdir}/dasd.conf
%ghost %config(noreplace) %{_sysconfdir}/zfcp.conf
%{_initddir}/cpi
%config(noreplace) %{_sysconfdir}/sysconfig/cpi
%{_sbindir}/dasdconf.sh
%{_sbindir}/zfcpconf.sh
%{_sbindir}/dasd_cio_free
@ -512,9 +503,7 @@ License: GPLv2
Summary: Monitoring daemons for Linux in z/VM
Group: System Environment/Daemons
Requires: coreutils
Requires(pre): chkconfig
Requires(preun): chkconfig
Requires(preun): initscripts
%{?systemd_requires}
%description mon_statd
Monitoring daemons for Linux in z/VM:
@ -526,21 +515,24 @@ Monitoring daemons for Linux in z/VM:
monitor stream.
%post mon_statd
/sbin/chkconfig --add mon_statd
%systemd_post mon_fsstatd.service
%systemd_post mon_procd.service
%preun mon_statd
if [ $1 = 0 ]; then
# not for updates
/sbin/service mon_statd stop > /dev/null 2>&1
/sbin/chkconfig --del mon_statd
fi
:
%systemd_preun mon_fsstatd.service
%systemd_preun mon_procd.service
%postun mon_statd
%systemd_postun_with_restart mon_fsstatd.service
%systemd_postun_with_restart mon_procd.service
%files mon_statd
%{_sbindir}/mon_fsstatd
%{_sbindir}/mon_procd
%config(noreplace) %{_sysconfdir}/sysconfig/mon_statd
%{_initddir}/mon_statd
%config(noreplace) %{_sysconfdir}/sysconfig/mon_fsstatd
%config(noreplace) %{_sysconfdir}/sysconfig/mon_procd
%{_unitdir}/mon_fsstatd.service
%{_unitdir}/mon_procd.service
%{_mandir}/man8/mon_fsstatd.8*
%{_mandir}/man8/mon_procd.8*
@ -551,9 +543,7 @@ fi
License: GPLv2+
Summary: Daemon that manages CPU and memory resources
Group: System Environment/Daemons
Requires(post): systemd
Requires(preun): systemd
Requires(postun): systemd
%{?systemd_requires}
BuildRequires: systemd
%description cpuplugd
@ -809,6 +799,11 @@ User-space development files for the s390/s390x architecture.
%changelog
* Wed Aug 23 2017 Dan Horák <dan[at]danny.cz> - 2:1.39.0-1
- rebased to 1.39.0
- completed switch to systemd
- further cleanups and consolidation
* Wed Aug 16 2017 Dan Horák <dan@danny.cz> - 2:1.37.1-4
- rebuild for librpm soname bump in rpm 4.13.90

View File

@ -1,3 +1,3 @@
SHA512 (cmsfs-1.1.8c.tar.gz) = 2ba5687d378fdd9871283728e81f1399047e74f9bba3936726eda11a978fe6ced1a300f15acb871d5daa26e61069d89767c753cf584f2731f5e99985db96aef0
SHA512 (src_vipa-2.1.0.tar.gz) = 8f6048e82b4bcc479dfb09d62da64b9519f66efc31889ff795ee6ca107e262167df57628c305f1b899c41bb3f035e6309552d8548c890855d319e8e60d6a6cf7
SHA512 (s390-tools-1.37.1.tar.bz2) = 43a255171956aad3d04e666a2ab949f392bb8d8faca0a8f8a4714f9eabbc93e625ed0ec0cae69f05ef6a3ab86982de2a757184b771b60e927d86c931fb5cdf89
SHA512 (s390-tools-1.39.0.tar.bz2) = 7f8471668452391136cbe7e64e5e3e992881752f28f994159cc47539f225231f9d8523881a7d38e75eaf669e0b9ba765c03d0fbf6f09a3a88f113d12978f6ef4