- fix building zipl with gcc9 (#1687085)

This commit is contained in:
Dan Horák 2019-03-09 17:50:42 +01:00
parent bd0e3fb9c2
commit b1b957aaf0
2 changed files with 38 additions and 1 deletions

View File

@ -0,0 +1,31 @@
From f06d42bc92eae8a463e140612e096fb915dfbc3f Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Sat, 9 Mar 2019 10:09:39 -0500
Subject: [PATCH] zipl: copy new section introduced by GCC 9
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
GCC 9 is using a new section called .rodata.cst8 for some literals and it must be included
when copying the bootloaders to the bin images.
Signed-off-by: Dan Horák <dan@danny.cz>
---
zipl/boot/Makefile | 1 +
1 file changed, 1 insertion(+)
diff --git a/zipl/boot/Makefile b/zipl/boot/Makefile
index 52b3a23..7a3571e 100644
--- a/zipl/boot/Makefile
+++ b/zipl/boot/Makefile
@@ -71,6 +71,7 @@ stage3.exec: head.o stage3.o kdump3.o libc.o sclp.o sclp_stage3.o \
--only-section=.ex_table \
--only-section=.data \
--only-section=.rodata.str1.2 \
+ --only-section=.rodata.cst8 \
--only-section=.rodata \
--only-section=.stage2dump.tail \
--only-section=.eckd2dump_mv.tail \
--
2.17.2

View File

@ -3,7 +3,7 @@
Name: s390utils
Summary: Utilities and daemons for IBM z Systems
Version: 2.8.0
Release: 1%{?dist}
Release: 2%{?dist}
Epoch: 2
License: MIT
ExclusiveArch: s390 s390x
@ -29,6 +29,8 @@ Source24: 91-zipl.install
# change the defaults to match Fedora environment
Patch0: s390-tools-zipl-invert-script-options.patch
Patch1: s390-tools-zipl-blscfg-rpm-nvr-sort.patch
# https://github.com/ibm-s390-tools/s390-tools/pull/60
Patch2: s390-tools-zipl-gcc9.patch
Requires: s390utils-base = %{epoch}:%{version}-%{release}
Requires: s390utils-osasnmpd = %{epoch}:%{version}-%{release}
@ -53,6 +55,7 @@ be used together with the zSeries (s390) Linux kernel and device drivers.
# Fedora/RHEL changes
%patch0 -p1 -b .zipl-invert-script-options
%patch1 -p1 -b .blscfg-rpm-nvr-sort
%patch2 -p1 -b .gcc9
# remove --strip from install
@ -742,6 +745,9 @@ User-space development files for the s390/s390x architecture.
%changelog
* Sat Mar 09 2019 Dan Horák <dan[at]danny.cz> - 2:2.8.0-2
- fix building zipl with gcc9 (#1687085)
* Mon Feb 18 2019 Dan Horák <dan[at]danny.cz> - 2:2.8.0-1
- rebased to 2.8.0