- rebased to 2.9.0
This commit is contained in:
parent
1a182b31d3
commit
61130fa91d
1
.gitignore
vendored
1
.gitignore
vendored
@ -15,3 +15,4 @@ src_vipa-2.0.4.tar.gz
|
|||||||
/s390-tools-2.7.0.tar.gz
|
/s390-tools-2.7.0.tar.gz
|
||||||
/s390-tools-2.7.1.tar.gz
|
/s390-tools-2.7.1.tar.gz
|
||||||
/s390-tools-2.8.0.tar.gz
|
/s390-tools-2.8.0.tar.gz
|
||||||
|
/s390-tools-2.9.0.tar.gz
|
||||||
|
@ -1,19 +1,18 @@
|
|||||||
diff -up s390-tools-2.7.1/zipl/src/Makefile.blscfg-rpm-nvr-sort s390-tools-2.7.1/zipl/src/Makefile
|
diff -up s390-tools-2.9.0/zipl/src/Makefile.blscfg-rpm-nvr-sort s390-tools-2.9.0/zipl/src/Makefile
|
||||||
--- s390-tools-2.7.1/zipl/src/Makefile.blscfg-rpm-nvr-sort 2019-01-02 07:46:02.847225675 -0500
|
--- s390-tools-2.9.0/zipl/src/Makefile.blscfg-rpm-nvr-sort 2019-05-22 08:16:17.317273801 -0400
|
||||||
+++ s390-tools-2.7.1/zipl/src/Makefile 2019-01-02 07:48:51.267225675 -0500
|
+++ s390-tools-2.9.0/zipl/src/Makefile 2019-05-22 08:18:02.947273801 -0400
|
||||||
@@ -8,7 +8,8 @@ ALL_CPPFLAGS += -I../include -I../boot \
|
@@ -7,7 +7,7 @@ ALL_CPPFLAGS += -I../include -I../boot \
|
||||||
|
-D_FILE_OFFSET_BITS=64 $(NO_PIE_CFLAGS)
|
||||||
ALL_LDFLAGS += -Wl,-z,noexecstack $(NO_PIE_LDFLAGS)
|
ALL_LDFLAGS += -Wl,-z,noexecstack $(NO_PIE_LDFLAGS)
|
||||||
|
|
||||||
libs = $(rootdir)/libu2s/libu2s.a \
|
-libs = $(rootdir)/libutil/libutil.a
|
||||||
- $(rootdir)/libutil/libutil.a
|
+libs = $(rootdir)/libutil/libutil.a -lrpm
|
||||||
+ $(rootdir)/libutil/libutil.a \
|
|
||||||
+ -lrpm
|
|
||||||
|
|
||||||
objects = misc.o error.o scan.o job.o boot.o bootmap.o disk.o \
|
objects = misc.o error.o scan.o job.o boot.o bootmap.o disk.o \
|
||||||
install.o zipl.o $(rootdir)/zipl/boot/data.o
|
install.o zipl.o $(rootdir)/zipl/boot/data.o
|
||||||
diff -up s390-tools-2.7.1/zipl/src/scan.c.blscfg-rpm-nvr-sort s390-tools-2.7.1/zipl/src/scan.c
|
diff -up s390-tools-2.9.0/zipl/src/scan.c.blscfg-rpm-nvr-sort s390-tools-2.9.0/zipl/src/scan.c
|
||||||
--- s390-tools-2.7.1/zipl/src/scan.c.blscfg-rpm-nvr-sort 2018-12-13 09:57:25.000000000 -0500
|
--- s390-tools-2.9.0/zipl/src/scan.c.blscfg-rpm-nvr-sort 2019-05-21 09:13:36.000000000 -0400
|
||||||
+++ s390-tools-2.7.1/zipl/src/scan.c 2019-01-02 07:46:02.847225675 -0500
|
+++ s390-tools-2.9.0/zipl/src/scan.c 2019-05-22 08:16:17.317273801 -0400
|
||||||
@@ -33,6 +33,8 @@
|
@@ -33,6 +33,8 @@
|
||||||
|
|
||||||
#include "lib/util_base.h"
|
#include "lib/util_base.h"
|
||||||
@ -23,7 +22,7 @@ diff -up s390-tools-2.7.1/zipl/src/scan.c.blscfg-rpm-nvr-sort s390-tools-2.7.1/z
|
|||||||
#include "boot.h"
|
#include "boot.h"
|
||||||
#include "error.h"
|
#include "error.h"
|
||||||
#include "misc.h"
|
#include "misc.h"
|
||||||
@@ -652,13 +654,103 @@ bls_filter(const struct dirent *ent)
|
@@ -653,13 +655,103 @@ bls_filter(const struct dirent *ent)
|
||||||
return strncmp(ent->d_name + offset, ".conf", strlen(".conf")) == 0;
|
return strncmp(ent->d_name + offset, ".conf", strlen(".conf")) == 0;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -1,31 +0,0 @@
|
|||||||
From f06d42bc92eae8a463e140612e096fb915dfbc3f Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
|
||||||
Date: Sat, 9 Mar 2019 10:09:39 -0500
|
|
||||||
Subject: [PATCH] zipl: copy new section introduced by GCC 9
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
GCC 9 is using a new section called .rodata.cst8 for some literals and it must be included
|
|
||||||
when copying the bootloaders to the bin images.
|
|
||||||
|
|
||||||
Signed-off-by: Dan Horák <dan@danny.cz>
|
|
||||||
---
|
|
||||||
zipl/boot/Makefile | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
diff --git a/zipl/boot/Makefile b/zipl/boot/Makefile
|
|
||||||
index 52b3a23..7a3571e 100644
|
|
||||||
--- a/zipl/boot/Makefile
|
|
||||||
+++ b/zipl/boot/Makefile
|
|
||||||
@@ -71,6 +71,7 @@ stage3.exec: head.o stage3.o kdump3.o libc.o sclp.o sclp_stage3.o \
|
|
||||||
--only-section=.ex_table \
|
|
||||||
--only-section=.data \
|
|
||||||
--only-section=.rodata.str1.2 \
|
|
||||||
+ --only-section=.rodata.cst8 \
|
|
||||||
--only-section=.rodata \
|
|
||||||
--only-section=.stage2dump.tail \
|
|
||||||
--only-section=.eckd2dump_mv.tail \
|
|
||||||
--
|
|
||||||
2.17.2
|
|
||||||
|
|
@ -2,8 +2,8 @@
|
|||||||
|
|
||||||
Name: s390utils
|
Name: s390utils
|
||||||
Summary: Utilities and daemons for IBM z Systems
|
Summary: Utilities and daemons for IBM z Systems
|
||||||
Version: 2.8.0
|
Version: 2.9.0
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
License: MIT
|
License: MIT
|
||||||
ExclusiveArch: s390 s390x
|
ExclusiveArch: s390 s390x
|
||||||
@ -29,8 +29,6 @@ Source24: 91-zipl.install
|
|||||||
# change the defaults to match Fedora environment
|
# change the defaults to match Fedora environment
|
||||||
Patch0: s390-tools-zipl-invert-script-options.patch
|
Patch0: s390-tools-zipl-invert-script-options.patch
|
||||||
Patch1: s390-tools-zipl-blscfg-rpm-nvr-sort.patch
|
Patch1: s390-tools-zipl-blscfg-rpm-nvr-sort.patch
|
||||||
# https://github.com/ibm-s390-tools/s390-tools/pull/60
|
|
||||||
Patch2: s390-tools-zipl-gcc9.patch
|
|
||||||
|
|
||||||
Requires: s390utils-base = %{epoch}:%{version}-%{release}
|
Requires: s390utils-base = %{epoch}:%{version}-%{release}
|
||||||
Requires: s390utils-osasnmpd = %{epoch}:%{version}-%{release}
|
Requires: s390utils-osasnmpd = %{epoch}:%{version}-%{release}
|
||||||
@ -55,7 +53,6 @@ be used together with the zSeries (s390) Linux kernel and device drivers.
|
|||||||
# Fedora/RHEL changes
|
# Fedora/RHEL changes
|
||||||
%patch0 -p1 -b .zipl-invert-script-options
|
%patch0 -p1 -b .zipl-invert-script-options
|
||||||
%patch1 -p1 -b .blscfg-rpm-nvr-sort
|
%patch1 -p1 -b .blscfg-rpm-nvr-sort
|
||||||
%patch2 -p1 -b .gcc9
|
|
||||||
|
|
||||||
|
|
||||||
# remove --strip from install
|
# remove --strip from install
|
||||||
@ -354,6 +351,7 @@ systemctl --no-reload preset device_cio_free.service >/dev/null 2>&1 || :
|
|||||||
%{_sbindir}/vmur
|
%{_sbindir}/vmur
|
||||||
%{_sbindir}/xcec-bridge
|
%{_sbindir}/xcec-bridge
|
||||||
%{_sbindir}/zcryptctl
|
%{_sbindir}/zcryptctl
|
||||||
|
%{_sbindir}/zcryptstats
|
||||||
%{_sbindir}/zfcpdbf
|
%{_sbindir}/zfcpdbf
|
||||||
%{_sbindir}/zgetdump
|
%{_sbindir}/zgetdump
|
||||||
%{_sbindir}/zipl
|
%{_sbindir}/zipl
|
||||||
@ -419,6 +417,7 @@ systemctl --no-reload preset device_cio_free.service >/dev/null 2>&1 || :
|
|||||||
%{_mandir}/man8/vmcp.8*
|
%{_mandir}/man8/vmcp.8*
|
||||||
%{_mandir}/man8/vmur.8*
|
%{_mandir}/man8/vmur.8*
|
||||||
%{_mandir}/man8/zcryptctl.8*
|
%{_mandir}/man8/zcryptctl.8*
|
||||||
|
%{_mandir}/man8/zcryptstats.8*
|
||||||
%{_mandir}/man8/zgetdump.8*
|
%{_mandir}/man8/zgetdump.8*
|
||||||
%{_mandir}/man8/znetconf.8*
|
%{_mandir}/man8/znetconf.8*
|
||||||
%{_mandir}/man8/zipl.8*
|
%{_mandir}/man8/zipl.8*
|
||||||
@ -746,6 +745,9 @@ User-space development files for the s390/s390x architecture.
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed May 22 2019 Dan Horák <dan[at]danny.cz> - 2:2.9.0-1
|
||||||
|
- rebased to 2.9.0
|
||||||
|
|
||||||
* Thu May 02 2019 Dan Horák <dan[at]danny.cz> - 2:2.8.0-3
|
* Thu May 02 2019 Dan Horák <dan[at]danny.cz> - 2:2.8.0-3
|
||||||
- dbginfo.sh needs tar (#1705628)
|
- dbginfo.sh needs tar (#1705628)
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (src_vipa-2.1.0.tar.gz) = 8f6048e82b4bcc479dfb09d62da64b9519f66efc31889ff795ee6ca107e262167df57628c305f1b899c41bb3f035e6309552d8548c890855d319e8e60d6a6cf7
|
SHA512 (src_vipa-2.1.0.tar.gz) = 8f6048e82b4bcc479dfb09d62da64b9519f66efc31889ff795ee6ca107e262167df57628c305f1b899c41bb3f035e6309552d8548c890855d319e8e60d6a6cf7
|
||||||
SHA512 (s390-tools-2.8.0.tar.gz) = c13a58924b069a832a8c73e450dd6c9c3942787c1fa345450b1537af17ca23eda99025ee78edbe6c7192d82840596f9e07e25a10fccfba69f8a82b29980d82d1
|
SHA512 (s390-tools-2.9.0.tar.gz) = 23315e8914a5c797b0678298ff51fd95a3c9f065b0fa9f6cf954573fd5ad394890d7f8dbd9cf2501d845c76c3fe31952b25cb7c2b2d59744305b2f37cf3a65bb
|
||||||
|
Loading…
Reference in New Issue
Block a user