- refresh from RHEL-7

- update patches
 - add zdsfs subpackage
 - rebase src_vipa to 2.1.0
This commit is contained in:
Dan Horák 2015-01-28 10:27:04 +01:00
parent 8161782040
commit 52a75a97d6
5 changed files with 10279 additions and 112 deletions

1
.gitignore vendored
View File

@ -9,3 +9,4 @@ src_vipa-2.0.4.tar.gz
/s390-tools-1.19.0.tar.bz2
/s390-tools-1.20.0.tar.bz2
/s390-tools-1.23.0.tar.bz2
/src_vipa-2.1.0.tar.gz

File diff suppressed because it is too large Load Diff

View File

@ -1,11 +1,11 @@
%define cmsfsver 1.1.8c
%define vipaver 2.0.4
%define vipaver 2.1.0
Name: s390utils
Summary: Utilities and daemons for IBM System/z
Group: System Environment/Base
Version: 1.23.0
Release: 13%{?dist}
Release: 14%{?dist}
Epoch: 2
License: GPLv2 and GPLv2+ and CPL
ExclusiveArch: s390 s390x
@ -41,8 +41,6 @@ Patch1000: cmsfs-1.1.8-warnings.patch
Patch1001: cmsfs-1.1.8-kernel26.patch
Patch1002: cmsfs-1.1.8-use-detected-filesystem-block-size-on-FBA-devices.patch
Patch2000: src_vipa-2.0.4-locations.patch
Requires: s390utils-base = %{epoch}:%{version}-%{release}
Requires: s390utils-osasnmpd = %{epoch}:%{version}-%{release}
Requires: s390utils-cpuplugd = %{epoch}:%{version}-%{release}
@ -82,14 +80,6 @@ pushd cmsfs-%{cmsfsver}
%patch1002 -p1 -b .use-detected-block-size
popd
#
# src_vipa
#
pushd src_vipa-%{vipaver}
# fix location of the library
%patch2000 -p1 -b .locations
popd
# remove --strip from install
find . -name Makefile | xargs sed -i 's/$(INSTALL) -s/$(INSTALL)/g'
@ -167,7 +157,7 @@ install -p -m 644 cmsfs-%{cmsfsver}/cmsfsck.8 $RPM_BUILD_ROOT%{_mandir}/man8
# src_vipa
pushd src_vipa-%{vipaver}
make install LIBDIR=%{_libdir} SBINDIR=%{_bindir} INSTROOT=$RPM_BUILD_ROOT
make install LIBDIR=%{_libdir} SBINDIR=%{_bindir} INSTROOT=$RPM_BUILD_ROOT LDCONFIG=/bin/true
popd
# install usefull headers for devel subpackage
@ -730,6 +720,23 @@ This package contains the CMS file system based on FUSE.
%{_bindir}/cmsfs-fuse
%{_mandir}/man1/cmsfs-fuse.1*
#
# *********************** zdsfs package ***********************
#
%package zdsfs
License: GPLv2
Summary: z/OS data set access based on FUSE
Group: System Environment/Base
BuildRequires: fuse-devel
Requires: fuse
%description zdsfs
This package contains the z/OS data set access based on FUSE.
%files zdsfs
%{_bindir}/zdsfs
%{_mandir}/man1/zdsfs.1*
#
# *********************** devel package ***********************
#
@ -746,6 +753,12 @@ User-space development files for the s390/s390x architecture.
%changelog
* Wed Jan 28 2015 Dan Horák <dan[at]danny.cz> - 2:1.23.0-14
- refresh from RHEL-7
- update patches
- add zdsfs subpackage
- rebase src_vipa to 2.1.0
* Thu Oct 09 2014 Dan Horák <dan[at]danny.cz> - 2:1.23.0-13
- update device_cio_free script
- udpate Requires for ziomon subpackage

View File

@ -1,3 +1,3 @@
71a8ee5918f2c44c385fcfe8350cdc98 cmsfs-1.1.8c.tar.gz
ba42772e5b305b5e147344442cd70826 src_vipa-2.0.4.tar.gz
d7c8f8d6213f0e61e24c393347dcd8b7 s390-tools-1.23.0.tar.bz2
6011b33227d843a6e2f8144331f4b3d4 src_vipa-2.1.0.tar.gz

View File

@ -1,74 +0,0 @@
From b2f1bf78400c686bbdbcf4c29fbbb93367abe409 Mon Sep 17 00:00:00 2001
From: =?utf-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Wed, 25 Mar 2009 09:36:08 +0100
Subject: [PATCH] fix location of the library
---
Makefile | 7 +++----
1 files changed, 3 insertions(+), 4 deletions(-)
diff --git a/Makefile b/Makefile
index 669b6c6..d395fa8 100644
--- a/Makefile
+++ b/Makefile
@@ -20,7 +20,8 @@ INSTALL=install
VERSION=2.0.4
# the path to the .so
-SRC_VIPA_PATH=$(INSTROOT)/usr/lib
+LIBDIR=/usr/lib
+SRC_VIPA_PATH=$(INSTROOT)$(LIBDIR)
# the path to the starter script
SRC_VIPA_STARTER_PATH=$(INSTROOT)/usr/sbin
# path to man page
@@ -34,8 +35,7 @@ src_vipa.so: src_vipa.c
src_vipa.sh:
echo '#!/bin/bash' > src_vipa.sh
- echo 'export LD_LIBRARY_PATH=$(SRC_VIPA_PATH):$$LD_LIBRARY_PATH' >> src_vipa.sh
- echo 'export LD_PRELOAD=$(SRC_VIPA_PATH)/src_vipa.so' >> src_vipa.sh
+ echo 'export LD_PRELOAD=$(LIBDIR)/src_vipa.so' >> src_vipa.sh
echo 'exec $$@' >> src_vipa.sh
chmod 755 src_vipa.sh
@@ -44,7 +44,6 @@ install: src_vipa.so src_vipa.sh
$(INSTALL) -m 755 src_vipa.so $(SRC_VIPA_PATH)
$(INSTALL) -m 755 src_vipa.sh $(SRC_VIPA_STARTER_PATH)
$(INSTALL) -m 644 src_vipa.8 $(SRC_VIPA_MANPAGE_PATH)/man8
- ldconfig
clean:
rm -f src_vipa.{i,s,o,sh,so} core src_vipa-$(VERSION).tar.gz
--
1.6.0.6
From 5c21f29f4d9e82942a997775c111280b85d01bb8 Mon Sep 17 00:00:00 2001
From: =?utf-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Wed, 22 Apr 2009 12:53:55 +0200
Subject: [PATCH] make the man page path and script path configurable
---
Makefile | 6 ++++--
1 files changed, 4 insertions(+), 2 deletions(-)
diff --git a/Makefile b/Makefile
index d395fa8..365472b 100644
--- a/Makefile
+++ b/Makefile
@@ -23,9 +23,11 @@ VERSION=2.0.4
LIBDIR=/usr/lib
SRC_VIPA_PATH=$(INSTROOT)$(LIBDIR)
# the path to the starter script
-SRC_VIPA_STARTER_PATH=$(INSTROOT)/usr/sbin
+SBINDIR=/usr/sbin
+SRC_VIPA_STARTER_PATH=$(INSTROOT)$(SBINDIR)
# path to man page
-SRC_VIPA_MANPAGE_PATH=$(INSTROOT)/usr/share/man
+MANDIR=/usr/share/man
+SRC_VIPA_MANPAGE_PATH=$(INSTROOT)$(MANDIR)
all: src_vipa.so src_vipa.sh
--
1.6.0.6