- rebased to 2.7.0
This commit is contained in:
parent
2ff30e744f
commit
01b858f02d
1
.gitignore
vendored
1
.gitignore
vendored
@ -12,3 +12,4 @@ src_vipa-2.0.4.tar.gz
|
||||
/s390-tools-2.4.0.tar.gz
|
||||
/s390-tools-2.5.0.tar.gz
|
||||
/s390-tools-2.6.0.tar.gz
|
||||
/s390-tools-2.7.0.tar.gz
|
||||
|
@ -1,241 +0,0 @@
|
||||
From 1f8c561494e6bbecaaa02ff9cd1b2b9216da59df Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||
Date: Fri, 31 Aug 2018 10:07:35 +0200
|
||||
Subject: [PATCH 1/4] drop LOADLIBES variable
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Remove depreciated LOADLIBES variable from the Makefile rules, LDLIBS serves
|
||||
the same purpose these days.
|
||||
|
||||
Signed-off-by: Dan Horák <dan@danny.cz>
|
||||
---
|
||||
common.mak | 2 +-
|
||||
cpuplugd/Makefile | 2 +-
|
||||
ipl_tools/Makefile | 2 +-
|
||||
vmconvert/Makefile | 2 +-
|
||||
vmur/Makefile | 2 +-
|
||||
ziomon/Makefile | 10 +++++-----
|
||||
6 files changed, 10 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/common.mak b/common.mak
|
||||
index 7d11b10..6029687 100644
|
||||
--- a/common.mak
|
||||
+++ b/common.mak
|
||||
@@ -240,7 +240,7 @@ endif
|
||||
$(CXX) $(ALL_CPPFLAGS) $(ALL_CXXFLAGS) -c $< -o $@
|
||||
|
||||
%: %.o
|
||||
- $(LINK) $(ALL_LDFLAGS) $^ $(LOADLIBES) $(LDLIBS) -o $@
|
||||
+ $(LINK) $(ALL_LDFLAGS) $^ $(LDLIBS) -o $@
|
||||
|
||||
%.a:
|
||||
$(AR) rcs $@ $^
|
||||
diff --git a/cpuplugd/Makefile b/cpuplugd/Makefile
|
||||
index a9a49ab..916638d 100644
|
||||
--- a/cpuplugd/Makefile
|
||||
+++ b/cpuplugd/Makefile
|
||||
@@ -7,7 +7,7 @@ LDLIBS += -lm
|
||||
OBJECTS = daemon.o cpu.o info.o terms.o config.o main.o getopt.o mem.o
|
||||
|
||||
cpuplugd: $(OBJECTS)
|
||||
- $(LINK) $(ALL_LDFLAGS) $^ $(LOADLIBES) $(LDLIBS) -o $@
|
||||
+ $(LINK) $(ALL_LDFLAGS) $^ $(LDLIBS) -o $@
|
||||
|
||||
clean:
|
||||
rm -f cpuplugd $(OBJECTS)
|
||||
diff --git a/ipl_tools/Makefile b/ipl_tools/Makefile
|
||||
index 128ec3e..506d5cd 100644
|
||||
--- a/ipl_tools/Makefile
|
||||
+++ b/ipl_tools/Makefile
|
||||
@@ -6,7 +6,7 @@ objects = main.o ccw.o fcp.o system.o shutdown.o \
|
||||
cmd_lsshut.o cmd_chshut.o cmd_lsreipl.o cmd_chreipl.o proc.o
|
||||
|
||||
chreipl: $(objects)
|
||||
- $(LINK) $(ALL_LDFLAGS) $^ $(LOADLIBES) $(LDLIBS) -o $@
|
||||
+ $(LINK) $(ALL_LDFLAGS) $^ $(LDLIBS) -o $@
|
||||
|
||||
lsreipl:
|
||||
ln -sf chreipl lsreipl
|
||||
diff --git a/vmconvert/Makefile b/vmconvert/Makefile
|
||||
index 4d0216c..380eb19 100644
|
||||
--- a/vmconvert/Makefile
|
||||
+++ b/vmconvert/Makefile
|
||||
@@ -9,7 +9,7 @@ libs = $(rootdir)/libvmdump/libvmdump.a
|
||||
objects = vmconvert.o
|
||||
|
||||
vmconvert: $(objects) $(libs)
|
||||
- $(LINKXX) $(ALL_LDFLAGS) $^ $(LOADLIBES) $(LDLIBS) -o $@
|
||||
+ $(LINKXX) $(ALL_LDFLAGS) $^ $(LDLIBS) -o $@
|
||||
|
||||
install: all
|
||||
$(INSTALL) -d -m 755 $(DESTDIR)$(USRBINDIR) $(DESTDIR)$(MANDIR)/man1
|
||||
diff --git a/vmur/Makefile b/vmur/Makefile
|
||||
index 1a6bddc..2c1c2d5 100644
|
||||
--- a/vmur/Makefile
|
||||
+++ b/vmur/Makefile
|
||||
@@ -11,7 +11,7 @@ libs = $(rootdir)/libvmdump/libvmdump.a \
|
||||
objects = vmur.o
|
||||
|
||||
vmur: $(objects) $(libs)
|
||||
- $(LINKXX) $(ALL_LDFLAGS) $^ $(LOADLIBES) $(LDLIBS) -o $@
|
||||
+ $(LINKXX) $(ALL_LDFLAGS) $^ $(LDLIBS) -o $@
|
||||
|
||||
install: all
|
||||
$(INSTALL) -d -m 755 $(DESTDIR)$(USRSBINDIR) $(DESTDIR)$(MANDIR)/man8
|
||||
diff --git a/ziomon/Makefile b/ziomon/Makefile
|
||||
index 778401b..61c2399 100644
|
||||
--- a/ziomon/Makefile
|
||||
+++ b/ziomon/Makefile
|
||||
@@ -12,33 +12,33 @@ ziomon_mgr_main.o: ziomon_mgr.c
|
||||
ziomon_mgr: LDLIBS += -lm
|
||||
ziomon_mgr: ziomon_dacc.o ziomon_util.o ziomon_mgr_main.o ziomon_tools.o \
|
||||
ziomon_zfcpdd.o ziomon_msg_tools.o
|
||||
- $(LINK) $(ALL_LDFLAGS) $^ $(LOADLIBES) $(LDLIBS) -o $@
|
||||
+ $(LINK) $(ALL_LDFLAGS) $^ $(LDLIBS) -o $@
|
||||
|
||||
ziomon_util_main.o: ziomon_util.c ziomon_util.h
|
||||
$(CC) -DWITH_MAIN $(ALL_CFLAGS) $(ALL_CPPFLAGS) -c $< -o $@
|
||||
ziomon_util: LDLIBS += -lm
|
||||
ziomon_util: ziomon_util_main.o ziomon_tools.o
|
||||
- $(LINK) $(ALL_LDFLAGS) $^ $(LOADLIBES) $(LDLIBS) -o $@
|
||||
+ $(LINK) $(ALL_LDFLAGS) $^ $(LDLIBS) -o $@
|
||||
|
||||
ziomon_zfcpdd_main.o: ziomon_zfcpdd.c ziomon_zfcpdd.h
|
||||
$(CC) -DWITH_MAIN $(ALL_CFLAGS) $(ALL_CPPFLAGS) -c $< -o $@
|
||||
ziomon_zfcpdd: LDLIBS += -lm -lrt -lpthread
|
||||
ziomon_zfcpdd: ziomon_zfcpdd_main.o ziomon_tools.o
|
||||
- $(LINK) $(ALL_LDFLAGS) $^ $(LOADLIBES) $(LDLIBS) -o $@
|
||||
+ $(LINK) $(ALL_LDFLAGS) $^ $(LDLIBS) -o $@
|
||||
|
||||
ziorep_traffic: ziorep_traffic.o ziorep_framer.o ziorep_frameset.o \
|
||||
ziorep_printers.o ziomon_dacc.o ziomon_util.o \
|
||||
ziomon_msg_tools.o ziomon_tools.o ziomon_zfcpdd.o \
|
||||
ziorep_cfgreader.o ziorep_collapser.o ziorep_utils.o \
|
||||
ziorep_filters.o
|
||||
- $(LINKXX) $(ALL_LDFLAGS) $^ $(LOADLIBES) $(LDLIBS) -o $@
|
||||
+ $(LINKXX) $(ALL_LDFLAGS) $^ $(LDLIBS) -o $@
|
||||
|
||||
ziorep_utilization: ziorep_utilization.o ziorep_framer.o ziorep_frameset.o \
|
||||
ziorep_printers.o ziomon_dacc.o ziomon_util.o \
|
||||
ziomon_msg_tools.o ziomon_tools.o ziomon_zfcpdd.o \
|
||||
ziorep_cfgreader.o ziorep_collapser.o ziorep_utils.o \
|
||||
ziorep_filters.o
|
||||
- $(LINKXX) $(ALL_LDFLAGS) $^ $(LOADLIBES) $(LDLIBS) -o $@
|
||||
+ $(LINKXX) $(ALL_LDFLAGS) $^ $(LDLIBS) -o $@
|
||||
|
||||
install: all
|
||||
$(SED) -e 's/%S390_TOOLS_VERSION%/$(S390_TOOLS_RELEASE)/' \
|
||||
--
|
||||
2.17.1
|
||||
|
||||
|
||||
From fb5268e46eac79cfdf683ddfff6d685df6008b38 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||
Date: Fri, 31 Aug 2018 10:13:38 +0200
|
||||
Subject: [PATCH 2/4] zkey: Drop redundant include
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Signed-off-by: Dan Horák <dan@danny.cz>
|
||||
---
|
||||
zkey/Makefile | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/zkey/Makefile b/zkey/Makefile
|
||||
index 68f35cf..725cb3b 100644
|
||||
--- a/zkey/Makefile
|
||||
+++ b/zkey/Makefile
|
||||
@@ -22,7 +22,6 @@ else
|
||||
INSTALL_TARGETS += zkey-cryptsetup-skip-cryptsetup2
|
||||
endif
|
||||
|
||||
-CPPFLAGS += -I../include
|
||||
LIBS = $(rootdir)/libutil/libutil.a
|
||||
|
||||
detect-libcryptsetup.h:
|
||||
--
|
||||
2.17.1
|
||||
|
||||
|
||||
From 577cbdaee51c0104465e4b77e5d931f8232d92e2 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||
Date: Fri, 31 Aug 2018 10:17:07 +0200
|
||||
Subject: [PATCH 3/4] zkey: Be consistent when refering to libutil.a
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Signed-off-by: Dan Horák <dan@danny.cz>
|
||||
---
|
||||
zkey/Makefile | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/zkey/Makefile b/zkey/Makefile
|
||||
index 725cb3b..7e2047a 100644
|
||||
--- a/zkey/Makefile
|
||||
+++ b/zkey/Makefile
|
||||
@@ -22,7 +22,7 @@ else
|
||||
INSTALL_TARGETS += zkey-cryptsetup-skip-cryptsetup2
|
||||
endif
|
||||
|
||||
-LIBS = $(rootdir)/libutil/libutil.a
|
||||
+libs = $(rootdir)/libutil/libutil.a
|
||||
|
||||
detect-libcryptsetup.h:
|
||||
echo "#include <libcryptsetup.h>" > detect-libcryptsetup.h
|
||||
@@ -69,10 +69,10 @@ keystore.o: keystore.c keystore.h properties.h
|
||||
zkey-cryptsetup.o: check-dep-zkey-cryptsetup zkey-cryptsetup.c pkey.h misc.h
|
||||
|
||||
zkey: LDLIBS = -ldl -lcrypto
|
||||
-zkey: zkey.o pkey.o properties.o keystore.o $(LIBS)
|
||||
+zkey: zkey.o pkey.o properties.o keystore.o $(libs)
|
||||
|
||||
zkey-cryptsetup: LDLIBS = -ldl -lcryptsetup -ljson-c
|
||||
-zkey-cryptsetup: zkey-cryptsetup.o pkey.o $(LIBS)
|
||||
+zkey-cryptsetup: zkey-cryptsetup.o pkey.o $(libs)
|
||||
|
||||
install-common:
|
||||
$(INSTALL) -d -m 755 $(DESTDIR)$(USRBINDIR)
|
||||
--
|
||||
2.17.1
|
||||
|
||||
|
||||
From b474b9d1a567e132f79c2a17ebbc3b56794e4797 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||
Date: Fri, 31 Aug 2018 04:29:39 -0400
|
||||
Subject: [PATCH 4/4] zkey: Be explicit about linking the tools
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
I've met cases when the make's default rule for linking was used instead omitting
|
||||
the ALL_LDFLAGS variable. The linking rule from common.mak is defined for linking
|
||||
*.o files only, here we have libutil.a too.
|
||||
|
||||
Signed-off-by: Dan Horák <dan@danny.cz>
|
||||
---
|
||||
zkey/Makefile | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/zkey/Makefile b/zkey/Makefile
|
||||
index 7e2047a..901ddd4 100644
|
||||
--- a/zkey/Makefile
|
||||
+++ b/zkey/Makefile
|
||||
@@ -70,9 +70,11 @@ zkey-cryptsetup.o: check-dep-zkey-cryptsetup zkey-cryptsetup.c pkey.h misc.h
|
||||
|
||||
zkey: LDLIBS = -ldl -lcrypto
|
||||
zkey: zkey.o pkey.o properties.o keystore.o $(libs)
|
||||
+ $(LINK) $(ALL_LDFLAGS) $^ $(LDLIBS) -o $@
|
||||
|
||||
zkey-cryptsetup: LDLIBS = -ldl -lcryptsetup -ljson-c
|
||||
zkey-cryptsetup: zkey-cryptsetup.o pkey.o $(libs)
|
||||
+ $(LINK) $(ALL_LDFLAGS) $^ $(LDLIBS) -o $@
|
||||
|
||||
install-common:
|
||||
$(INSTALL) -d -m 755 $(DESTDIR)$(USRBINDIR)
|
||||
--
|
||||
2.17.1
|
||||
|
@ -1,106 +0,0 @@
|
||||
From 0318dfbc726a82ce1e9309e55186f3c4faae72f1 Mon Sep 17 00:00:00 2001
|
||||
From: Eric Sandeen <sandeen@sandeen.net>
|
||||
Date: Wed, 12 Sep 2018 09:40:22 -0500
|
||||
Subject: [PATCH] zipl: use FIEMAP mapping ioctl if it exists
|
||||
|
||||
zipl currently uses the FIBMAP ioctl to map blocks for the bootloader;
|
||||
on XFS, if FIBMAP is requested on a reflinked file, it will fail -
|
||||
and FIBMAP returns 0 in this case, which is indistinguishable from a
|
||||
hole. This causes boot to fail because the file is not mapped.
|
||||
|
||||
We can use the FIEMAP ioctl instead, which is able to map reflinked
|
||||
files. While FIEMAP is able to map entire extents at once, here we
|
||||
simply use it to obtain the mapping block-by-block so that it fits
|
||||
in with the current FIBMAP calls.
|
||||
|
||||
Signed-off-by: Eric Sandeen <sandeen@redhat.com>
|
||||
---
|
||||
zipl/src/disk.c | 57 +++++++++++++++++++++++++++++++++++++++++++++----
|
||||
1 file changed, 53 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/zipl/src/disk.c b/zipl/src/disk.c
|
||||
index 0d8e7796..43092bf1 100644
|
||||
--- a/zipl/src/disk.c
|
||||
+++ b/zipl/src/disk.c
|
||||
@@ -21,6 +21,8 @@
|
||||
#include <sys/sysmacros.h>
|
||||
#include <sys/vfs.h>
|
||||
#include <unistd.h>
|
||||
+#include <linux/fs.h>
|
||||
+#include <linux/fiemap.h>
|
||||
|
||||
#include "lib/util_proc.h"
|
||||
|
||||
@@ -550,8 +552,12 @@ disk_get_blocknum(int fd, int fd_is_basedisk, blocknum_t logical,
|
||||
{
|
||||
struct statfs buf;
|
||||
blocknum_t phy_per_fs;
|
||||
- int mapped;
|
||||
+ blocknum_t mapped;
|
||||
+ int block;
|
||||
int subblock;
|
||||
+ int fiemap_size;
|
||||
+ int map_offset;
|
||||
+ struct fiemap *fiemap;
|
||||
|
||||
/* No file system: partition or raw disk */
|
||||
if (info->fs_block_size == -1) {
|
||||
@@ -576,12 +582,55 @@ disk_get_blocknum(int fd, int fd_is_basedisk, blocknum_t logical,
|
||||
}
|
||||
/* Get mapping in file system blocks */
|
||||
phy_per_fs = info->fs_block_size / info->phy_block_size;
|
||||
- mapped = logical / phy_per_fs;
|
||||
subblock = logical % phy_per_fs;
|
||||
- if (ioctl(fd, FIBMAP, &mapped)) {
|
||||
- error_reason("Could not get file mapping");
|
||||
+
|
||||
+ /* First try FIEMAP, more complicated to set up */
|
||||
+ fiemap_size = sizeof(struct fiemap) + sizeof(struct fiemap_extent);
|
||||
+
|
||||
+ fiemap = misc_malloc(fiemap_size);
|
||||
+ if (!fiemap)
|
||||
return -1;
|
||||
+ memset(fiemap, 0, fiemap_size);
|
||||
+
|
||||
+ fiemap->fm_extent_count = 1;
|
||||
+ fiemap->fm_flags = FIEMAP_FLAG_SYNC;
|
||||
+ /* fm_start, fm_length in bytes; logical is in physical block units */
|
||||
+ fiemap->fm_start = logical * info->phy_block_size;
|
||||
+ fiemap->fm_length = info->phy_block_size;
|
||||
+
|
||||
+ if (ioctl(fd, FS_IOC_FIEMAP, (unsigned long)fiemap)) {
|
||||
+ /* FIEMAP failed, fall back to FIBMAP */
|
||||
+ block = logical / phy_per_fs;
|
||||
+ if (ioctl(fd, FIBMAP, &block)) {
|
||||
+ error_reason("Could not get file mapping");
|
||||
+ free(fiemap);
|
||||
+ return -1;
|
||||
+ }
|
||||
+ mapped = block;
|
||||
+ } else {
|
||||
+ if (fiemap->fm_mapped_extents) {
|
||||
+ if (fiemap->fm_extents[0].fe_flags &
|
||||
+ FIEMAP_EXTENT_ENCODED) {
|
||||
+ error_reason("File mapping is encoded");
|
||||
+ free(fiemap);
|
||||
+ return -1;
|
||||
+ }
|
||||
+ /*
|
||||
+ * returned extent may start prior to our request
|
||||
+ */
|
||||
+ map_offset = fiemap->fm_start -
|
||||
+ fiemap->fm_extents[0].fe_logical;
|
||||
+ mapped = fiemap->fm_extents[0].fe_physical +
|
||||
+ map_offset;
|
||||
+ /* set mapped to fs block units */
|
||||
+ mapped = mapped / info->fs_block_size;
|
||||
+ } else {
|
||||
+ mapped = 0;
|
||||
+ }
|
||||
}
|
||||
+
|
||||
+ free(fiemap);
|
||||
+
|
||||
if (mapped == 0) {
|
||||
/* This is a hole in the file */
|
||||
*physical = 0;
|
@ -1,56 +0,0 @@
|
||||
From c33cc5a6198a9d32c2fe8da8cd3038627d99ebab Mon Sep 17 00:00:00 2001
|
||||
From: Ingo Franzki <ifranzki@linux.ibm.com>
|
||||
Date: Wed, 17 Oct 2018 13:52:48 +0200
|
||||
Subject: [PATCH] zkey: Makefile: Avoid relink of modules during 'make install'
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Because targets check-dep-zkey and check-dep-zkey-cryptsetup
|
||||
do not produce any file, any targets that have a pre-req on those
|
||||
targets are rebuilt during 'make install'.
|
||||
|
||||
Also correct .PHONY targets.
|
||||
|
||||
Fixes: https://github.com/ibm-s390-tools/s390-tools/issues/46
|
||||
Signed-off-by: Ingo Franzki <ifranzki@linux.ibm.com>
|
||||
Signed-off-by: Jan Höppner <hoeppner@linux.ibm.com>
|
||||
---
|
||||
zkey/Makefile | 9 +++++++--
|
||||
1 file changed, 7 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/zkey/Makefile b/zkey/Makefile
|
||||
index 901ddd4..bc7bc33 100644
|
||||
--- a/zkey/Makefile
|
||||
+++ b/zkey/Makefile
|
||||
@@ -37,6 +37,7 @@ check-dep-zkey:
|
||||
"openssl/evp.h", \
|
||||
"openssl-devel", \
|
||||
"HAVE_OPENSSL=0")
|
||||
+ touch check-dep-zkey
|
||||
|
||||
check-dep-zkey-cryptsetup: detect-libcryptsetup.h
|
||||
$(call check_dep, \
|
||||
@@ -50,6 +51,7 @@ check-dep-zkey-cryptsetup: detect-libcryptsetup.h
|
||||
"json-c/json.h", \
|
||||
"json-c-devel", \
|
||||
"HAVE_JSONC=0")
|
||||
+ touch check-dep-zkey-cryptsetup
|
||||
|
||||
zkey-skip:
|
||||
echo " SKIP zkey due to HAVE_OPENSSL=0"
|
||||
@@ -93,6 +95,9 @@ install-zkey-cryptsetup:
|
||||
install: all install-common $(INSTALL_TARGETS)
|
||||
|
||||
clean:
|
||||
- rm -f *.o zkey zkey-cryptsetup detect-libcryptsetup.h
|
||||
+ rm -f *.o zkey zkey-cryptsetup detect-libcryptsetup.h \
|
||||
+ check-dep-zkey check-dep-zkey-cryptsetup
|
||||
|
||||
-.PHONY: all install clean
|
||||
+.PHONY: all install clean zkey-skip zkey-cryptsetup-skip-cryptsetup2 \
|
||||
+ zkey-cryptsetup-skip-jsonc install-common install-zkey \
|
||||
+ install-zkey-cryptsetup
|
||||
--
|
||||
2.17.2
|
||||
|
@ -4,8 +4,8 @@
|
||||
Name: s390utils
|
||||
Summary: Utilities and daemons for IBM z Systems
|
||||
Group: System Environment/Base
|
||||
Version: 2.6.0
|
||||
Release: 8%{?dist}
|
||||
Version: 2.7.0
|
||||
Release: 1%{?dist}
|
||||
Epoch: 2
|
||||
License: MIT
|
||||
ExclusiveArch: s390 s390x
|
||||
@ -31,13 +31,7 @@ Source24: 91-zipl.install
|
||||
|
||||
# change the defaults to match Fedora environment
|
||||
Patch0: s390-tools-zipl-invert-script-options.patch
|
||||
# https://github.com/ibm-s390-tools/s390-tools/pull/36
|
||||
Patch1: s390-tools-zipl-fiemap.patch
|
||||
# https://github.com/ibm-s390-tools/s390-tools/pull/35
|
||||
Patch2: s390-tools-cleanup.patch
|
||||
Patch3: 0007-blscfg-sort-like-rpm-nvr-not-like-a-single-version.patch
|
||||
# https://github.com/ibm-s390-tools/s390-tools/issues/46
|
||||
Patch4: s390-tools-zkey-no-relink.patch
|
||||
|
||||
Patch1000: cmsfs-1.1.8-warnings.patch
|
||||
Patch1001: cmsfs-1.1.8-kernel26.patch
|
||||
@ -67,10 +61,7 @@ be used together with the zSeries (s390) Linux kernel and device drivers.
|
||||
|
||||
# Fedora/RHEL changes
|
||||
%patch0 -p1 -b .zipl-invert-script-options
|
||||
%patch1 -p1 -b .zipl-fiemap
|
||||
%patch2 -p1 -b .cleanup
|
||||
%patch3 -p1 -b .blscfg-rpm-nvr-sort
|
||||
%patch4 -p1 -b .zkey-no-relink
|
||||
|
||||
#
|
||||
# cmsfs
|
||||
@ -399,11 +390,13 @@ systemctl --no-reload preset device_cio_free.service >/dev/null 2>&1 || :
|
||||
%{_sbindir}/vmcp
|
||||
%{_sbindir}/vmur
|
||||
%{_sbindir}/xcec-bridge
|
||||
%{_sbindir}/zcryptctl
|
||||
%{_sbindir}/zfcpdbf
|
||||
%{_sbindir}/zgetdump
|
||||
%{_sbindir}/zipl
|
||||
%{_sbindir}/zipl-switch-to-blscfg
|
||||
%{_sbindir}/znetconf
|
||||
%{_sbindir}/zpcictl
|
||||
%{_bindir}/lscpumf
|
||||
%{_bindir}/dump2tar
|
||||
%{_bindir}/vmconvert
|
||||
@ -462,9 +455,11 @@ systemctl --no-reload preset device_cio_free.service >/dev/null 2>&1 || :
|
||||
%{_mandir}/man8/tunedasd.8*
|
||||
%{_mandir}/man8/vmcp.8*
|
||||
%{_mandir}/man8/vmur.8*
|
||||
%{_mandir}/man8/zcryptctl.8*
|
||||
%{_mandir}/man8/zgetdump.8*
|
||||
%{_mandir}/man8/znetconf.8*
|
||||
%{_mandir}/man8/zipl.8*
|
||||
%{_mandir}/man8/zpcictl.8*
|
||||
%dir %{_datadir}/s390-tools/
|
||||
%{_datadir}/s390-tools/cpumf/
|
||||
%{_datadir}/s390-tools/netboot/
|
||||
@ -816,6 +811,9 @@ User-space development files for the s390/s390x architecture.
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Oct 31 2018 Dan Horák <dan[at]danny.cz> - 2:2.7.0-1
|
||||
- rebased to 2.7.0
|
||||
|
||||
* Mon Oct 22 2018 Dan Horák <dan[at]danny.cz> - 2:2.6.0-8
|
||||
- don't relink the zkey tools
|
||||
|
||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (cmsfs-1.1.8c.tar.gz) = 2ba5687d378fdd9871283728e81f1399047e74f9bba3936726eda11a978fe6ced1a300f15acb871d5daa26e61069d89767c753cf584f2731f5e99985db96aef0
|
||||
SHA512 (src_vipa-2.1.0.tar.gz) = 8f6048e82b4bcc479dfb09d62da64b9519f66efc31889ff795ee6ca107e262167df57628c305f1b899c41bb3f035e6309552d8548c890855d319e8e60d6a6cf7
|
||||
SHA512 (s390-tools-2.6.0.tar.gz) = 0f35eae85896c4fbc784d0e0549c7856741e7d8ba979f2897c6f546987485d19019dac36b9443d2ff10f8da3128de2203c7526fac480756388fc61380a93536e
|
||||
SHA512 (s390-tools-2.7.0.tar.gz) = f1c41f251d77ab7776def1569c2e8c424571b1fda9b3d6921fcf65bbfaa7c9dfc585a89e839ba00813ce4ee462ff525e3cf36d6dd02bf64b62ae81f2d4b7ca7d
|
||||
|
Loading…
Reference in New Issue
Block a user