- rebased to 2.3.0

This commit is contained in:
Rafael Santos 2018-02-21 13:29:42 +01:00
parent 6e58e0e033
commit 00a29e6617
4 changed files with 7 additions and 115 deletions

1
.gitignore vendored
View File

@ -8,3 +8,4 @@ src_vipa-2.0.4.tar.gz
/s390-tools-2.0.0.tar.gz
/s390-tools-2.1.0.tar.gz
/s390-tools-2.2.0.tar.gz
/s390-tools-2.3.0.tar.gz

View File

@ -1,107 +0,0 @@
From 05de40cdeb0e1343343692e621a4bd6010d8cf6b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Mon, 22 Jan 2018 12:32:19 +0100
Subject: [PATCH] Replace delimiter char in sed expressions
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Use a character, that can't be used in rpm Version and Release tag, as
the delimiter in sed expressions.
Fixes: #25
Signed-off-by: Dan Horák <dan@danny.cz>
Signed-off-by: Michael Holzheu <holzheu@linux.vnet.ibm.com>
---
hmcdrvfs/Makefile | 2 +-
ip_watcher/Makefile | 2 +-
qethconf/Makefile | 2 +-
scripts/Makefile | 4 ++--
zconf/Makefile | 4 ++--
5 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/hmcdrvfs/Makefile b/hmcdrvfs/Makefile
index 5144c15..5d81031 100644
--- a/hmcdrvfs/Makefile
+++ b/hmcdrvfs/Makefile
@@ -49,7 +49,7 @@ install: all install-scripts
install-scripts: lshmc
@for i in $^; do \
cat $$i | \
- sed -e 's+%S390_TOOLS_VERSION%+$(S390_TOOLS_RELEASE)+' \
+ sed -e 's/%S390_TOOLS_VERSION%/$(S390_TOOLS_RELEASE)/' \
>$(DESTDIR)$(USRSBINDIR)/$$i; \
chown $(OWNER).$(GROUP) $(DESTDIR)$(USRSBINDIR)/$$i; \
chmod 755 $(DESTDIR)$(USRSBINDIR)/$$i; \
diff --git a/ip_watcher/Makefile b/ip_watcher/Makefile
index d0190e7..0e9df39 100644
--- a/ip_watcher/Makefile
+++ b/ip_watcher/Makefile
@@ -8,7 +8,7 @@ clean:
rm -f *.o core xcec-bridge
install: ip_watcher.pl xcec-bridge start_hsnc.sh
- $(SED) -e 's+%S390_TOOLS_VERSION%+$(S390_TOOLS_RELEASE)+' \
+ $(SED) -e 's/%S390_TOOLS_VERSION%/$(S390_TOOLS_RELEASE)/' \
< start_hsnc.sh >$(DESTDIR)$(USRSBINDIR)/start_hsnc.sh; \
chown $(OWNER).$(GROUP) $(DESTDIR)$(USRSBINDIR)/start_hsnc.sh; \
chmod 755 $(DESTDIR)$(USRSBINDIR)/start_hsnc.sh; \
diff --git a/qethconf/Makefile b/qethconf/Makefile
index e320b45..0b099a2 100644
--- a/qethconf/Makefile
+++ b/qethconf/Makefile
@@ -3,7 +3,7 @@ include ../common.mak
all:
install: qethconf
- $(SED) -e 's+%S390_TOOLS_VERSION%+$(S390_TOOLS_RELEASE)+' \
+ $(SED) -e 's/%S390_TOOLS_VERSION%/$(S390_TOOLS_RELEASE)/' \
< qethconf >$(DESTDIR)$(BINDIR)/qethconf; \
chown $(OWNER).$(GROUP) $(DESTDIR)$(BINDIR)/qethconf; \
chmod 755 $(DESTDIR)$(BINDIR)/qethconf; \
diff --git a/scripts/Makefile b/scripts/Makefile
index f0c2ff7..dc5b0f0 100644
--- a/scripts/Makefile
+++ b/scripts/Makefile
@@ -10,13 +10,13 @@ install:
@for i in $(SCRIPTS); \
do \
cat $$i | \
- sed -e 's+%S390_TOOLS_VERSION%+$(S390_TOOLS_RELEASE)+' \
+ sed -e 's/%S390_TOOLS_VERSION%/$(S390_TOOLS_RELEASE)/' \
>$(DESTDIR)$(BINDIR)/$$i; \
chown $(OWNER):$(GROUP) $(DESTDIR)$(BINDIR)/$$i; \
chmod 755 $(DESTDIR)$(BINDIR)/$$i; \
done
- sed -e 's+%S390_TOOLS_VERSION%+$(S390_TOOLS_RELEASE)+' cpictl > \
+ sed -e 's/%S390_TOOLS_VERSION%/$(S390_TOOLS_RELEASE)/' cpictl > \
$(DESTDIR)$(TOOLS_LIBDIR)/cpictl
chown $(OWNER):$(GROUP) $(DESTDIR)$(TOOLS_LIBDIR)/cpictl
chmod 775 $(DESTDIR)$(TOOLS_LIBDIR)/cpictl
diff --git a/zconf/Makefile b/zconf/Makefile
index a4acd8f..008b598 100644
--- a/zconf/Makefile
+++ b/zconf/Makefile
@@ -23,7 +23,7 @@ install: install-scripts install-manpages install-usrsbin-scripts $(SUB_DIRS)
install-scripts: $(SCRIPTS)
@for i in $^; do \
cat $$i | \
- sed -e 's+%S390_TOOLS_VERSION%+$(S390_TOOLS_RELEASE)+' \
+ sed -e 's/%S390_TOOLS_VERSION%/$(S390_TOOLS_RELEASE)/' \
>$(DESTDIR)$(BINDIR)/$$i; \
chown $(OWNER).$(GROUP) $(DESTDIR)$(BINDIR)/$$i; \
chmod 755 $(DESTDIR)$(BINDIR)/$$i; \
@@ -32,7 +32,7 @@ install-scripts: $(SCRIPTS)
install-usrsbin-scripts: $(USRSBIN_SCRIPTS)
@for i in $^; do \
cat $$i | \
- sed -e 's+%S390_TOOLS_VERSION%+$(S390_TOOLS_RELEASE)+' \
+ sed -e 's/%S390_TOOLS_VERSION%/$(S390_TOOLS_RELEASE)/' \
>$(DESTDIR)$(USRSBINDIR)/$$i; \
chown $(OWNER).$(GROUP) $(DESTDIR)$(USRSBINDIR)/$$i; \
chmod 755 $(DESTDIR)$(USRSBINDIR)/$$i; \
--
2.13.6

View File

@ -4,8 +4,8 @@
Name: s390utils
Summary: Utilities and daemons for IBM z Systems
Group: System Environment/Base
Version: 2.2.0
Release: 3%{?dist}
Version: 2.3.0
Release: 1%{?dist}
Epoch: 2
License: MIT
ExclusiveArch: s390 s390x
@ -28,9 +28,6 @@ Source16: ccw_init
Source17: ccw.udev
Source21: normalize_dasd_arg
# https://github.com/ibm-s390-tools/s390-tools/commit/05de40cdeb0e1343343692e621a4bd6010d8cf6b
Patch0: s390-tools-2.2.0-delim.patch
Patch1000: cmsfs-1.1.8-warnings.patch
Patch1001: cmsfs-1.1.8-kernel26.patch
Patch1002: cmsfs-1.1.8-use-detected-filesystem-block-size-on-FBA-devices.patch
@ -54,7 +51,6 @@ be used together with the zSeries (s390) Linux kernel and device drivers.
%prep
%setup -q -n s390-tools-%{version} -a 4 -a 6
%patch0 -p1
# Fedora/RHEL changes
# none
@ -789,6 +785,9 @@ User-space development files for the s390/s390x architecture.
%changelog
* Wed Feb 21 2018 Rafael Santos <rdossant@redhat.com> - 2:2.3.0-1
- rebased to 2.3.0
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2:2.2.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

View File

@ -1,4 +1,3 @@
SHA512 (cmsfs-1.1.8c.tar.gz) = 2ba5687d378fdd9871283728e81f1399047e74f9bba3936726eda11a978fe6ced1a300f15acb871d5daa26e61069d89767c753cf584f2731f5e99985db96aef0
SHA512 (src_vipa-2.1.0.tar.gz) = 8f6048e82b4bcc479dfb09d62da64b9519f66efc31889ff795ee6ca107e262167df57628c305f1b899c41bb3f035e6309552d8548c890855d319e8e60d6a6cf7
SHA512 (s390-tools-2.1.0.tar.gz) = a1e2f7cda8a16f9ea3c5e7bfe118dd8044542b4fee7086a3656fc985f64170e29884177004265e9f0802c45fa04057edf665feccebeb38dc0f5515093ccf31aa
SHA512 (s390-tools-2.2.0.tar.gz) = f029b92f18f95b49e189a4f5ad78c02ee629e630a93a8bbfe6966030fe8aaf069e86582d77213d68b447300b73317e4dbcb228df5ff0795a2785f6735087ceab
SHA512 (s390-tools-2.3.0.tar.gz) = a4733eda8ba55bacfd07b000abe72e1f17f0ece774205649ae97115646253231230d2dc579d83d6f2018cc88d7c9240862e37387d1f18dac2928938b09605838