auto-import changelog data from rwall-0.17-5.src.rpm
Sat Aug 05 2000 Bill Nottingham <notting@redhat.com> - condrestart fixes Thu Jul 20 2000 Bill Nottingham <notting@redhat.com> - move initscript back Wed Jul 12 2000 Prospector <bugzilla@redhat.com> - automatic rebuild Mon Jul 10 2000 Preston Brown <pbrown@redhat.com> - move initscript Sun Jun 18 2000 Jeff Johnson <jbj@redhat.com> - FHS packaging. - update to 0.17. Fri Feb 11 2000 Bill Nottingham <notting@redhat.com> - fix description Mon Feb 07 2000 Jeff Johnson <jbj@redhat.com> - compress man pages. Sat Feb 05 2000 Florian La Roche <Florian.LaRoche@redhat.com> - change %postun to %preun Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com> - fix descriptions and summary - man pages are compressed Tue Jan 04 2000 Bill Nottingham <notting@redhat.com> - split client and server Tue Dec 21 1999 Jeff Johnson <jbj@redhat.com> - update to 0.16. Mon Aug 16 1999 Bill Nottingham <notting@redhat.com> - initscript munging Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com> - auto rebuild in the new build environment (release 22) Mon Mar 15 1999 Jeff Johnson <jbj@redhat.com> - compile for 6.0. Tue May 05 1998 Prospector System <bugs@redhat.com> - translations modified for de, fr, tr Sat May 02 1998 Cristian Gafton <gafton@redhat.com> - enhanced initscript Tue Oct 28 1997 Erik Troan <ewt@redhat.com> - fixed init script (didn't include function library) - doesn't invoke wall with -n anymore Sun Oct 19 1997 Erik Troan <ewt@redhat.com> - added a chkconfig compatible initscript - added %attr attributes Tue Jul 15 1997 Erik Troan <ewt@redhat.com> - initial build
This commit is contained in:
parent
6f532e510f
commit
46a547716e
@ -0,0 +1 @@
|
||||
netkit-rwall-0.17-pre20000412.tar.gz
|
11
netkit-rwalld-0.10-banner.patch
Normal file
11
netkit-rwalld-0.10-banner.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- netkit-rwall-0.10/rpc.rwalld/rwalld.c.ewt Tue Oct 28 11:54:11 1997
|
||||
+++ netkit-rwall-0.10/rpc.rwalld/rwalld.c Tue Oct 28 11:54:18 1997
|
||||
@@ -59,7 +59,7 @@
|
||||
#ifdef OSF
|
||||
#define WALL_CMD "/usr/sbin/wall"
|
||||
#else
|
||||
-#define WALL_CMD "/usr/bin/wall -n"
|
||||
+#define WALL_CMD "/usr/bin/wall"
|
||||
#endif
|
||||
|
||||
void wallprog_1(struct svc_req *rqstp, SVCXPRT *transp);
|
148
rwall.spec
Normal file
148
rwall.spec
Normal file
@ -0,0 +1,148 @@
|
||||
%define _snapshot -pre20000412
|
||||
Summary: Client for sending messages to a host's logged in users.
|
||||
Name: rwall
|
||||
Version: 0.17
|
||||
Release: 5
|
||||
Copyright: BSD
|
||||
Group: System Environment/Daemons
|
||||
Source: ftp://ftp.uk.linux.org/pub/linux/Networking/netkit-devel/netkit-rwall-%{version}%{_snapshot}.tar.gz
|
||||
Source1: rwalld.init
|
||||
Patch1: netkit-rwalld-0.10-banner.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-root
|
||||
|
||||
%description
|
||||
The rwall command sends a message to all of the users logged into a
|
||||
specified host. Actually, your machine's rwall client sends the
|
||||
message to the rwall daemon running on the specified host, and the
|
||||
rwall daemon relays the message to all of the users logged in to that
|
||||
host.
|
||||
|
||||
Install rwall if you'd like the ability to send messages to users
|
||||
logged in to a specified host machine.
|
||||
|
||||
%package server
|
||||
Summary: Server for sending messages to a host's logged in users.
|
||||
Prereq: /sbin/chkconfig /etc/init.d
|
||||
Group: System Environment/Daemons
|
||||
Requires: portmap
|
||||
|
||||
%description server
|
||||
The rwall command sends a message to all of the users logged into
|
||||
a specified host. The rwall-server package contains the daemon for
|
||||
receiving such messages, and is disabled by default on Red Hat Linux
|
||||
systems (it can be very annoying to keep getting all those messages
|
||||
when you're trying to play Quake--I mean, trying to get some work done).
|
||||
|
||||
Install rwall-server if you'd like the ability to receive messages
|
||||
from users on remote hosts.
|
||||
|
||||
%prep
|
||||
%setup -q -n netkit-rwall-%{version}%{_snapshot}
|
||||
%patch1 -p1 -b .banner
|
||||
|
||||
%build
|
||||
sh configure
|
||||
perl -pi -e '
|
||||
s,^CC=.*$,CC=cc,;
|
||||
s,-O2,\$(RPM_OPT_FLAGS),;
|
||||
s,^BINDIR=.*$,BINDIR=%{_bindir},;
|
||||
s,^MANDIR=.*$,MANDIR=%{_mandir},;
|
||||
s,^SBINDIR=.*$,SBINDIR=%{_sbindir},;
|
||||
' MCONFIG
|
||||
|
||||
make RPM_OPT_FLAGS="$RPM_OPT_FLAGS"
|
||||
|
||||
%install
|
||||
rm -rf ${RPM_BUILD_ROOT}
|
||||
mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
|
||||
mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
|
||||
mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man{1,8}
|
||||
mkdir -p ${RPM_BUILD_ROOT}/etc/rc.d/init.d
|
||||
|
||||
make INSTALLROOT=${RPM_BUILD_ROOT} install
|
||||
install -m 755 $RPM_SOURCE_DIR/rwalld.init ${RPM_BUILD_ROOT}/etc/rc.d/init.d/rwalld
|
||||
|
||||
%clean
|
||||
rm -rf ${RPM_BUILD_ROOT}
|
||||
|
||||
%post server
|
||||
/sbin/chkconfig --add rwalld
|
||||
|
||||
%preun server
|
||||
if [ $1 = 0 ]; then
|
||||
/sbin/chkconfig --del rwalld
|
||||
fi
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/rwall
|
||||
%{_mandir}/man1/rwall.1*
|
||||
|
||||
%files server
|
||||
%defattr(-,root,root)
|
||||
%{_sbindir}/rpc.rwalld
|
||||
%{_mandir}/man8/rpc.rwalld.8*
|
||||
%{_mandir}/man8/rwalld.8*
|
||||
%config /etc/rc.d/init.d/rwalld
|
||||
|
||||
%changelog
|
||||
* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
|
||||
- condrestart fixes
|
||||
|
||||
* Thu Jul 20 2000 Bill Nottingham <notting@redhat.com>
|
||||
- move initscript back
|
||||
|
||||
* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
|
||||
- automatic rebuild
|
||||
|
||||
* Mon Jul 10 2000 Preston Brown <pbrown@redhat.com>
|
||||
- move initscript
|
||||
|
||||
* Sun Jun 18 2000 Jeff Johnson <jbj@redhat.com>
|
||||
- FHS packaging.
|
||||
- update to 0.17.
|
||||
|
||||
* Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
|
||||
- fix description
|
||||
|
||||
* Mon Feb 7 2000 Jeff Johnson <jbj@redhat.com>
|
||||
- compress man pages.
|
||||
|
||||
* Sat Feb 5 2000 Florian La Roche <Florian.LaRoche@redhat.com>
|
||||
- change %postun to %preun
|
||||
|
||||
* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
|
||||
- fix descriptions and summary
|
||||
- man pages are compressed
|
||||
|
||||
* Mon Jan 4 2000 Bill Nottingham <notting@redhat.com>
|
||||
- split client and server
|
||||
|
||||
* Tue Dec 21 1999 Jeff Johnson <jbj@redhat.com>
|
||||
- update to 0.16.
|
||||
|
||||
* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
|
||||
- initscript munging
|
||||
|
||||
* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
|
||||
- auto rebuild in the new build environment (release 22)
|
||||
|
||||
* Mon Mar 15 1999 Jeff Johnson <jbj@redhat.com>
|
||||
- compile for 6.0.
|
||||
|
||||
* Tue May 05 1998 Prospector System <bugs@redhat.com>
|
||||
- translations modified for de, fr, tr
|
||||
|
||||
* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
|
||||
- enhanced initscript
|
||||
|
||||
* Tue Oct 28 1997 Erik Troan <ewt@redhat.com>
|
||||
- fixed init script (didn't include function library)
|
||||
- doesn't invoke wall with -n anymore
|
||||
|
||||
* Sun Oct 19 1997 Erik Troan <ewt@redhat.com>
|
||||
- added a chkconfig compatible initscript
|
||||
- added %attr attributes
|
||||
|
||||
* Tue Jul 15 1997 Erik Troan <ewt@redhat.com>
|
||||
- initial build
|
68
rwalld.init
Executable file
68
rwalld.init
Executable file
@ -0,0 +1,68 @@
|
||||
#! /bin/sh
|
||||
#
|
||||
# chkconfig: - 60 20
|
||||
# description: The rwall protocol allows remote users to display messages \
|
||||
# on all of the active terminals on a system (like local \
|
||||
# users can do with the wall command).
|
||||
# processname: rpc.rwalld
|
||||
|
||||
# Source function library.
|
||||
. /etc/init.d/functions
|
||||
|
||||
# Get config.
|
||||
. /etc/sysconfig/network
|
||||
|
||||
# Check that networking is up.
|
||||
if [ ${NETWORKING} = "no" ] ; then
|
||||
exit 0
|
||||
fi
|
||||
|
||||
RETVAL=0
|
||||
|
||||
start() {
|
||||
echo -n "Starting rwall services: "
|
||||
daemon rpc.rwalld
|
||||
RETVAL=$?
|
||||
echo
|
||||
[ $RETVAL -eq 0 ] && touch /var/lock/subsys/rwalld
|
||||
return $RETVAL
|
||||
}
|
||||
|
||||
stop() {
|
||||
echo -n "Stopping rwall services: "
|
||||
killproc rpc.rwalld
|
||||
RETVAL=$?
|
||||
echo
|
||||
[ $RETVAL -eq 0 ] && rm -f /var/lock/subsys/rwalld
|
||||
return $RETVAL
|
||||
}
|
||||
|
||||
restart() {
|
||||
stop
|
||||
start
|
||||
}
|
||||
|
||||
# See how we were called.
|
||||
case "$1" in
|
||||
start)
|
||||
start
|
||||
;;
|
||||
stop)
|
||||
stop
|
||||
;;
|
||||
status)
|
||||
status rpc.rwalld
|
||||
;;
|
||||
condrestart)
|
||||
[ -f /var/lock/subsys/rwalld ] && restart || :
|
||||
;;
|
||||
restart|reload)
|
||||
restart
|
||||
;;
|
||||
*)
|
||||
echo "Usage: rwalld {start|stop|status|restart}"
|
||||
exit 1
|
||||
;;
|
||||
esac
|
||||
|
||||
exit $?
|
Loading…
Reference in New Issue
Block a user