2e8923ba1c
python3-rpm is added (temporarily) to work around https://bugzilla.redhat.com/show_bug.cgi?id=2275274. The binutils-gold dependency is needed for one test. Previously binutils implicitly dependend on binutils-gold. Backport https://github.com/rust-lang/rust/pull/126263 to fix one codegen test failure on s390x. There are some additional test failures on ppc64le and s390x for which I have filed https://github.com/rust-lang/rust/issues/126260 and https://github.com/rust-lang/rust/issues/126261.
24 lines
1.1 KiB
Diff
24 lines
1.1 KiB
Diff
diff -up rustc-beta-src/src/tools/cargo/Cargo.lock.orig rustc-beta-src/src/tools/cargo/Cargo.lock
|
|
--- rustc-beta-src/src/tools/cargo/Cargo.lock.orig 2006-07-24 10:21:28.000000000 +0900
|
|
+++ rustc-beta-src/src/tools/cargo/Cargo.lock 2024-05-06 14:13:00.172595245 +0900
|
|
@@ -2191,7 +2191,6 @@ version = "0.28.0"
|
|
source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
checksum = "0c10584274047cb335c23d3e61bcef8e323adae7c5c8c760540f73610177fc3f"
|
|
dependencies = [
|
|
- "cc",
|
|
"pkg-config",
|
|
"vcpkg",
|
|
]
|
|
diff -up rustc-beta-src/src/tools/cargo/Cargo.toml.orig rustc-beta-src/src/tools/cargo/Cargo.toml
|
|
--- rustc-beta-src/src/tools/cargo/Cargo.toml.orig 2024-05-06 14:13:00.173595257 +0900
|
|
+++ rustc-beta-src/src/tools/cargo/Cargo.toml 2024-05-06 14:13:54.089275003 +0900
|
|
@@ -77,7 +77,7 @@ proptest = "1.4.0"
|
|
pulldown-cmark = { version = "0.10.2", default-features = false, features = ["html"] }
|
|
rand = "0.8.5"
|
|
regex = "1.10.4"
|
|
-rusqlite = { version = "0.31.0", features = ["bundled"] }
|
|
+rusqlite = { version = "0.31.0", features = [] }
|
|
rustfix = { version = "0.8.2", path = "crates/rustfix" }
|
|
same-file = "1.0.6"
|
|
security-framework = "2.10.0"
|