rust/rustc-1.44.0-disable-http2....

67 lines
2.3 KiB
Diff

--- rustc-1.44.0-src/Cargo.lock.orig 2020-06-01 08:44:15.000000000 -0700
+++ rustc-1.44.0-src/Cargo.lock 2020-06-04 15:54:08.234883383 -0700
@@ -817,7 +817,6 @@
dependencies = [
"cc",
"libc",
- "libnghttp2-sys",
"libz-sys",
"openssl-sys",
"pkg-config",
@@ -1808,16 +1807,6 @@
]
[[package]]
-name = "libnghttp2-sys"
-version = "0.1.2"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "02254d44f4435dd79e695f2c2b83cd06a47919adea30216ceaf0c57ca0a72463"
-dependencies = [
- "cc",
- "libc",
-]
-
-[[package]]
name = "libssh2-sys"
version = "0.2.14"
source = "registry+https://github.com/rust-lang/crates.io-index"
--- rustc-1.44.0-src/src/tools/cargo/Cargo.toml.orig 2020-06-01 08:44:43.000000000 -0700
+++ rustc-1.44.0-src/src/tools/cargo/Cargo.toml 2020-06-04 15:54:08.234883383 -0700
@@ -25,7 +25,7 @@
crates-io = { path = "crates/crates-io", version = "0.31" }
crossbeam-utils = "0.7"
crypto-hash = "0.3.1"
-curl = { version = "0.4.23", features = ["http2"] }
+curl = { version = "0.4.23", features = [] }
curl-sys = "0.4.22"
env_logger = "0.7.0"
pretty_env_logger = { version = "0.4", optional = true }
--- rustc-1.44.0-src/src/tools/cargo/src/cargo/core/package.rs.orig 2020-06-01 08:44:43.000000000 -0700
+++ rustc-1.44.0-src/src/tools/cargo/src/cargo/core/package.rs 2020-06-04 15:54:08.234883383 -0700
@@ -385,14 +385,8 @@
// Also note that pipelining is disabled as curl authors have indicated
// that it's buggy, and we've empirically seen that it's buggy with HTTP
// proxies.
- let mut multi = Multi::new();
- let multiplexing = config.http_config()?.multiplexing.unwrap_or(true);
- multi
- .pipelining(false, multiplexing)
- .chain_err(|| "failed to enable multiplexing/pipelining in curl")?;
-
- // let's not flood crates.io with connections
- multi.set_max_host_connections(2)?;
+ let multi = Multi::new();
+ let multiplexing = false;
Ok(PackageSet {
packages: package_ids
@@ -562,7 +556,7 @@
macro_rules! try_old_curl {
($e:expr, $msg:expr) => {
let result = $e;
- if cfg!(target_os = "macos") {
+ if cfg!(any(target_os = "linux", target_os = "macos")) {
if let Err(e) = result {
warn!("ignoring libcurl {} error: {}", $msg, e);
}