rust/0001-compiler_builtins-disable-f16-and-f128.patch
David Abdurachmanov e94c6d60ff
Compile with f16 and f128 disabled
Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
2024-11-14 15:13:35 +02:00

30 lines
972 B
Diff

From 0d289c6b0bbb50f62e3ca388124c29aa9127e6b9 Mon Sep 17 00:00:00 2001
From: David Abdurachmanov <davidlt@rivosinc.com>
Date: Thu, 14 Nov 2024 13:10:26 +0000
Subject: [PATCH] compiler_builtins: disable f16 and f128
This is needed to get 1.82.0 compiled. 1.81.0 as a boostrap compiler
will fail as-is.
Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
---
library/alloc/Cargo.toml | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/library/alloc/Cargo.toml b/library/alloc/Cargo.toml
index 4365bcc4a..7849d463b 100644
--- a/library/alloc/Cargo.toml
+++ b/library/alloc/Cargo.toml
@@ -10,7 +10,7 @@ edition = "2021"
[dependencies]
core = { path = "../core" }
-compiler_builtins = { version = "0.1.123", features = ['rustc-dep-of-std'] }
+compiler_builtins = { version = "0.1.123", features = ['rustc-dep-of-std', 'no-f16-f128'] }
[dev-dependencies]
rand = { version = "0.8.5", default-features = false, features = ["alloc"] }
--
2.47.0