28 lines
841 B
Diff
28 lines
841 B
Diff
From f25809d2d33e1141d73487e55fe155f41762aef3 Mon Sep 17 00:00:00 2001
|
|
From: onur-ozkan <work@onurozkan.dev>
|
|
Date: Sun, 10 Mar 2024 09:16:24 +0300
|
|
Subject: [PATCH] fix `long-linker-command-lines` failure caused by
|
|
`rust.rpath=false`
|
|
|
|
Signed-off-by: onur-ozkan <work@onurozkan.dev>
|
|
---
|
|
tests/run-make/long-linker-command-lines/Makefile | 2 ++
|
|
1 file changed, 2 insertions(+)
|
|
|
|
diff --git a/tests/run-make/long-linker-command-lines/Makefile b/tests/run-make/long-linker-command-lines/Makefile
|
|
index f864ea74f4a9..b573038e344a 100644
|
|
--- a/tests/run-make/long-linker-command-lines/Makefile
|
|
+++ b/tests/run-make/long-linker-command-lines/Makefile
|
|
@@ -1,6 +1,8 @@
|
|
# ignore-cross-compile
|
|
include ../tools.mk
|
|
|
|
+export LD_LIBRARY_PATH := $(HOST_RPATH_DIR)
|
|
+
|
|
all:
|
|
$(RUSTC) foo.rs -g -O
|
|
RUSTC="$(RUSTC_ORIGINAL)" $(call RUN,foo)
|
|
--
|
|
2.44.0
|
|
|