e605359b2b
Revert to libgit2 1.3.x
67 lines
2.5 KiB
Diff
67 lines
2.5 KiB
Diff
--- rustc-1.59.0-src/Cargo.lock.orig 2022-02-22 10:19:00.330367749 -0800
|
|
+++ rustc-1.59.0-src/Cargo.lock 2022-02-22 10:19:00.332367706 -0800
|
|
@@ -909,7 +909,6 @@
|
|
dependencies = [
|
|
"cc",
|
|
"libc",
|
|
- "libnghttp2-sys",
|
|
"libz-sys",
|
|
"openssl-sys",
|
|
"pkg-config",
|
|
@@ -1957,16 +1956,6 @@
|
|
checksum = "7fc7aa29613bd6a620df431842069224d8bc9011086b1db4c0e0cd47fa03ec9a"
|
|
|
|
[[package]]
|
|
-name = "libnghttp2-sys"
|
|
-version = "0.1.4+1.41.0"
|
|
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
-checksum = "03624ec6df166e79e139a2310ca213283d6b3c30810c54844f307086d4488df1"
|
|
-dependencies = [
|
|
- "cc",
|
|
- "libc",
|
|
-]
|
|
-
|
|
-[[package]]
|
|
name = "libz-sys"
|
|
version = "1.1.3"
|
|
source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
--- rustc-1.59.0-src/src/tools/cargo/Cargo.toml.orig 2022-02-22 10:19:00.332367706 -0800
|
|
+++ rustc-1.59.0-src/src/tools/cargo/Cargo.toml 2022-02-22 10:19:54.029231795 -0800
|
|
@@ -22,7 +22,7 @@
|
|
cargo-util = { path = "crates/cargo-util", version = "0.1.2" }
|
|
crates-io = { path = "crates/crates-io", version = "0.33.1" }
|
|
crossbeam-utils = "0.8"
|
|
-curl = { version = "0.4.41", features = ["http2"] }
|
|
+curl = { version = "0.4.41", features = [] }
|
|
curl-sys = "0.4.50"
|
|
env_logger = "0.9.0"
|
|
pretty_env_logger = { version = "0.4", optional = true }
|
|
--- rustc-1.59.0-src/src/tools/cargo/src/cargo/core/package.rs.orig 2022-02-21 18:48:53.000000000 -0800
|
|
+++ rustc-1.59.0-src/src/tools/cargo/src/cargo/core/package.rs 2022-02-22 10:19:00.332367706 -0800
|
|
@@ -419,14 +419,8 @@
|
|
// Also note that pipelining is disabled as curl authors have indicated
|
|
// that it's buggy, and we've empirically seen that it's buggy with HTTP
|
|
// proxies.
|
|
- let mut multi = Multi::new();
|
|
- let multiplexing = config.http_config()?.multiplexing.unwrap_or(true);
|
|
- multi
|
|
- .pipelining(false, multiplexing)
|
|
- .with_context(|| "failed to enable multiplexing/pipelining in curl")?;
|
|
-
|
|
- // let's not flood crates.io with connections
|
|
- multi.set_max_host_connections(2)?;
|
|
+ let multi = Multi::new();
|
|
+ let multiplexing = false;
|
|
|
|
Ok(PackageSet {
|
|
packages: package_ids
|
|
@@ -655,7 +649,7 @@
|
|
macro_rules! try_old_curl {
|
|
($e:expr, $msg:expr) => {
|
|
let result = $e;
|
|
- if cfg!(target_os = "macos") {
|
|
+ if cfg!(any(target_os = "linux", target_os = "macos")) {
|
|
if let Err(e) = result {
|
|
warn!("ignoring libcurl {} error: {}", $msg, e);
|
|
}
|