Update patch to disable http2

This commit is contained in:
Josh Stone 2020-04-23 13:31:34 -07:00
parent c4e02f596e
commit d5bc581fc8
2 changed files with 14 additions and 14 deletions

View File

@ -86,7 +86,7 @@ Patch4: rust-pr70163-prepare-for-llvm-10-upgrade.patch
# libcurl on EL7 doesn't have http2, but since cargo requests it, curl-sys
# will try to build it statically -- instead we turn off the feature.
Patch10: rustc-1.42.0-disable-http2.patch
Patch10: rustc-1.43.0-disable-http2.patch
# Get the Rust triple for any arch.
%{lua: function rust_triple(arch)

View File

@ -1,6 +1,6 @@
--- rustc-1.42.0-src/Cargo.lock.orig 2020-03-09 15:11:17.000000000 -0700
+++ rustc-1.42.0-src/Cargo.lock 2020-03-12 15:42:18.942468302 -0700
@@ -818,7 +818,6 @@
--- rustc-1.43.0-src/Cargo.lock.orig 2020-04-20 15:17:56.000000000 -0700
+++ rustc-1.43.0-src/Cargo.lock 2020-04-23 13:27:41.781857941 -0700
@@ -798,7 +798,6 @@
dependencies = [
"cc",
"libc",
@ -8,7 +8,7 @@
"libz-sys",
"openssl-sys",
"pkg-config",
@@ -1803,16 +1802,6 @@
@@ -1782,16 +1781,6 @@
]
[[package]]
@ -25,20 +25,20 @@
name = "libssh2-sys"
version = "0.2.14"
source = "registry+https://github.com/rust-lang/crates.io-index"
--- rustc-1.42.0-src/src/tools/cargo/Cargo.toml.orig 2020-03-09 15:11:43.000000000 -0700
+++ rustc-1.42.0-src/src/tools/cargo/Cargo.toml 2020-03-12 15:41:33.787431876 -0700
@@ -25,7 +25,7 @@
crates-io = { path = "crates/crates-io", version = "0.31" }
--- rustc-1.43.0-src/src/tools/cargo/Cargo.toml.orig 2020-04-23 13:27:41.781857941 -0700
+++ rustc-1.43.0-src/src/tools/cargo/Cargo.toml 2020-04-23 13:29:31.355523076 -0700
@@ -26,7 +26,7 @@
crossbeam-channel = "0.4"
crossbeam-utils = "0.7"
crypto-hash = "0.3.1"
-curl = { version = "0.4.23", features = ["http2"] }
+curl = { version = "0.4.23", features = [] }
curl-sys = "0.4.22"
env_logger = "0.7.0"
pretty_env_logger = { version = "0.3", optional = true }
--- rustc-1.42.0-src/src/tools/cargo/src/cargo/core/package.rs.orig 2020-03-09 15:11:43.000000000 -0700
+++ rustc-1.42.0-src/src/tools/cargo/src/cargo/core/package.rs 2020-03-12 15:46:45.401782270 -0700
@@ -375,14 +375,8 @@
pretty_env_logger = { version = "0.4", optional = true }
--- rustc-1.43.0-src/src/tools/cargo/src/cargo/core/package.rs.orig 2020-04-20 15:19:12.000000000 -0700
+++ rustc-1.43.0-src/src/tools/cargo/src/cargo/core/package.rs 2020-04-23 13:27:41.782857920 -0700
@@ -378,14 +378,8 @@
// Also note that pipelining is disabled as curl authors have indicated
// that it's buggy, and we've empirically seen that it's buggy with HTTP
// proxies.
@ -55,7 +55,7 @@
Ok(PackageSet {
packages: package_ids
@@ -480,7 +474,7 @@
@@ -483,7 +477,7 @@
macro_rules! try_old_curl {
($e:expr, $msg:expr) => {
let result = $e;