beta test

This commit is contained in:
Josh Stone 2018-12-03 14:58:10 -08:00
parent 2f05e496e5
commit 6af1fde79b
2 changed files with 66 additions and 11 deletions

View File

@ -9,10 +9,10 @@
# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
# or nightly wants some beta-YYYY-MM-DD
# Note that cargo matches the program version here, not its crate version.
%global bootstrap_rust 1.29.2
%global bootstrap_cargo 1.29.0
%global bootstrap_rust 1.30.0
%global bootstrap_cargo 1.30.0
%global bootstrap_channel %{bootstrap_rust}
%global bootstrap_date 2018-10-12
%global bootstrap_date 2018-10-25
# Only the specified arches will use bootstrap binaries.
#global bootstrap_arches %%{rust_arches}
@ -55,15 +55,15 @@
# Some sub-packages are versioned independently of the rust compiler and runtime itself.
# Also beware that if any of these are not changed in a version bump, then the release
# number should still increase, not be reset to 1!
%global rustc_version 1.30.1
%global cargo_version 1.30.0
%global rustfmt_version 0.99.4
%global rls_version 0.130.5
%global rustc_version 1.31.0
%global cargo_version 1.31.0
%global rustfmt_version 1.0.0
%global rls_version 1.31.6
%global clippy_version 0.0.212
Name: rust
Version: %{rustc_version}
Release: 7%{?dist}
Release: 0.1.beta.17%{?dist}
Summary: The Rust Programming Language
License: (ASL 2.0 or MIT) and (BSD and MIT)
# ^ written as: (rust itself) and (bundled libraries)
@ -77,6 +77,10 @@ ExclusiveArch: %{rust_arches}
%endif
Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
# rustfmt->bytecount->simd only works on i686, x86_64, and aarch64
# https://github.com/rust-lang/rust/issues/56261
Patch1: rustfmt-bytecount-no-simd.patch
# Get the Rust triple for any arch.
%{lua: function rust_triple(arch)
local abi = "gnu"
@ -157,7 +161,7 @@ BuildRequires: %{python}
%if %with bundled_llvm
BuildRequires: cmake3 >= 3.4.3
Provides: bundled(llvm) = 7.0
Provides: bundled(llvm) = 8.0
%else
BuildRequires: cmake >= 2.8.11
%if 0%{?epel}
@ -359,7 +363,6 @@ reformatting, and code completion, and enables renaming and refactorings.
%package -n clippy-preview
Summary: Lints to catch common mistakes and improve your Rust code
Version: %{clippy_version}
License: MPLv2.0
Provides: clippy = %{clippy_version}
Requires: cargo
# /usr/bin/clippy-driver is dynamically linked against internal rustc libs
@ -400,6 +403,12 @@ test -f '%{local_rust_root}/bin/rustc'
%setup -q -n %{rustc_package}
# rustfmt->bytecount->simd only works on i686, x86_64, and aarch64
# https://github.com/rust-lang/rust/issues/56261
%ifnarch i686 x86_64 aarch64
%patch1 -p0
%endif
%if "%{python}" == "python3"
sed -i.try-py3 -e '/try python2.7/i try python3 "$@"' ./configure
%endif
@ -669,7 +678,7 @@ rm -f %{buildroot}%{rustlibdir}/etc/lldb_*.py*
%{_bindir}/cargo-clippy
%{_bindir}/clippy-driver
%doc src/tools/clippy/{README.md,CHANGELOG.md}
%license src/tools/clippy/LICENSE
%license src/tools/clippy/LICENSE-{APACHE,MIT}
%files src
@ -682,6 +691,9 @@ rm -f %{buildroot}%{rustlibdir}/etc/lldb_*.py*
%changelog
* Sat Nov 17 2018 Josh Stone <jistone@redhat.com> - 1.31.0-0.1.beta.13
- beta test
* Thu Nov 08 2018 Josh Stone <jistone@redhat.com> - 1.30.1-7
- Update to 1.30.1.

View File

@ -0,0 +1,43 @@
--- src/tools/rustfmt/Cargo.toml 2018-11-25 01:44:10.000000000 -0800
+++ src/tools/rustfmt/Cargo.toml 2018-11-26 14:57:07.921495841 -0800
@@ -51,7 +51,7 @@
rustc-ap-syntax = "297.0.0"
rustc-ap-syntax_pos = "297.0.0"
failure = "0.1.1"
-bytecount = { version = "0.3", features = ["simd-accel"] }
+bytecount = { version = "0.3", features = [] }
# A noop dependency that changes in the Rust repository, it's a bit of a hack.
# See the `src/tools/rustc-workspace-hack/README.md` file in `rust-lang/rust`
--- src/Cargo.lock 2018-11-25 01:42:12.000000000 -0800
+++ src/Cargo.lock 2018-11-26 15:21:01.917516541 -0800
@@ -182,9 +182,6 @@
name = "bytecount"
version = "0.3.2"
source = "registry+https://github.com/rust-lang/crates.io-index"
-dependencies = [
- "simd 0.2.3 (registry+https://github.com/rust-lang/crates.io-index)",
-]
[[package]]
name = "byteorder"
@@ -2651,11 +2648,6 @@
source = "registry+https://github.com/rust-lang/crates.io-index"
[[package]]
-name = "simd"
-version = "0.2.3"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-
-[[package]]
name = "siphasher"
version = "0.2.2"
source = "registry+https://github.com/rust-lang/crates.io-index"
@@ -3396,7 +3388,6 @@
"checksum serde_json 1.0.31 (registry+https://github.com/rust-lang/crates.io-index)" = "bb47a3d5c84320222f66d7db21157c4a7407755de41798f9b4c1c40593397b1a"
"checksum shell-escape 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)" = "170a13e64f2a51b77a45702ba77287f5c6829375b04a69cf2222acd17d0cfab9"
"checksum shlex 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)" = "7fdf1b9db47230893d76faad238fd6097fd6d6a9245cd7a4d90dbd639536bbd2"
-"checksum simd 0.2.3 (registry+https://github.com/rust-lang/crates.io-index)" = "0048b17eb9577ac545c61d85c3559b41dfb4cbea41c9bd9ca6a4f73ff05fda84"
"checksum siphasher 0.2.2 (registry+https://github.com/rust-lang/crates.io-index)" = "0df90a788073e8d0235a67e50441d47db7c8ad9debd91cbf43736a2a92d36537"
"checksum smallvec 0.6.5 (registry+https://github.com/rust-lang/crates.io-index)" = "153ffa32fd170e9944f7e0838edf824a754ec4c1fc64746fcc9fe1f8fa602e5d"
"checksum socket2 0.3.8 (registry+https://github.com/rust-lang/crates.io-index)" = "c4d11a52082057d87cb5caa31ad812f4504b97ab44732cd8359df2e9ff9f48e7"