Override default target CPUs to match distro settings
This commit is contained in:
parent
6fff218b19
commit
356401c7f1
98
0001-Expand-the-LLVM-coverage-of-print-target-cpus.patch
Normal file
98
0001-Expand-the-LLVM-coverage-of-print-target-cpus.patch
Normal file
@ -0,0 +1,98 @@
|
||||
From 23b3553ca0332dee4bdd79251b881d552e6bbafa Mon Sep 17 00:00:00 2001
|
||||
From: Josh Stone <jistone@redhat.com>
|
||||
Date: Fri, 5 May 2023 17:27:59 -0700
|
||||
Subject: [PATCH] Expand the LLVM coverage of `--print target-cpus`
|
||||
|
||||
We've been relying on a custom patch to add `MCSubtargetInfo::getCPUTable`
|
||||
for `rustc --print target-cpus`, and just printing that it's not supported
|
||||
on external LLVM builds. LLVM `main` now has `getAllProcessorDescriptions`
|
||||
that can replace ours, so now we try to use that. In addition, the fallback
|
||||
path can at least print the native and default cpu options.
|
||||
|
||||
There were also some mismatches in the function signatures here between
|
||||
`LLVM_RUSTLLVM` and otherwise; this is now mitigated by sharing these
|
||||
functions and only using cpp to adjust the function bodies.
|
||||
|
||||
(cherry picked from commit 67ae38a336599a7e0d2898a5ea3416b947458f5d)
|
||||
---
|
||||
.../rustc_llvm/llvm-wrapper/PassWrapper.cpp | 30 ++++++++++---------
|
||||
1 file changed, 16 insertions(+), 14 deletions(-)
|
||||
|
||||
diff --git a/compiler/rustc_llvm/llvm-wrapper/PassWrapper.cpp b/compiler/rustc_llvm/llvm-wrapper/PassWrapper.cpp
|
||||
index b1503e6e4b87..a4827a57f5cf 100644
|
||||
--- a/compiler/rustc_llvm/llvm-wrapper/PassWrapper.cpp
|
||||
+++ b/compiler/rustc_llvm/llvm-wrapper/PassWrapper.cpp
|
||||
@@ -297,7 +297,6 @@ static Reloc::Model fromRust(LLVMRustRelocModel RustReloc) {
|
||||
report_fatal_error("Bad RelocModel.");
|
||||
}
|
||||
|
||||
-#ifdef LLVM_RUSTLLVM
|
||||
/// getLongestEntryLength - Return the length of the longest entry in the table.
|
||||
template<typename KV>
|
||||
static size_t getLongestEntryLength(ArrayRef<KV> Table) {
|
||||
@@ -312,11 +311,21 @@ extern "C" void LLVMRustPrintTargetCPUs(LLVMTargetMachineRef TM, const char* Tar
|
||||
const MCSubtargetInfo *MCInfo = Target->getMCSubtargetInfo();
|
||||
const Triple::ArchType HostArch = Triple(sys::getProcessTriple()).getArch();
|
||||
const Triple::ArchType TargetArch = Target->getTargetTriple().getArch();
|
||||
+
|
||||
+#if LLVM_VERSION_GE(17, 0)
|
||||
+ const ArrayRef<SubtargetSubTypeKV> CPUTable = MCInfo->getAllProcessorDescriptions();
|
||||
+#elif defined(LLVM_RUSTLLVM)
|
||||
const ArrayRef<SubtargetSubTypeKV> CPUTable = MCInfo->getCPUTable();
|
||||
+#else
|
||||
+ printf("Full target CPU help is not supported by this LLVM version.\n\n");
|
||||
+ SubtargetSubTypeKV TargetCPUKV = { TargetCPU, {{}}, {{}} };
|
||||
+ const ArrayRef<SubtargetSubTypeKV> CPUTable = TargetCPUKV;
|
||||
+#endif
|
||||
unsigned MaxCPULen = getLongestEntryLength(CPUTable);
|
||||
|
||||
printf("Available CPUs for this target:\n");
|
||||
if (HostArch == TargetArch) {
|
||||
+ MaxCPULen = std::max(MaxCPULen, (unsigned) std::strlen("native"));
|
||||
const StringRef HostCPU = sys::getHostCPUName();
|
||||
printf(" %-*s - Select the CPU of the current host (currently %.*s).\n",
|
||||
MaxCPULen, "native", (int)HostCPU.size(), HostCPU.data());
|
||||
@@ -336,34 +345,27 @@ extern "C" void LLVMRustPrintTargetCPUs(LLVMTargetMachineRef TM, const char* Tar
|
||||
}
|
||||
|
||||
extern "C" size_t LLVMRustGetTargetFeaturesCount(LLVMTargetMachineRef TM) {
|
||||
+#ifdef LLVM_RUSTLLVM
|
||||
const TargetMachine *Target = unwrap(TM);
|
||||
const MCSubtargetInfo *MCInfo = Target->getMCSubtargetInfo();
|
||||
const ArrayRef<SubtargetFeatureKV> FeatTable = MCInfo->getFeatureTable();
|
||||
return FeatTable.size();
|
||||
+#else
|
||||
+ return 0;
|
||||
+#endif
|
||||
}
|
||||
|
||||
extern "C" void LLVMRustGetTargetFeature(LLVMTargetMachineRef TM, size_t Index,
|
||||
const char** Feature, const char** Desc) {
|
||||
+#ifdef LLVM_RUSTLLVM
|
||||
const TargetMachine *Target = unwrap(TM);
|
||||
const MCSubtargetInfo *MCInfo = Target->getMCSubtargetInfo();
|
||||
const ArrayRef<SubtargetFeatureKV> FeatTable = MCInfo->getFeatureTable();
|
||||
const SubtargetFeatureKV Feat = FeatTable[Index];
|
||||
*Feature = Feat.Key;
|
||||
*Desc = Feat.Desc;
|
||||
-}
|
||||
-
|
||||
-#else
|
||||
-
|
||||
-extern "C" void LLVMRustPrintTargetCPUs(LLVMTargetMachineRef) {
|
||||
- printf("Target CPU help is not supported by this LLVM version.\n\n");
|
||||
-}
|
||||
-
|
||||
-extern "C" size_t LLVMRustGetTargetFeaturesCount(LLVMTargetMachineRef) {
|
||||
- return 0;
|
||||
-}
|
||||
-
|
||||
-extern "C" void LLVMRustGetTargetFeature(LLVMTargetMachineRef, const char**, const char**) {}
|
||||
#endif
|
||||
+}
|
||||
|
||||
extern "C" const char* LLVMRustGetHostCPUName(size_t *len) {
|
||||
StringRef Name = sys::getHostCPUName();
|
||||
--
|
||||
2.40.1
|
||||
|
@ -0,0 +1,53 @@
|
||||
From 6e2adb05860b72610291d3b0e8bd525c44cb0cc9 Mon Sep 17 00:00:00 2001
|
||||
From: Josh Stone <jistone@redhat.com>
|
||||
Date: Fri, 9 Jun 2023 15:23:08 -0700
|
||||
Subject: [PATCH] Let environment variables override some default CPUs
|
||||
|
||||
---
|
||||
compiler/rustc_target/src/spec/powerpc64le_unknown_linux_gnu.rs | 2 +-
|
||||
compiler/rustc_target/src/spec/s390x_unknown_linux_gnu.rs | 2 +-
|
||||
compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs | 2 +-
|
||||
3 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/compiler/rustc_target/src/spec/powerpc64le_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/powerpc64le_unknown_linux_gnu.rs
|
||||
index fd896e086b54..08d0c43d20b4 100644
|
||||
--- a/compiler/rustc_target/src/spec/powerpc64le_unknown_linux_gnu.rs
|
||||
+++ b/compiler/rustc_target/src/spec/powerpc64le_unknown_linux_gnu.rs
|
||||
@@ -2,7 +2,7 @@
|
||||
|
||||
pub fn target() -> Target {
|
||||
let mut base = super::linux_gnu_base::opts();
|
||||
- base.cpu = "ppc64le".into();
|
||||
+ base.cpu = option_env!("RUSTC_TARGET_CPU_PPC64LE").unwrap_or("ppc64le").into();
|
||||
base.add_pre_link_args(LinkerFlavor::Gnu(Cc::Yes, Lld::No), &["-m64"]);
|
||||
base.max_atomic_width = Some(64);
|
||||
base.stack_probes = StackProbeType::Inline;
|
||||
diff --git a/compiler/rustc_target/src/spec/s390x_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/s390x_unknown_linux_gnu.rs
|
||||
index f2c722b9a89d..17a14d10b27e 100644
|
||||
--- a/compiler/rustc_target/src/spec/s390x_unknown_linux_gnu.rs
|
||||
+++ b/compiler/rustc_target/src/spec/s390x_unknown_linux_gnu.rs
|
||||
@@ -5,7 +5,7 @@ pub fn target() -> Target {
|
||||
let mut base = super::linux_gnu_base::opts();
|
||||
base.endian = Endian::Big;
|
||||
// z10 is the oldest CPU supported by LLVM
|
||||
- base.cpu = "z10".into();
|
||||
+ base.cpu = option_env!("RUSTC_TARGET_CPU_S390X").unwrap_or("z10").into();
|
||||
// FIXME: The ABI implementation in cabi_s390x.rs is for now hard-coded to assume the no-vector
|
||||
// ABI. Pass the -vector feature string to LLVM to respect this assumption. On LLVM < 16, we
|
||||
// also strip v128 from the data_layout below to match the older LLVM's expectation.
|
||||
diff --git a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
||||
index 9af1049b8702..68f876dd18c3 100644
|
||||
--- a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
||||
+++ b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
||||
@@ -2,7 +2,7 @@
|
||||
|
||||
pub fn target() -> Target {
|
||||
let mut base = super::linux_gnu_base::opts();
|
||||
- base.cpu = "x86-64".into();
|
||||
+ base.cpu = option_env!("RUSTC_TARGET_CPU_X86_64").unwrap_or("x86-64").into();
|
||||
base.max_atomic_width = Some(64);
|
||||
base.add_pre_link_args(LinkerFlavor::Gnu(Cc::Yes, Lld::No), &["-m64"]);
|
||||
base.stack_probes = StackProbeType::X86;
|
||||
--
|
||||
2.40.1
|
||||
|
102
0001-Rollup-merge-of-110876-mj10021-issue-110647-fix-r-b-.patch
Normal file
102
0001-Rollup-merge-of-110876-mj10021-issue-110647-fix-r-b-.patch
Normal file
@ -0,0 +1,102 @@
|
||||
From 6edbc665ea37ba3bf852b4eb42898b7d6e7b919c Mon Sep 17 00:00:00 2001
|
||||
From: Dylan DPC <99973273+Dylan-DPC@users.noreply.github.com>
|
||||
Date: Fri, 5 May 2023 18:40:35 +0530
|
||||
Subject: [PATCH] Rollup merge of #110876 - mj10021:issue-110647-fix, r=b-naber
|
||||
|
||||
Added default target cpu to `--print target-cpus` output and updated docs
|
||||
|
||||
Added default target cpu info as requested in issue #110647 and noted the new output in the documentation
|
||||
|
||||
(cherry picked from commit 65702bfd6bfb8616e182ddd19d0520ce7e35314a)
|
||||
---
|
||||
compiler/rustc_codegen_llvm/src/llvm/ffi.rs | 2 +-
|
||||
compiler/rustc_codegen_llvm/src/llvm_util.rs | 9 ++++++++-
|
||||
.../rustc_llvm/llvm-wrapper/PassWrapper.cpp | 17 +++++++++++++----
|
||||
src/doc/rustc/src/codegen-options/index.md | 3 ++-
|
||||
4 files changed, 24 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/compiler/rustc_codegen_llvm/src/llvm/ffi.rs b/compiler/rustc_codegen_llvm/src/llvm/ffi.rs
|
||||
index 05bbdbb7415c..383a9d2e5ddb 100644
|
||||
--- a/compiler/rustc_codegen_llvm/src/llvm/ffi.rs
|
||||
+++ b/compiler/rustc_codegen_llvm/src/llvm/ffi.rs
|
||||
@@ -2263,7 +2263,7 @@ pub fn LLVMRustDIBuilderCreateDebugLocation<'a>(
|
||||
|
||||
pub fn LLVMRustHasFeature(T: &TargetMachine, s: *const c_char) -> bool;
|
||||
|
||||
- pub fn LLVMRustPrintTargetCPUs(T: &TargetMachine);
|
||||
+ pub fn LLVMRustPrintTargetCPUs(T: &TargetMachine, cpu: *const c_char);
|
||||
pub fn LLVMRustGetTargetFeaturesCount(T: &TargetMachine) -> size_t;
|
||||
pub fn LLVMRustGetTargetFeature(
|
||||
T: &TargetMachine,
|
||||
diff --git a/compiler/rustc_codegen_llvm/src/llvm_util.rs b/compiler/rustc_codegen_llvm/src/llvm_util.rs
|
||||
index 46692fd5e8bc..2fbdab9f8ce0 100644
|
||||
--- a/compiler/rustc_codegen_llvm/src/llvm_util.rs
|
||||
+++ b/compiler/rustc_codegen_llvm/src/llvm_util.rs
|
||||
@@ -329,7 +329,14 @@ pub(crate) fn print(req: PrintRequest, sess: &Session) {
|
||||
require_inited();
|
||||
let tm = create_informational_target_machine(sess);
|
||||
match req {
|
||||
- PrintRequest::TargetCPUs => unsafe { llvm::LLVMRustPrintTargetCPUs(tm) },
|
||||
+ PrintRequest::TargetCPUs => {
|
||||
+ // SAFETY generate a C compatible string from a byte slice to pass
|
||||
+ // the target CPU name into LLVM, the lifetime of the reference is
|
||||
+ // at least as long as the C function
|
||||
+ let cpu_cstring = CString::new(handle_native(sess.target.cpu.as_ref()))
|
||||
+ .unwrap_or_else(|e| bug!("failed to convert to cstring: {}", e));
|
||||
+ unsafe { llvm::LLVMRustPrintTargetCPUs(tm, cpu_cstring.as_ptr()) };
|
||||
+ }
|
||||
PrintRequest::TargetFeatures => print_target_features(sess, tm),
|
||||
_ => bug!("rustc_codegen_llvm can't handle print request: {:?}", req),
|
||||
}
|
||||
diff --git a/compiler/rustc_llvm/llvm-wrapper/PassWrapper.cpp b/compiler/rustc_llvm/llvm-wrapper/PassWrapper.cpp
|
||||
index 08e38b0c9d59..b1503e6e4b87 100644
|
||||
--- a/compiler/rustc_llvm/llvm-wrapper/PassWrapper.cpp
|
||||
+++ b/compiler/rustc_llvm/llvm-wrapper/PassWrapper.cpp
|
||||
@@ -307,7 +307,7 @@ static size_t getLongestEntryLength(ArrayRef<KV> Table) {
|
||||
return MaxLen;
|
||||
}
|
||||
|
||||
-extern "C" void LLVMRustPrintTargetCPUs(LLVMTargetMachineRef TM) {
|
||||
+extern "C" void LLVMRustPrintTargetCPUs(LLVMTargetMachineRef TM, const char* TargetCPU) {
|
||||
const TargetMachine *Target = unwrap(TM);
|
||||
const MCSubtargetInfo *MCInfo = Target->getMCSubtargetInfo();
|
||||
const Triple::ArchType HostArch = Triple(sys::getProcessTriple()).getArch();
|
||||
@@ -321,9 +321,18 @@ extern "C" void LLVMRustPrintTargetCPUs(LLVMTargetMachineRef TM) {
|
||||
printf(" %-*s - Select the CPU of the current host (currently %.*s).\n",
|
||||
MaxCPULen, "native", (int)HostCPU.size(), HostCPU.data());
|
||||
}
|
||||
- for (auto &CPU : CPUTable)
|
||||
- printf(" %-*s\n", MaxCPULen, CPU.Key);
|
||||
- printf("\n");
|
||||
+ for (auto &CPU : CPUTable) {
|
||||
+ // Compare cpu against current target to label the default
|
||||
+ if (strcmp(CPU.Key, TargetCPU) == 0) {
|
||||
+ printf(" %-*s - This is the default target CPU"
|
||||
+ " for the current build target (currently %s).",
|
||||
+ MaxCPULen, CPU.Key, Target->getTargetTriple().str().c_str());
|
||||
+ }
|
||||
+ else {
|
||||
+ printf(" %-*s", MaxCPULen, CPU.Key);
|
||||
+ }
|
||||
+ printf("\n");
|
||||
+ }
|
||||
}
|
||||
|
||||
extern "C" size_t LLVMRustGetTargetFeaturesCount(LLVMTargetMachineRef TM) {
|
||||
diff --git a/src/doc/rustc/src/codegen-options/index.md b/src/doc/rustc/src/codegen-options/index.md
|
||||
index 62347f169a5e..3a14f582d600 100644
|
||||
--- a/src/doc/rustc/src/codegen-options/index.md
|
||||
+++ b/src/doc/rustc/src/codegen-options/index.md
|
||||
@@ -574,7 +574,8 @@ change in the future.
|
||||
This instructs `rustc` to generate code specifically for a particular processor.
|
||||
|
||||
You can run `rustc --print target-cpus` to see the valid options to pass
|
||||
-here. Each target has a default base CPU. Special values include:
|
||||
+and the default target CPU for the current buid target.
|
||||
+Each target has a default base CPU. Special values include:
|
||||
|
||||
* `native` can be passed to use the processor of the host machine.
|
||||
* `generic` refers to an LLVM target with minimal features but modern tuning.
|
||||
--
|
||||
2.40.1
|
||||
|
48
rust.spec
48
rust.spec
@ -84,7 +84,7 @@
|
||||
|
||||
Name: rust
|
||||
Version: 1.70.0
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: The Rust Programming Language
|
||||
License: (ASL 2.0 or MIT) and (BSD and MIT)
|
||||
# ^ written as: (rust itself) and (bundled libraries)
|
||||
@ -106,6 +106,18 @@ Patch1: 0001-Use-lld-provided-by-system-for-wasm.patch
|
||||
# Set a substitute-path in rust-gdb for standard library sources.
|
||||
Patch2: rustc-1.70.0-rust-gdb-substitute-path.patch
|
||||
|
||||
# Override default target CPUs to match distro settings
|
||||
# TODO: upstream this ability into the actual build configuration
|
||||
Patch3: 0001-Let-environment-variables-override-some-default-CPUs.patch
|
||||
|
||||
# Added default target cpu to `--print target-cpus` output
|
||||
# https://github.com/rust-lang/rust/pull/110876
|
||||
Patch4: 0001-Rollup-merge-of-110876-mj10021-issue-110647-fix-r-b-.patch
|
||||
|
||||
# Improve `--print target-cpus` for non-bundled LLVM
|
||||
# https://github.com/rust-lang/rust/pull/111274
|
||||
Patch5: 0001-Expand-the-LLVM-coverage-of-print-target-cpus.patch
|
||||
|
||||
### RHEL-specific patches below ###
|
||||
|
||||
# Simple rpm macros for rust-toolset (as opposed to full rust-packaging)
|
||||
@ -574,6 +586,9 @@ test -f '%{local_rust_root}/bin/rustc'
|
||||
|
||||
%patch -P1 -p1
|
||||
%patch -P2 -p1
|
||||
%patch -P3 -p1
|
||||
%patch -P4 -p1
|
||||
%patch -P5 -p1
|
||||
|
||||
%if %with disabled_libssh2
|
||||
%patch -P100 -p1
|
||||
@ -646,24 +661,20 @@ find -name '*.rs' -type f -perm /111 -exec chmod -v -x '{}' '+'
|
||||
%endif
|
||||
|
||||
# These are similar to __cflags_arch_* in /usr/lib/rpm/redhat/macros
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 9
|
||||
%ifarch x86_64
|
||||
%global rust_target_cpu %[0%{?rhel} >= 10 ? "x86-64-v3" : ""]
|
||||
%global rust_target_cpu %[0%{?rhel} == 9 ? "x86-64-v2" : "%{rust_target_cpu}"]
|
||||
%endif
|
||||
%ifarch s390x
|
||||
%global rust_target_cpu %[0%{?rhel} >= 9 ? "z14" : "zEC12"]
|
||||
%endif
|
||||
%ifarch ppc64le
|
||||
%global rust_target_cpu %[0%{?rhel} >= 9 ? "pwr9" : "pwr8"]
|
||||
%endif
|
||||
%endif
|
||||
%{lua: function rustc_target_cpus()
|
||||
local fedora = tonumber(rpm.expand("0%{?fedora}"))
|
||||
local rhel = tonumber(rpm.expand("0%{?rhel}"))
|
||||
local env =
|
||||
" RUSTC_TARGET_CPU_X86_64=x86-64" .. ((rhel >= 10) and "-v3" or (rhel == 9) and "-v2" or "")
|
||||
.. " RUSTC_TARGET_CPU_PPC64LE=" .. ((rhel >= 9) and "pwr9" or "pwr8")
|
||||
.. " RUSTC_TARGET_CPU_S390X=" ..
|
||||
((rhel >= 9) and "z14" or (rhel == 8 or fedora >= 38) and "z13" or
|
||||
(fedora >= 26) and "zEC12" or (rhel == 7) and "z196" or "z10")
|
||||
return env
|
||||
end}
|
||||
|
||||
# Set up shared environment variables for build/install/check
|
||||
%global rust_env %{?rustflags:RUSTFLAGS="%{rustflags}"}
|
||||
%if "%{?rust_target_cpu}" != ""
|
||||
%global rust_env %{?rust_env} CARGO_TARGET_%{rust_triple_env}_RUSTFLAGS=-Ctarget-cpu=%{rust_target_cpu}
|
||||
%endif
|
||||
%global rust_env %{?rustflags:RUSTFLAGS="%{rustflags}"} %{lua: print(rustc_target_cpus())}
|
||||
%if %defined cmake_path
|
||||
%global rust_env %{?rust_env} PATH="%{cmake_path}:$PATH"
|
||||
%endif
|
||||
@ -1049,6 +1060,9 @@ end}
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Jun 23 2023 Josh Stone <jistone@redhat.com> - 1.70.0-2
|
||||
- Override default target CPUs to match distro settings
|
||||
|
||||
* Thu Jun 01 2023 Josh Stone <jistone@redhat.com> - 1.70.0-1
|
||||
- Update to 1.70.0.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user