Re-enable f16 and f128
Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
This commit is contained in:
parent
75ddf70cc4
commit
28edb41b48
@ -1,29 +0,0 @@
|
||||
From 0d289c6b0bbb50f62e3ca388124c29aa9127e6b9 Mon Sep 17 00:00:00 2001
|
||||
From: David Abdurachmanov <davidlt@rivosinc.com>
|
||||
Date: Thu, 14 Nov 2024 13:10:26 +0000
|
||||
Subject: [PATCH] compiler_builtins: disable f16 and f128
|
||||
|
||||
This is needed to get 1.82.0 compiled. 1.81.0 as a boostrap compiler
|
||||
will fail as-is.
|
||||
|
||||
Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
|
||||
---
|
||||
library/alloc/Cargo.toml | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/library/alloc/Cargo.toml b/library/alloc/Cargo.toml
|
||||
index 4365bcc4a..7849d463b 100644
|
||||
--- a/library/alloc/Cargo.toml
|
||||
+++ b/library/alloc/Cargo.toml
|
||||
@@ -10,7 +10,7 @@ edition = "2021"
|
||||
|
||||
[dependencies]
|
||||
core = { path = "../core" }
|
||||
-compiler_builtins = { version = "0.1.123", features = ['rustc-dep-of-std'] }
|
||||
+compiler_builtins = { version = "0.1.123", features = ['rustc-dep-of-std', 'no-f16-f128'] }
|
||||
|
||||
[dev-dependencies]
|
||||
rand = { version = "0.8.5", default-features = false, features = ["alloc"] }
|
||||
--
|
||||
2.47.0
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: rust
|
||||
Version: 1.82.0
|
||||
Release: %autorelease -e 0.riscv64
|
||||
Release: %autorelease -e 1.riscv64
|
||||
Summary: The Rust Programming Language
|
||||
License: (Apache-2.0 OR MIT) AND (Artistic-2.0 AND BSD-3-Clause AND ISC AND MIT AND MPL-2.0 AND Unicode-DFS-2016)
|
||||
# ^ written as: (rust itself) and (bundled libraries)
|
||||
@ -164,10 +164,6 @@ Patch6: rustc-1.82.0-unbundle-sqlite.patch
|
||||
# https://github.com/rust-lang/rust/pull/130034
|
||||
Patch7: 0001-Fix-enabling-wasm-component-ld-to-match-other-tools.patch
|
||||
|
||||
#https://github.com/felixonmars/archriscv-packages/pull/4243
|
||||
#https://github.com/rust-lang/rust/issues/129268#issuecomment-2430520140
|
||||
Patch9: 0001-compiler_builtins-disable-f16-and-f128.patch
|
||||
|
||||
### RHEL-specific patches below ###
|
||||
|
||||
# Simple rpm macros for rust-toolset (as opposed to full rust-packaging)
|
||||
@ -675,7 +671,6 @@ rm -rf %{wasi_libc_dir}/dlmalloc/
|
||||
%patch -P6 -p1
|
||||
%endif
|
||||
%patch -P7 -p1
|
||||
%patch -P9 -p1
|
||||
|
||||
%if %with disabled_libssh2
|
||||
%patch -P100 -p1
|
||||
|
Loading…
Reference in New Issue
Block a user