Update patch to disable http2

This commit is contained in:
Josh Stone 2020-03-12 15:47:42 -07:00
parent 5037c3fc20
commit 2625654aa0
2 changed files with 13 additions and 13 deletions

View File

@ -80,7 +80,7 @@ Patch2: 0001-Drop-cfg-bootstrap-code.patch
# libcurl on EL7 doesn't have http2, but since cargo requests it, curl-sys
# will try to build it statically -- instead we turn off the feature.
Patch10: rustc-1.41.0-disable-http2.patch
Patch10: rustc-1.42.0-disable-http2.patch
# Get the Rust triple for any arch.
%{lua: function rust_triple(arch)

View File

@ -1,6 +1,6 @@
--- rustc-1.41.0-src/Cargo.lock.orig 2020-01-27 07:34:02.000000000 -0800
+++ rustc-1.41.0-src/Cargo.lock 2020-01-31 10:46:54.164921589 -0800
@@ -823,7 +823,6 @@
--- rustc-1.42.0-src/Cargo.lock.orig 2020-03-09 15:11:17.000000000 -0700
+++ rustc-1.42.0-src/Cargo.lock 2020-03-12 15:42:18.942468302 -0700
@@ -818,7 +818,6 @@
dependencies = [
"cc",
"libc",
@ -8,14 +8,14 @@
"libz-sys",
"openssl-sys",
"pkg-config",
@@ -1811,16 +1810,6 @@
@@ -1803,16 +1802,6 @@
]
[[package]]
-name = "libnghttp2-sys"
-version = "0.1.1"
-version = "0.1.2"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "d75d7966bda4730b722d1eab8e668df445368a24394bae9fc1e8dc0ab3dbe4f4"
-checksum = "02254d44f4435dd79e695f2c2b83cd06a47919adea30216ceaf0c57ca0a72463"
-dependencies = [
- "cc",
- "libc",
@ -23,12 +23,12 @@
-
-[[package]]
name = "libssh2-sys"
version = "0.2.11"
version = "0.2.14"
source = "registry+https://github.com/rust-lang/crates.io-index"
--- rustc-1.41.0-src/src/tools/cargo/Cargo.toml.orig 2020-01-27 07:34:20.000000000 -0800
+++ rustc-1.41.0-src/src/tools/cargo/Cargo.toml 2020-01-31 10:46:54.165921568 -0800
--- rustc-1.42.0-src/src/tools/cargo/Cargo.toml.orig 2020-03-09 15:11:43.000000000 -0700
+++ rustc-1.42.0-src/src/tools/cargo/Cargo.toml 2020-03-12 15:41:33.787431876 -0700
@@ -25,7 +25,7 @@
crates-io = { path = "crates/crates-io", version = "0.30" }
crates-io = { path = "crates/crates-io", version = "0.31" }
crossbeam-utils = "0.7"
crypto-hash = "0.3.1"
-curl = { version = "0.4.23", features = ["http2"] }
@ -36,8 +36,8 @@
curl-sys = "0.4.22"
env_logger = "0.7.0"
pretty_env_logger = { version = "0.3", optional = true }
--- rustc-1.41.0-src/src/tools/cargo/src/cargo/core/package.rs.orig 2020-01-27 07:34:20.000000000 -0800
+++ rustc-1.41.0-src/src/tools/cargo/src/cargo/core/package.rs 2020-01-31 10:46:54.166921547 -0800
--- rustc-1.42.0-src/src/tools/cargo/src/cargo/core/package.rs.orig 2020-03-09 15:11:43.000000000 -0700
+++ rustc-1.42.0-src/src/tools/cargo/src/cargo/core/package.rs 2020-03-12 15:46:45.401782270 -0700
@@ -375,14 +375,8 @@
// Also note that pipelining is disabled as curl authors have indicated
// that it's buggy, and we've empirically seen that it's buggy with HTTP