Update to 0.0.4

Also remove unneeded
`0001-dist-add-polkit-rule-for-rpm-ostree-59.patch` file.

Signed-off-by: Robert Fairley <rfairley@redhat.com>
This commit is contained in:
Robert Fairley 2019-08-02 16:21:10 +00:00
parent 8523582e4a
commit f977d18ca5
5 changed files with 19 additions and 32 deletions

1
.gitignore vendored
View File

@ -1,3 +1,4 @@
/zincati-0.0.1.crate
/zincati-0.0.2.crate
/zincati-0.0.3.crate
/zincati-0.0.4.crate

View File

@ -1,26 +0,0 @@
From 6b98e164cd233fb1a68d49d2b6b9f9bf2c2dcb8a Mon Sep 17 00:00:00 2001
From: Robert Fairley <rfairley@redhat.com>
Date: Thu, 4 Jul 2019 09:21:18 -0400
Subject: [PATCH] dist: add polkit rule for rpm-ostree
Add a polkit rule to allow the `zincati` user to make `deploy` and
`finalize-deployment` calls to the D-Bus API exposed by rpm-ostree.
---
dist/polkit-1/rules.d/zincati.rules | 8 ++++++++
1 file changed, 8 insertions(+)
create mode 100644 dist/polkit-1/rules.d/zincati.rules
diff --git a/dist/polkit-1/rules.d/zincati.rules b/dist/polkit-1/rules.d/zincati.rules
new file mode 100644
index 0000000..2171bde
--- /dev/null
+++ b/dist/polkit-1/rules.d/zincati.rules
@@ -0,0 +1,8 @@
+// Allow Zincati to deploy, and finalize a staged deployment through rpm-ostree.
+polkit.addRule(function(action, subject) {
+ if ((action.id == "org.projectatomic.rpmostree1.deploy" ||
+ action.id == "org.projectatomic.rpmostree1.finalize-deployment") &&
+ subject.user == "zincati") {
+ return polkit.Result.YES;
+ }
+})

View File

@ -5,8 +5,8 @@
%global crate zincati
Name: rust-%{crate}
Version: 0.0.3
Release: 2%{?dist}
Version: 0.0.4
Release: 1%{?dist}
Summary: Update agent for Fedora CoreOS
# Upstream license specification: Apache-2.0
@ -97,6 +97,9 @@ install -Dpm0644 -t %{buildroot}%{_datadir}/polkit-1/rules.d \
%endif
%changelog
* Fri Aug 02 2019 Robert Fairley <rfairley@redhat.com> - 0.0.4-1
- Update to 0.0.4
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (zincati-0.0.3.crate) = 6dede66e18b0d96ce4811f11e5c75423747095e1484c3b0f78a83291cb63f6f5847c457faeeb5cf97c229a778bc2e4855c7a428e1f69b79b94b0dfba7746918d
SHA512 (zincati-0.0.4.crate) = afd6bc07f06db9b53559a20db0b433f261b00423ccc742da4496136035c6e90a6a5013cd3067931d73321d80ef80bec6d823e2487c49879eb9050cae2b5dd664

View File

@ -1,5 +1,5 @@
--- zincati-0.0.3/Cargo.toml 1970-01-01T00:00:00+00:00
+++ zincati-0.0.3/Cargo.toml 2019-07-10T19:11:21.227014+00:00
--- zincati-0.0.4/Cargo.toml 1970-01-01T00:00:00+00:00
+++ zincati-0.0.4/Cargo.toml 2019-08-02T15:43:54.059801+00:00
@@ -39,7 +39,7 @@
version = "^0.4.7"
@ -9,7 +9,7 @@
[dependencies.envsubst]
version = "^0.1.0"
@@ -48,7 +48,7 @@
@@ -51,7 +51,7 @@
version = "^0.1.5"
[dependencies.futures]
@ -18,3 +18,12 @@
[dependencies.glob]
version = "^0.3.0"
@@ -76,7 +76,7 @@
default-features = false
[dependencies.reqwest]
-version = "^0.9.19"
+version = "^0.9.13"
[dependencies.serde]
version = "^1.0.98"