Update to 0.0.3

Temporarily relax futures to 0.1.27 and env_logger to 0.6.1

Signed-off-by: Robert Fairley <rfairley@redhat.com>
This commit is contained in:
Robert Fairley 2019-07-10 19:32:44 +00:00
parent b336ef9a6e
commit f40e9cc15e
4 changed files with 26 additions and 13 deletions

1
.gitignore vendored
View File

@ -1,2 +1,3 @@
/zincati-0.0.1.crate
/zincati-0.0.2.crate
/zincati-0.0.3.crate

View File

@ -5,8 +5,8 @@
%global crate zincati
Name: rust-%{crate}
Version: 0.0.2
Release: 7%{?dist}
Version: 0.0.3
Release: 1%{?dist}
Summary: Update agent for Fedora CoreOS
# Upstream license specification: Apache-2.0
@ -15,8 +15,6 @@ URL: https://crates.io/crates/zincati
Source: %{crates_source}
# Initial patched metadata
Patch0: zincati-fix-metadata.diff
# Add polkit rule to authorize zincati to perform upgrades https://github.com/coreos/zincati/pull/59
Patch0001: 0001-dist-add-polkit-rule-for-rpm-ostree-59.patch
ExclusiveArch: %{rust_arches}
@ -42,6 +40,7 @@ Summary: %{summary}
%dir %{_prefix}/lib/%{crate}
%dir %{_prefix}/lib/%{crate}/config.d
%{_prefix}/lib/%{crate}/config.d/50-fedora-coreos-cincinnati.toml
%{_prefix}/lib/%{crate}/config.d/10-auto-updates.toml
%attr(0775, zincati, zincati) %dir /run/%{crate}
%attr(0775, zincati, zincati) %dir /run/%{crate}/config.d
%attr(0770, zincati, zincati) %dir /run/%{crate}/private
@ -98,6 +97,10 @@ install -Dpm0644 -t %{buildroot}%{_datadir}/polkit-1/rules.d \
%endif
%changelog
* Wed Jul 10 2019 Robert Fairley <rfairley@redhat.com> - 0.0.3-1
- Update to 0.0.3
- Temporarily relax futures to 0.1.27 and env_logger to 0.6.1
* Thu Jul 04 2019 Robert Fairley <rfairley@redhat.com> - 0.0.2-7
- Require the polkit package, rather than the rules.d directory

View File

@ -1 +1 @@
SHA512 (zincati-0.0.2.crate) = ad8df004329980c0af8a13b885da6d9026b372c8495a024d48333ba1f0d01fd76dfcdbe69be10934cb3db41e485b5e506636c7269e92241e64bbfdd04f8e56fb
SHA512 (zincati-0.0.3.crate) = 6dede66e18b0d96ce4811f11e5c75423747095e1484c3b0f78a83291cb63f6f5847c457faeeb5cf97c229a778bc2e4855c7a428e1f69b79b94b0dfba7746918d

View File

@ -1,11 +1,20 @@
--- zincati-0.0.2/Cargo.toml 1970-01-01T00:00:00+00:00
+++ zincati-0.0.2/Cargo.toml 2019-06-26T21:47:47.218388+00:00
@@ -57,7 +57,7 @@
version = "^1.3.0"
--- zincati-0.0.3/Cargo.toml 1970-01-01T00:00:00+00:00
+++ zincati-0.0.3/Cargo.toml 2019-07-10T19:11:21.227014+00:00
@@ -39,7 +39,7 @@
version = "^0.4.7"
[dependencies.liboverdrop]
-version = "^0.0.1"
+version = "^0.0.2"
[dependencies.env_logger]
-version = "^0.6.2"
+version = "^0.6.1"
[dependencies.libsystemd]
[dependencies.envsubst]
version = "^0.1.0"
@@ -48,7 +48,7 @@
version = "^0.1.5"
[dependencies.futures]
-version = "^0.1.28"
+version = "^0.1.27"
[dependencies.glob]
version = "^0.3.0"