New upstream version 0.0.14

This updates to latest release (0.0.14),
see https://github.com/coreos/zincati/releases/tag/v0.0.14.
This commit is contained in:
Luca BRUNO 2020-11-11 13:48:27 +00:00 committed by Luca BRUNO
parent b1db82382b
commit e08407ebc2
No known key found for this signature in database
GPG Key ID: A9834A2252078E4E
5 changed files with 12 additions and 146 deletions

1
.gitignore vendored
View File

@ -10,3 +10,4 @@
/zincati-0.0.11.crate
/zincati-0.0.12.crate
/zincati-0.0.13.crate
/zincati-0.0.14.crate

View File

@ -1,121 +0,0 @@
From 231d7cba7fb42924f85f21743923bd404eef9d1a Mon Sep 17 00:00:00 2001
From: Luca BRUNO <luca.bruno@coreos.com>
Date: Tue, 29 Sep 2020 07:24:03 +0000
Subject: [PATCH] update_agent: adapt to actix-0.10 API changes
---
src/update_agent/actor.rs | 24 ++++++++++++------------
1 file changed, 12 insertions(+), 12 deletions(-)
diff --git a/src/update_agent/actor.rs b/src/update_agent/actor.rs
index ed51db2..65a2891 100644
--- a/src/update_agent/actor.rs
+++ b/src/update_agent/actor.rs
@@ -99,7 +99,7 @@ impl Handler<RefreshTick> for UpdateAgent {
// Process state machine refresh ticks sequentially.
ctx.wait(update_machine);
- Box::new(actix::fut::ok(()))
+ Box::pin(actix::fut::ok(()))
}
}
@@ -164,7 +164,7 @@ impl UpdateAgent {
Ok(())
});
- Box::new(initialization)
+ Box::pin(initialization)
}
/// Try to report steady state.
@@ -181,7 +181,7 @@ impl UpdateAgent {
Ok(())
});
- Box::new(state_change)
+ Box::pin(state_change)
}
/// Try to check for updates.
@@ -210,7 +210,7 @@ impl UpdateAgent {
Ok(())
});
- Box::new(state_change)
+ Box::pin(state_change)
}
/// Try to stage an update.
@@ -227,7 +227,7 @@ impl UpdateAgent {
Ok(())
});
- Box::new(state_change)
+ Box::pin(state_change)
}
/// Try to finalize an update.
@@ -242,7 +242,7 @@ impl UpdateAgent {
.then(|can_finalize, actor, _ctx| actor.finalize_deployment(can_finalize, release))
.map(|res, actor, _ctx| res.map(|release| actor.state.update_finalized(release)));
- Box::new(state_change)
+ Box::pin(state_change)
}
/// Actor job is done.
@@ -253,7 +253,7 @@ impl UpdateAgent {
Ok(())
});
- Box::new(state_change)
+ Box::pin(state_change)
}
/// Fetch and stage an update, in finalization-locked mode.
@@ -273,7 +273,7 @@ impl UpdateAgent {
.map_err(|e| log::error!("failed to stage deployment: {}", e))
.into_actor(self);
- Box::new(upgrade)
+ Box::pin(upgrade)
}
/// Record a failed deploy attempt.
@@ -304,7 +304,7 @@ impl UpdateAgent {
})
.into_actor(self);
- Box::new(depls)
+ Box::pin(depls)
}
/// Finalize a deployment (unlock and reboot).
@@ -314,7 +314,7 @@ impl UpdateAgent {
release: Release,
) -> ResponseActFuture<Self, Result<Release, ()>> {
if !can_finalize {
- return Box::new(actix::fut::err(()));
+ return Box::pin(actix::fut::err(()));
}
log::info!(
@@ -329,12 +329,12 @@ impl UpdateAgent {
.map_err(|e| log::error!("failed to finalize deployment: {}", e))
.into_actor(self);
- Box::new(upgrade)
+ Box::pin(upgrade)
}
/// Do nothing, without errors.
fn nop(&mut self) -> ResponseActFuture<Self, Result<(), ()>> {
let nop = actix::fut::ok(());
- Box::new(nop)
+ Box::pin(nop)
}
}
--
2.28.0

View File

@ -1,11 +1,11 @@
# Generated by rust2rpm 13
# Generated by rust2rpm 15
%bcond_without check
%global __cargo_skip_build 0
%global crate zincati
Name: rust-%{crate}
Version: 0.0.13
Version: 0.0.14
Release: 1%{?dist}
Summary: Update agent for Fedora CoreOS
@ -13,12 +13,6 @@ Summary: Update agent for Fedora CoreOS
License: ASL 2.0
URL: https://crates.io/crates/zincati
Source: %{crates_source}
# Initial patched metadata
# - Update actix from ^0.9 to 0.10.0
Patch0: zincati-fix-metadata.diff
# Port to the new actix. Can drop after next upstream release.
# https://github.com/coreos/zincati/commit/231d7cb
Patch1: 0001-update_agent-adapt-to-actix-0.10-API-changes.patch
ExclusiveArch: %{rust_arches}
@ -53,11 +47,7 @@ License: ASL 2.0 and BSD and MIT and MPLv2.0 and zlib
%license COPYRIGHT LICENSE
%dir %{_prefix}/lib/%{crate}
%dir %{_prefix}/lib/%{crate}/config.d
%{_prefix}/lib/%{crate}/config.d/10-agent.toml
%{_prefix}/lib/%{crate}/config.d/10-auto-updates.toml
%{_prefix}/lib/%{crate}/config.d/10-identity.toml
%{_prefix}/lib/%{crate}/config.d/30-updates-strategy.toml
%{_prefix}/lib/%{crate}/config.d/50-fedora-coreos-cincinnati.toml
%{_prefix}/lib/%{crate}/config.d/*.toml
%attr(0775, zincati, zincati) %dir /run/%{crate}
%attr(0775, zincati, zincati) %dir /run/%{crate}/config.d
%attr(0770, zincati, zincati) %dir /run/%{crate}/private
@ -70,6 +60,7 @@ License: ASL 2.0 and BSD and MIT and MPLv2.0 and zlib
%{_sysusersdir}/50-zincati.conf
%{_tmpfilesdir}/zincati.conf
%{_datadir}/polkit-1/rules.d/zincati.rules
%{_datadir}/polkit-1/actions/org.coreos.zincati.*
%post -n %{crate}
%systemd_post zincati.service
@ -111,6 +102,8 @@ install -Dpm0644 -t %{buildroot}%{_tmpfilesdir} \
dist/tmpfiles.d/*.conf
install -Dpm0644 -t %{buildroot}%{_datadir}/polkit-1/rules.d \
dist/polkit-1/rules.d/*.rules
install -Dpm0644 -t %{buildroot}%{_datadir}/polkit-1/actions \
dist/polkit-1/actions/org.coreos.zincati.*
ln -snf /run/%{crate}/public/metrics.promsock %{buildroot}/run/%{crate}/private/metrics.promsock
%if %{with check}
@ -119,6 +112,10 @@ ln -snf /run/%{crate}/public/metrics.promsock %{buildroot}/run/%{crate}/private/
%endif
%changelog
* Wed Nov 11 13:55:25 UTC 2020 Luca BRUNO <lucab@lucabruno.net> - 0.0.14-1
- New upstream version
https://github.com/coreos/zincati/releases/tag/v0.0.14
* Tue Sep 29 2020 Dusty Mabe <dusty@dustymabe.com> - 0.0.13-1
- Update to 0.0.13

View File

@ -1 +1 @@
SHA512 (zincati-0.0.13.crate) = 811776b58b1b74e824d9933a06bb5f3996c76847b667074337b607f9b38653889689891380004e5588a935f4bcb5c4ceba4592bfe3da95c2623ee6f626fb83d4
SHA512 (zincati-0.0.14.crate) = f16a6754d95877284e7935e2b78f089666df24bdaef993043fc76db73b0aa5548bdbf134a9ce96ceb121345f398bd90d82b4fb5dc9d0b17006042e4ef7549209

View File

@ -1,11 +0,0 @@
--- zincati-0.0.13/Cargo.toml 2020-09-22T14:09:39+00:00
+++ zincati-0.0.13/Cargo.toml 2020-09-30T04:37:33.367601+00:00
@@ -30,7 +30,7 @@
[profile.release]
lto = true
[dependencies.actix]
-version = "^0.9"
+version = "^0.10"
[dependencies.cfg-if]
version = "^0.1"