Update to 0.0.5

Also install the `zincati` binary under /usr/libexec.
See: https://github.com/coreos/fedora-coreos-tracker/issues/244

Signed-off-by: Robert Fairley <rfairley@redhat.com>
This commit is contained in:
rfairley 2019-09-11 11:10:00 +00:00 committed by Robert Fairley
parent f977d18ca5
commit 791bd6bd3a
4 changed files with 48 additions and 16 deletions

1
.gitignore vendored
View File

@ -2,3 +2,4 @@
/zincati-0.0.2.crate
/zincati-0.0.3.crate
/zincati-0.0.4.crate
/zincati-0.0.5.crate

View File

@ -5,7 +5,7 @@
%global crate zincati
Name: rust-%{crate}
Version: 0.0.4
Version: 0.0.5
Release: 1%{?dist}
Summary: Update agent for Fedora CoreOS
@ -34,13 +34,14 @@ Summary: %{summary}
%description -n %{crate} %{_description}
%files -n %{crate}
%{_bindir}/zincati
%{_libexecdir}/zincati
%doc README.md
%license COPYRIGHT LICENSE
%dir %{_prefix}/lib/%{crate}
%dir %{_prefix}/lib/%{crate}/config.d
%{_prefix}/lib/%{crate}/config.d/50-fedora-coreos-cincinnati.toml
%{_prefix}/lib/%{crate}/config.d/10-auto-updates.toml
%{_prefix}/lib/%{crate}/config.d/10-identity.toml
%attr(0775, zincati, zincati) %dir /run/%{crate}
%attr(0775, zincati, zincati) %dir /run/%{crate}/config.d
%attr(0770, zincati, zincati) %dir /run/%{crate}/private
@ -77,6 +78,10 @@ Summary: %{summary}
%install
%cargo_install
# `zincati` should not be executed directly by users, so we move the binary
# out of `/usr/bin`. See: https://github.com/coreos/fedora-coreos-tracker/issues/244
mkdir -p %{buildroot}%{_libexecdir}
mv %{buildroot}%{_bindir}/zincati %{buildroot}%{_libexecdir}/zincati
install -Dpm0644 -t %{buildroot}%{_prefix}/lib/%{crate}/config.d \
dist/config.d/*.toml
mkdir -p %{buildroot}/run/%{crate}/config.d
@ -97,6 +102,10 @@ install -Dpm0644 -t %{buildroot}%{_datadir}/polkit-1/rules.d \
%endif
%changelog
* Wed Sep 11 2019 Robert Fairley <rfairley@redhat.com> - 0.0.5-1
- Update to 0.0.5
- Install binary under /usr/libexec
* Fri Aug 02 2019 Robert Fairley <rfairley@redhat.com> - 0.0.4-1
- Update to 0.0.4

View File

@ -1 +1 @@
SHA512 (zincati-0.0.4.crate) = afd6bc07f06db9b53559a20db0b433f261b00423ccc742da4496136035c6e90a6a5013cd3067931d73321d80ef80bec6d823e2487c49879eb9050cae2b5dd664
SHA512 (zincati-0.0.5.crate) = db5d8fa74cc579d0fc18461fb19e9528c36627917eb85411c2536479fa19bb2f86107e653b7f34279017b3fabdee25d27f9d13ba94744844bfe9285714b10e1f

View File

@ -1,29 +1,51 @@
--- zincati-0.0.4/Cargo.toml 1970-01-01T00:00:00+00:00
+++ zincati-0.0.4/Cargo.toml 2019-08-02T15:43:54.059801+00:00
@@ -39,7 +39,7 @@
version = "^0.4.7"
--- zincati-0.0.5/Cargo.toml 1970-01-01T00:00:00+00:00
+++ zincati-0.0.5/Cargo.toml 2019-09-11T15:06:04.640429+00:00
@@ -36,7 +36,7 @@
version = "^0.1.9"
[dependencies.chrono]
-version = "^0.4.9"
+version = "^0.4.8"
[dependencies.env_logger]
-version = "^0.6.2"
+version = "^0.6.1"
[dependencies.envsubst]
version = "^0.1.0"
version = "^0.6.2"
@@ -51,7 +51,7 @@
version = "^0.1.5"
[dependencies.futures]
-version = "^0.1.28"
-version = "^0.1.29"
+version = "^0.1.27"
[dependencies.glob]
version = "^0.3.0"
@@ -76,7 +76,7 @@
@@ -80,7 +80,7 @@
default-features = false
[dependencies.reqwest]
-version = "^0.9.19"
-version = "^0.9.20"
+version = "^0.9.13"
[dependencies.serde]
version = "^1.0.98"
version = "^1.0.100"
@@ -90,18 +90,18 @@
version = "^1.0.40"
[dependencies.structopt]
-version = "^0.3.1"
+version = "^0.2.18"
[dependencies.tokio]
version = "^0.1.22"
[dependencies.toml]
-version = "^0.5.3"
+version = "^0.5.1"
[dependencies.url_serde]
version = "^0.2.0"
[dev-dependencies.mockito]
-version = "^0.20"
+version = "^0.17.1"
[dev-dependencies.proptest]
version = "^0.9"