Update to 0.0.6

Signed-off-by: Robert Fairley <rfairley@redhat.com>
This commit is contained in:
Robert Fairley 2019-11-20 21:53:29 +00:00
parent 791bd6bd3a
commit 6cada0ad31
4 changed files with 21 additions and 29 deletions

1
.gitignore vendored
View File

@ -3,3 +3,4 @@
/zincati-0.0.3.crate
/zincati-0.0.4.crate
/zincati-0.0.5.crate
/zincati-0.0.6.crate

View File

@ -5,7 +5,7 @@
%global crate zincati
Name: rust-%{crate}
Version: 0.0.5
Version: 0.0.6
Release: 1%{?dist}
Summary: Update agent for Fedora CoreOS
@ -39,9 +39,10 @@ Summary: %{summary}
%license COPYRIGHT LICENSE
%dir %{_prefix}/lib/%{crate}
%dir %{_prefix}/lib/%{crate}/config.d
%{_prefix}/lib/%{crate}/config.d/50-fedora-coreos-cincinnati.toml
%{_prefix}/lib/%{crate}/config.d/10-auto-updates.toml
%{_prefix}/lib/%{crate}/config.d/10-identity.toml
%{_prefix}/lib/%{crate}/config.d/30-updates-strategy.toml
%{_prefix}/lib/%{crate}/config.d/50-fedora-coreos-cincinnati.toml
%attr(0775, zincati, zincati) %dir /run/%{crate}
%attr(0775, zincati, zincati) %dir /run/%{crate}/config.d
%attr(0770, zincati, zincati) %dir /run/%{crate}/private
@ -102,6 +103,9 @@ install -Dpm0644 -t %{buildroot}%{_datadir}/polkit-1/rules.d \
%endif
%changelog
* Tue Oct 15 2019 Robert Fairley <rfairley@redhat.com> - 0.0.6-1
- Update to 0.0.6
* Wed Sep 11 2019 Robert Fairley <rfairley@redhat.com> - 0.0.5-1
- Update to 0.0.5
- Install binary under /usr/libexec

View File

@ -1 +1 @@
SHA512 (zincati-0.0.5.crate) = db5d8fa74cc579d0fc18461fb19e9528c36627917eb85411c2536479fa19bb2f86107e653b7f34279017b3fabdee25d27f9d13ba94744844bfe9285714b10e1f
SHA512 (zincati-0.0.6.crate) = 1c0b904e7f696b70416ccef19a72cebf47d53c65a19fda6bb541a91b918563df365b339c9d855ec3714d968396ce0d346c779541d14ee8e22db7a1ff7ab268be

View File

@ -1,14 +1,5 @@
--- zincati-0.0.5/Cargo.toml 1970-01-01T00:00:00+00:00
+++ zincati-0.0.5/Cargo.toml 2019-09-11T15:06:04.640429+00:00
@@ -36,7 +36,7 @@
version = "^0.1.9"
[dependencies.chrono]
-version = "^0.4.9"
+version = "^0.4.8"
[dependencies.env_logger]
version = "^0.6.2"
--- zincati-0.0.6/Cargo.toml 1970-01-01T00:00:00+00:00
+++ zincati-0.0.6/Cargo.toml 2019-11-20T17:23:58.272331+00:00
@@ -51,7 +51,7 @@
version = "^0.1.5"
@ -18,34 +9,30 @@
[dependencies.glob]
version = "^0.3.0"
@@ -80,7 +80,7 @@
default-features = false
@@ -83,7 +83,7 @@
version = "^0.7.2"
[dependencies.reqwest]
-version = "^0.9.20"
-version = "^0.9.21"
+version = "^0.9.13"
[dependencies.serde]
version = "^1.0.100"
@@ -90,18 +90,18 @@
version = "^1.0.40"
version = "^1.0.101"
@@ -93,7 +93,7 @@
version = "^1.0.41"
[dependencies.structopt]
-version = "^0.3.1"
-version = "^0.3.2"
+version = "^0.2.18"
[dependencies.tokio]
version = "^0.1.22"
@@ -107,7 +107,7 @@
version = "^0.1"
[dependencies.toml]
-version = "^0.5.3"
+version = "^0.5.1"
[dependencies.url_serde]
version = "^0.2.0"
[dev-dependencies.mockito]
-version = "^0.20"
+version = "^0.17.1"
-version = "^0.21"
+version = "^0.22"
[dev-dependencies.proptest]
version = "^0.9"