Update to 0.0.13

This commit is contained in:
Dusty Mabe 2020-09-30 00:49:20 -04:00
parent 82cfd04819
commit 46ce5d1a71
No known key found for this signature in database
GPG Key ID: 3302DBD73952E671
4 changed files with 13 additions and 18 deletions

1
.gitignore vendored
View File

@ -9,3 +9,4 @@
/zincati-0.0.10.crate
/zincati-0.0.11.crate
/zincati-0.0.12.crate
/zincati-0.0.13.crate

View File

@ -5,8 +5,8 @@
%global crate zincati
Name: rust-%{crate}
Version: 0.0.12
Release: 6%{?dist}
Version: 0.0.13
Release: 1%{?dist}
Summary: Update agent for Fedora CoreOS
# Upstream license specification: Apache-2.0
@ -14,8 +14,7 @@ License: ASL 2.0
URL: https://crates.io/crates/zincati
Source: %{crates_source}
# Initial patched metadata
# - Update actix from ^0.9 to 0.10.0-alpha.2
# - Downgrade proptest from ^0.10 to ^0.9
# - Update actix from ^0.9 to 0.10.0
Patch0: zincati-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -81,6 +80,7 @@ License: ASL 2.0 and BSD and MIT and MPLv2.0 and zlib
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
# Port to the new actix
# No longer needed after https://github.com/coreos/zincati/pull/359
sed -i -e "s/Box::new/Box::pin/g" src/update_agent/actor.rs
%cargo_prep
@ -119,6 +119,9 @@ ln -snf /run/%{crate}/public/metrics.promsock %{buildroot}/run/%{crate}/private/
%endif
%changelog
* Tue Sep 29 2020 Dusty Mabe <dusty@dustymabe.com> - 0.0.13-1
- Update to 0.0.13
* Wed Sep 23 2020 Kelvin Fan <kfan@redhat.com> - 0.0.12-6
- Remove unnecessary usage of systemd RPM macro in %pre

View File

@ -1 +1 @@
SHA512 (zincati-0.0.12.crate) = d21c095f6ccfb2cc49b41fea82b6e528f47c568409df881cd688580feb3c86bec5769c14abf53fac28c0cfec9877a9bd14c1a50f7258ba1db8e15a6ecaeb78c7
SHA512 (zincati-0.0.13.crate) = 811776b58b1b74e824d9933a06bb5f3996c76847b667074337b607f9b38653889689891380004e5588a935f4bcb5c4ceba4592bfe3da95c2623ee6f626fb83d4

View File

@ -1,20 +1,11 @@
--- zincati-0.0.12/Cargo.toml 2020-06-25T15:58:17+00:00
+++ zincati-0.0.12/Cargo.toml 2020-06-29T18:59:20.433864+00:00
@@ -29,7 +29,7 @@
--- zincati-0.0.13/Cargo.toml 2020-09-22T14:09:39+00:00
+++ zincati-0.0.13/Cargo.toml 2020-09-30T04:37:33.367601+00:00
@@ -30,7 +30,7 @@
[profile.release]
lto = true
[dependencies.actix]
-version = "^0.9"
+version = "0.10.0-alpha.2"
+version = "^0.10"
[dependencies.cfg-if]
version = "^0.1"
@@ -117,7 +117,7 @@
version = "^0.25"
[dev-dependencies.proptest]
-version = "^0.10"
+version = "^0.9"
[features]
failpoints = ["fail/failpoints"]