rust-yubibomb/rust-yubibomb.spec

93 lines
2.2 KiB
RPMSpec

# Generated by rust2rpm 20
%bcond_without check
%global crate yubibomb
Name: rust-%{crate}
Version: 0.2.7
Release: %autorelease
Summary: Rust command line tool that prints out a 6-digit random number
# Upstream license specification: GPL-3.0
License: GPLv3
URL: https://crates.io/crates/yubibomb
Source: %{crates_source}
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
%global _description %{expand:
Don't you love when you accidentally tap your Yubikey when you have your IRC
client in focus and you send 987947 into Libera? Want to be able to have that
experience without having to reach all the way over to your laptop's USB port?
Now you can!.}
%description %{_description}
%package -n %{crate}
Summary: %{summary}
# GPLv3.0: rust-yubibomb 0.2.7
# MIT or ASL 2.0: rust-cfg-if 1.0.0
# MIT or ASL 2.0: rust-getrandom 0.2.3
# MIT or ASL 2.0: rust-libc 0.2.109
# MIT or ASL 2.0: rust-ppv-lite86 0.2.15
# MIT or ASL 2.0: rust-rand 0.8.4
# MIT or ASL 2.0: rust-rand_chacha 0.3.1
# MIT or ASL 2.0: rust-rand_core 0.6.3
License: GPLv3 and (MIT or ASL 2.0)
%description -n %{crate} %{_description}
%files -n %{crate}
%license LICENSE
%doc CHANGELOG.md README.md
%{_bindir}/yubibomb
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE
%doc CHANGELOG.md README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog