Update to yubibomb-0.2.0.

Signed-off-by: Randy Barlow <randy@electronsweatshop.com>
This commit is contained in:
Randy Barlow 2018-02-13 17:19:19 -05:00
parent 29b6a5d660
commit 8b25caed30
4 changed files with 10 additions and 15 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
/yubibomb-0.1.0.crate
/yubibomb-0.2.0.crate

View File

@ -4,22 +4,20 @@
%global crate yubibomb
Name: rust-%{crate}
Version: 0.1.0
Release: 4%{?dist}
Version: 0.2.0
Release: 1%{?dist}
Summary: Rust command line tool that prints out a 6-digit random number
License: GPLv3+
URL: https://crates.io/crates/yubibomb
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Bump rand to 0.4, https://gitlab.com/bowlofeggs/yubibomb/merge_requests/1
Patch0: yubibomb-0.1.0-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(rand) >= 0.4.0 with crate(rand) < 0.5.0)
BuildRequires: (crate(regex) >= 0.2.0 with crate(regex) < 0.3.0)
%description
%{summary}.
@ -50,10 +48,14 @@ to your laptop's USB port? Now you can!
%files -n %{crate}
%license LICENSE
%doc README.md
%doc CHANGELOG README.md
%{_bindir}/yubibomb
%{cargo_registry}/%{crate}-%{version}/
%changelog
* Tue Feb 13 2018 Randy Barlow <bowlofeggs@fedoraproject.org> - 0.2.0-1
- Update to 0.2.0.
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (yubibomb-0.1.0.crate) = ff0de0be755cbab345685c0555db82b3a9d94d52d132aff0eff5725b1ac46e1158e7d706e7fd7fd6f1ac30e4aa1130d8d96ff746bf2b346ceaf55b9a69fcc62c
SHA512 (yubibomb-0.2.0.crate) = c187f3bf3549a1bc5f501086e1de643b465364042ce0084f1f21f90b03d0b42edccd083ffe39210b20d4a97bf2deaf9437b30008a2bcef52948748b9c17b12ef

View File

@ -1,8 +0,0 @@
--- yubibomb-0.1.0/Cargo.toml 2017-05-01T03:20:39+02:00
+++ yubibomb-0.1.0/Cargo.toml 2017-12-31T14:48:15.928601+01:00
@@ -13,4 +13,4 @@
readme = "README.md"
[dependencies]
-rand = "0.3.0"
+rand = "0.4"