initial import

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
Igor Gnatenko 2017-11-14 23:46:46 +01:00
parent dc374f8278
commit 954a13546a
5 changed files with 158 additions and 0 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
/tokei-6.1.2.crate

View File

@ -0,0 +1,26 @@
From 2a3b1b7d578de123537e9dcac42e4e455d4eae55 Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Tue, 14 Nov 2017 18:27:21 +0100
Subject: [PATCH] bump handlebars to 0.29
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
---
src/language/language_type.hbs.rs | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/language/language_type.hbs.rs b/src/language/language_type.hbs.rs
index e97b137..da42e4e 100644
--- a/src/language/language_type.hbs.rs
+++ b/src/language/language_type.hbs.rs
@@ -247,7 +247,7 @@ pub fn get_filetype_from_shebang<P>(file: P) -> Option<&'static str>
|
{{~/unless}}
{{~/each}}
- => Some("{{this.extensions[0]}}"),
+ => Some("{{this.extensions.[0]}}"),
{{~/if}}
{{~/each}}
env => {
--
2.15.0

97
rust-tokei.spec Normal file
View File

@ -0,0 +1,97 @@
# Generated by rust2rpm
%bcond_without check
%global crate tokei
Name: rust-%{crate}
Version: 6.1.2
Release: 1%{?dist}
Summary: Utility that allows you to count code, quickly
License: MIT or ASL 2.0
URL: https://crates.io/crates/tokei
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Bump handlebars to 0.29
# * Bump ignore to 0.3
# * Bump rayon to 0.9
# https://github.com/Aaronepower/tokei/pull/158
Patch0: tokei-6.1.2-fix-metadata.diff
# Make it work with handlebars v0.29
Patch1: 0001-bump-handlebars-to-0.29.patch
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(clap) >= 2.24.0 with crate(clap) < 3.0.0)
BuildRequires: (crate(encoding) >= 0.2.0 with crate(encoding) < 0.3.0)
BuildRequires: (crate(env_logger) >= 0.4.0 with crate(env_logger) < 0.5.0)
BuildRequires: (crate(errln) >= 0.1.0 with crate(errln) < 0.2.0)
BuildRequires: (crate(hex) >= 0.2.0 with crate(hex) < 0.3.0)
BuildRequires: (crate(ignore) >= 0.3.0 with crate(ignore) < 0.4.0)
BuildRequires: (crate(log) >= 0.3.0 with crate(log) < 0.4.0)
BuildRequires: (crate(rayon) >= 0.9.0 with crate(rayon) < 0.10.0)
BuildRequires: (crate(regex) >= 0.2.0 with crate(regex) < 0.3.0)
BuildRequires: (crate(serde) >= 1.0.0 with crate(serde) < 2.0.0)
BuildRequires: (crate(serde_cbor) >= 0.6.0 with crate(serde_cbor) < 0.7.0)
BuildRequires: (crate(serde_derive) >= 1.0.0 with crate(serde_derive) < 2.0.0)
BuildRequires: (crate(serde_json) >= 1.0.0 with crate(serde_json) < 2.0.0)
BuildRequires: (crate(serde_yaml) >= 0.7.0 with crate(serde_yaml) < 0.8.0)
BuildRequires: (crate(toml) >= 0.4.0 with crate(toml) < 0.5.0)
# [build-dependencies]
BuildRequires: (crate(handlebars) >= 0.29.0 with crate(handlebars) < 0.30.0)
BuildRequires: (crate(ignore) >= 0.3.0 with crate(ignore) < 0.4.0)
BuildRequires: (crate(lazy_static) >= 0.2.0 with crate(lazy_static) < 0.3.0)
BuildRequires: (crate(serde_json) >= 1.0.0 with crate(serde_json) < 2.0.0)
%if %{with check}
# [dev-dependencies]
BuildRequires: (crate(lazy_static) >= 0.2.0 with crate(lazy_static) < 0.3.0)
BuildRequires: (crate(tempdir) >= 0.3.0 with crate(tempdir) < 0.4.0)
%endif
%description
%{summary}.
%package -n %{crate}
Summary: %{summary}
%description -n %{crate}
A utility that allows you to count code, quickly.
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel
A simple, effcient library for counting code in directories.
This package contains library source intended for building other packages
which use %{crate} from crates.io.
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%files -n %{crate}
%license LICENSE-MIT LICENSE-APACHE
%{_bindir}/tokei
%files devel
%license LICENSE-MIT LICENSE-APACHE
%{cargo_registry}/%{crate}-%{version}/
%changelog
* Tue Nov 14 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 6.1.2-1
- Initial package

1
sources Normal file
View File

@ -0,0 +1 @@
SHA512 (tokei-6.1.2.crate) = fcab141eea6204a097e474575a9c2982f2fb6417834c7af9aa54bb714d7fe81a4685647da099e3e5e812555f601172896d4ae61734d9afec404391c221db8e9f

View File

@ -0,0 +1,33 @@
--- tokei-6.1.2/Cargo.toml 1970-01-01T01:00:00+01:00
+++ tokei-6.1.2/Cargo.toml 2017-11-14T18:29:06.058269+01:00
@@ -60,7 +60,7 @@
features = []
[dependencies.ignore]
-version = "0.2"
+version = "0.3"
[dependencies.errln]
version = "0.1"
@@ -74,7 +74,7 @@
optional = true
[dependencies.rayon]
-version = "0.7"
+version = "0.9"
[dependencies.clap]
version = "2.24"
@@ -84,10 +84,10 @@
[dev-dependencies.lazy_static]
version = "0.2"
[build-dependencies.ignore]
-version = "0.2"
+version = "0.3"
[build-dependencies.handlebars]
-version = "0.27"
+version = "0.29"
[build-dependencies.serde_json]
version = "1"