Initial import

Signed-off-by: Igor Raits <ignatenkobrain@fedoraproject.org>
This commit is contained in:
Igor Raits 2020-03-19 13:17:38 +01:00
parent dc374f8278
commit 448f9712d8
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C
4 changed files with 80 additions and 0 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
/tokei-10.1.2.crate

67
rust-tokei.spec Normal file
View File

@ -0,0 +1,67 @@
# Generated by rust2rpm 13
%bcond_without check
# No devel stuff in released Fedora
%global __cargo_is_lib() false
%global crate tokei
Name: rust-%{crate}
Version: 10.1.2
Release: 3%{?dist}
Summary: Utility that allows you to count code, quickly
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/tokei
Source: %{crates_source}
# Initial patched metadata
# * Update git2 to 0.13, https://github.com/XAMPPRocky/tokei/commit/df72338cf710a054b8977f6e5abb38bc5e792471
Patch0: tokei-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
%global _description %{expand:
Utility that allows you to count code, quickly.}
%description %{_description}
%package -n %{crate}
Summary: %{summary}
# Install all deps (without check), grab their licenses and make it simple
# * ASL 2.0 or Boost
# * ASL 2.0 or MIT
# * MIT
# * MIT or ASL 2.0
# * (MIT or ASL 2.0) and BSD
# * Unlicense or MIT
License: MIT and BSD and (ASL 2.0 or Boost)
%description -n %{crate} %{_description}
%files -n %{crate}
%license LICENCE-MIT LICENCE-APACHE
%{_bindir}/tokei
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires -a
%build
%cargo_build -a
%install
%cargo_install -a
%if %{with check}
%check
%cargo_test -a
%endif
%changelog
* Thu Mar 19 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 10.1.2-3
- Initial package

1
sources Normal file
View File

@ -0,0 +1 @@
SHA512 (tokei-10.1.2.crate) = e4f1b7ed79941e2504a7b9d680c50d06b6bd486d7e603a14120ff2411334274fecf2475192d479ff19a8cde424ba2784d27cb72ff60aee06302f1ab7cba70349

11
tokei-fix-metadata.diff Normal file
View File

@ -0,0 +1,11 @@
--- tokei-10.1.2/Cargo.toml 2020-02-13T17:02:09+00:00
+++ tokei-10.1.2/Cargo.toml 2020-03-19T10:06:08.298004+00:00
@@ -83,7 +83,7 @@
[dependencies.toml]
version = "0.5.6"
[dev-dependencies.git2]
-version = "0.11.0"
+version = "0.13.0"
features = []
default-features = false