Rebuild for rust-hex 0.3

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
Igor Gnatenko 2017-11-18 10:07:18 +01:00
parent 08595f6ff1
commit 3861672757
4 changed files with 54 additions and 5 deletions

View File

@ -1,7 +1,7 @@
From 2a3b1b7d578de123537e9dcac42e4e455d4eae55 Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Tue, 14 Nov 2017 18:27:21 +0100
Subject: [PATCH] bump handlebars to 0.29
Subject: [PATCH 1/2] bump handlebars to 0.29
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
---

View File

@ -0,0 +1,34 @@
From 1493633dc5945118222f77a3bc3b01de59429b1b Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Sat, 18 Nov 2017 09:57:51 +0100
Subject: [PATCH 2/2] bump hex to 0.3
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
---
src/language/languages.rs | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/src/language/languages.rs b/src/language/languages.rs
index effabeb..ba996db 100644
--- a/src/language/languages.rs
+++ b/src/language/languages.rs
@@ -339,7 +339,6 @@ impl Languages {
/// extern crate tokei;
/// # use tokei::*;
/// extern crate hex;
- /// use hex::ToHex;
///
/// # fn main () {
/// let cbor = "a16452757374a666626c616e6b730564636f64650c68636f6d6d656e747\
@@ -350,7 +349,7 @@ impl Languages {
/// let mut languages = Languages::new();
/// languages.get_statistics(vec!["build.rs"], vec![]);
///
- /// assert_eq!(cbor, &languages.to_cbor().unwrap().to_hex());
+ /// assert_eq!(cbor, hex::encode(&languages.to_cbor().unwrap()));
/// # }
/// ```
#[cfg(feature = "cbor")]
--
2.15.0

View File

@ -7,20 +7,23 @@
Name: rust-%{crate}
Version: 6.1.2
Release: 3%{?dist}
Release: 4%{?dist}
Summary: Utility that allows you to count code, quickly
License: MIT or ASL 2.0
URL: https://crates.io/crates/tokei
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Bump handlebars to 0.29
# * Bump ignore to 0.3
# * Bump rayon to 0.9
# * Bump handlebars to 0.29
# * Bump hex to 0.3
# https://github.com/Aaronepower/tokei/pull/158
Patch0: tokei-6.1.2-fix-metadata.diff
# Make it work with handlebars v0.29
Patch1: 0001-bump-handlebars-to-0.29.patch
# Make it work with hex v0.3
Patch2: 0002-bump-hex-to-0.3.patch
ExclusiveArch: %{rust_arches}
@ -30,7 +33,7 @@ BuildRequires: (crate(clap) >= 2.24.0 with crate(clap) < 3.0.0)
BuildRequires: (crate(encoding) >= 0.2.0 with crate(encoding) < 0.3.0)
BuildRequires: (crate(env_logger) >= 0.4.0 with crate(env_logger) < 0.5.0)
BuildRequires: (crate(errln) >= 0.1.0 with crate(errln) < 0.2.0)
BuildRequires: (crate(hex) >= 0.2.0 with crate(hex) < 0.3.0)
BuildRequires: (crate(hex) >= 0.3.0 with crate(hex) < 0.4.0)
BuildRequires: (crate(ignore) >= 0.3.0 with crate(ignore) < 0.4.0)
BuildRequires: (crate(log) >= 0.3.0 with crate(log) < 0.4.0)
BuildRequires: (crate(rayon) >= 0.9.0 with crate(rayon) < 0.10.0)
@ -95,6 +98,9 @@ which use %{crate} from crates.io.
%{cargo_registry}/%{crate}-%{version}/
%changelog
* Sat Nov 18 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 6.1.2-4
- Rebuild for rust-hex 0.3
* Wed Nov 15 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 6.1.2-3
- Rebuild for dependency change

View File

@ -1,5 +1,14 @@
--- tokei-6.1.2/Cargo.toml 1970-01-01T01:00:00+01:00
+++ tokei-6.1.2/Cargo.toml 2017-11-14T18:29:06.058269+01:00
+++ tokei-6.1.2/Cargo.toml 2017-11-18T10:07:56.357114+01:00
@@ -31,7 +31,7 @@
optional = true
[dependencies.hex]
-version = "0.2"
+version = "0.3"
optional = true
[dependencies.encoding]
@@ -60,7 +60,7 @@
features = []