Update to 7.0.3

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
Igor Gnatenko 2018-06-11 20:12:39 +02:00
parent 3e6659c90e
commit 12d8ba87ba
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C
4 changed files with 9 additions and 41 deletions

1
.gitignore vendored
View File

@ -1,3 +1,4 @@
/tokei-6.1.2.crate
/tokei-7.0.0.crate
/tokei-7.0.1.crate
/tokei-7.0.3.crate

View File

@ -6,18 +6,13 @@
%global crate tokei
Name: rust-%{crate}
Version: 7.0.1
Release: 6%{?dist}
Version: 7.0.3
Release: 1%{?dist}
Summary: Utility that allows you to count code, quickly
License: MIT or ASL 2.0
URL: https://crates.io/crates/tokei
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Bump handlebars to 0.31, https://github.com/Aaronepower/tokei/pull/187
# * Bump ignore to 0.4, https://github.com/Aaronepower/tokei/pull/188
# * Bump rayon to 1, https://github.com/Aaronepower/tokei/pull/192
Patch0: tokei-7.0.1-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -30,7 +25,6 @@ BuildRequires: (crate(hex) >= 0.3.0 with crate(hex) < 0.4.0)
BuildRequires: (crate(ignore) >= 0.4.0 with crate(ignore) < 0.5.0)
BuildRequires: (crate(log) >= 0.4.0 with crate(log) < 0.5.0)
BuildRequires: (crate(rayon) >= 1.0.0 with crate(rayon) < 2.0.0)
BuildRequires: (crate(regex) >= 0.2.0 with crate(regex) < 0.3.0)
BuildRequires: (crate(serde) >= 1.0.0 with crate(serde) < 2.0.0)
BuildRequires: (crate(serde_cbor) >= 0.8.0 with crate(serde_cbor) < 0.9.0)
BuildRequires: (crate(serde_derive) >= 1.0.0 with crate(serde_derive) < 2.0.0)
@ -38,13 +32,14 @@ BuildRequires: (crate(serde_json) >= 1.0.0 with crate(serde_json) < 2.0.0)
BuildRequires: (crate(serde_yaml) >= 0.7.0 with crate(serde_yaml) < 0.8.0)
BuildRequires: (crate(toml) >= 0.4.0 with crate(toml) < 0.5.0)
# [build-dependencies]
BuildRequires: (crate(handlebars) >= 0.31.0 with crate(handlebars) < 0.32.0)
BuildRequires: (crate(handlebars) >= 0.32.0 with crate(handlebars) < 0.33.0)
BuildRequires: (crate(ignore) >= 0.4.0 with crate(ignore) < 0.5.0)
BuildRequires: (crate(lazy_static) >= 1.0.0 with crate(lazy_static) < 2.0.0)
BuildRequires: (crate(serde_json) >= 1.0.0 with crate(serde_json) < 2.0.0)
%if %{with check}
# [dev-dependencies]
BuildRequires: (crate(lazy_static) >= 1.0.0 with crate(lazy_static) < 2.0.0)
BuildRequires: (crate(regex) >= 1.0.0 with crate(regex) < 2.0.0)
BuildRequires: (crate(tempdir) >= 0.3.0 with crate(tempdir) < 0.4.0)
%endif
@ -91,6 +86,9 @@ which use %{crate} from crates.io.
%{cargo_registry}/%{crate}-%{version}/
%changelog
* Thu Jun 14 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 7.0.3-1
- Update to 7.0.3
* Wed Feb 21 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 7.0.1-6
- Rebuild for passing %%__cargo_common_opts bug

View File

@ -1 +1 @@
SHA512 (tokei-7.0.1.crate) = f929104df1f9cdd7e7ec87e1e7cf28df3348b51db1a4f01decaf4b6ded47356224d6b57607e24f08be9e333bacef64118547fae040437aa8b5cb47cddcc51636
SHA512 (tokei-7.0.3.crate) = c8e2eeac7331e5bbb5377f7dc44468b0b44d0d8b886be8f16c3b61c0089e2cc6660a5f3cb86104a69ef815cc17b561c4545c16dd2e387e72163760799d0b0a9d

View File

@ -1,31 +0,0 @@
--- tokei-7.0.1/Cargo.toml 1970-01-01T01:00:00+01:00
+++ tokei-7.0.1/Cargo.toml 2018-02-20T08:10:18.530638+01:00
@@ -41,13 +41,13 @@
optional = true
[dependencies.ignore]
-version = "0.3"
+version = "0.4"
[dependencies.log]
version = "0.4"
[dependencies.rayon]
-version = "0.9"
+version = "1"
[dependencies.regex]
version = "0.2"
@@ -81,10 +81,10 @@
[dev-dependencies.tempdir]
version = "0.3"
[build-dependencies.handlebars]
-version = "0.29"
+version = "0.31"
[build-dependencies.ignore]
-version = "0.3"
+version = "0.4"
[build-dependencies.lazy_static]
version = "1"