Update to 0.5.1 Close: rhbz#2032033

This commit is contained in:
Robert-André Mauchin 2022-06-19 21:27:41 +02:00
parent 385352e82e
commit ec79130d1c
4 changed files with 145 additions and 151 deletions

1
.gitignore vendored
View File

@ -6,3 +6,4 @@
/rav1e-0.4.0.crate
/rav1e-0.4.1.crate
/rav1e-0.5.0.crate
/rav1e-0.5.1.crate

View File

@ -1,5 +1,14 @@
--- rav1e-0.5.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ rav1e-0.5.0/Cargo.toml 2021-11-21T03:36:51.742045+00:00
--- rav1e-0.5.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ rav1e-0.5.1/Cargo.toml 2022-06-19T18:14:31.663238+00:00
@@ -90,7 +90,7 @@
default-features = false
[dependencies.console]
-version = "0.14"
+version = "0.15"
optional = true
[dependencies.crossbeam]
@@ -233,21 +233,7 @@
unstable = []
wasm = ["wasm-bindgen"]

View File

@ -1,4 +1,4 @@
# Generated by rust2rpm 18
# Generated by rust2rpm 21
%bcond_without check
# Install all deps (without check), grab their licenses and make it simple
@ -16,7 +16,7 @@
%global crate rav1e
Name: rust-%{crate}
Version: 0.5.0
Version: 0.5.1
Release: %autorelease
Summary: Fastest and safest AV1 encoder
@ -26,26 +26,23 @@ License: BSD and ISC
URL: https://crates.io/crates/rav1e
Source: %{crates_source}
# Initial patched metadata
# * Bump console to 0.15
# * Bump system-deps to 6
# * Remove fuzzing dependencies
# * Bump system-deps dependency from 3.1.2 to 6
Patch0: rav1e-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Fastest and safest AV1 encoder.}
%description %{_description}
%if ! %{__cargo_skip_build}
%package -n %{crate}
Summary: %{summary}
License: %{binary_license}
%description -n %{crate} %{_description}
@ -65,32 +62,23 @@ Library files for rav1e, the fastest and safest AV1 encoder.
%license LICENSE PATENTS
%{_libdir}/librav1e.so.0*
%package -n %{crate}-devel
Summary: Development files for rav1e
Requires: %{crate}-libs%{?_isa} = %{version}-%{release}
%description -n %{crate}-devel
Development files for rav1e, the fastest and safest AV1 encoder.
%files -n %{crate}-devel
%{_includedir}/rav1e/
%{_libdir}/librav1e.so
%{_libdir}/pkgconfig/rav1e.pc
%endif
%package devel
Summary: %{summary}
BuildArch: noarch
Requires: %{crate}-libs%{?_isa} = %{version}-%{release}
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license PATENTS LICENSE
%doc README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%license %{crate_instdir}/LICENSE
%license %{crate_instdir}/PATENTS
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%{_includedir}/rav1e/
%{_libdir}/librav1e.so
%{_libdir}/pkgconfig/rav1e.pc
%package -n %{name}+default-devel
Summary: %{summary}
@ -98,11 +86,11 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+aom-sys-devel
Summary: %{summary}
@ -110,11 +98,11 @@ BuildArch: noarch
%description -n %{name}+aom-sys-devel %{_description}
This package contains library source intended for building other packages
which use "aom-sys" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "aom-sys" feature of the "%{crate}" crate.
%files -n %{name}+aom-sys-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+asm-devel
Summary: %{summary}
@ -122,11 +110,11 @@ BuildArch: noarch
%description -n %{name}+asm-devel %{_description}
This package contains library source intended for building other packages
which use "asm" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "asm" feature of the "%{crate}" crate.
%files -n %{name}+asm-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+av-metrics-devel
Summary: %{summary}
@ -134,11 +122,11 @@ BuildArch: noarch
%description -n %{name}+av-metrics-devel %{_description}
This package contains library source intended for building other packages
which use "av-metrics" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "av-metrics" feature of the "%{crate}" crate.
%files -n %{name}+av-metrics-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+backtrace-devel
Summary: %{summary}
@ -146,11 +134,11 @@ BuildArch: noarch
%description -n %{name}+backtrace-devel %{_description}
This package contains library source intended for building other packages
which use "backtrace" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "backtrace" feature of the "%{crate}" crate.
%files -n %{name}+backtrace-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bench-devel
Summary: %{summary}
@ -158,11 +146,11 @@ BuildArch: noarch
%description -n %{name}+bench-devel %{_description}
This package contains library source intended for building other packages
which use "bench" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "bench" feature of the "%{crate}" crate.
%files -n %{name}+bench-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+binaries-devel
Summary: %{summary}
@ -170,11 +158,11 @@ BuildArch: noarch
%description -n %{name}+binaries-devel %{_description}
This package contains library source intended for building other packages
which use "binaries" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "binaries" feature of the "%{crate}" crate.
%files -n %{name}+binaries-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+byteorder-devel
Summary: %{summary}
@ -182,11 +170,11 @@ BuildArch: noarch
%description -n %{name}+byteorder-devel %{_description}
This package contains library source intended for building other packages
which use "byteorder" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "byteorder" feature of the "%{crate}" crate.
%files -n %{name}+byteorder-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+capi-devel
Summary: %{summary}
@ -194,11 +182,11 @@ BuildArch: noarch
%description -n %{name}+capi-devel %{_description}
This package contains library source intended for building other packages
which use "capi" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "capi" feature of the "%{crate}" crate.
%files -n %{name}+capi-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+cc-devel
Summary: %{summary}
@ -206,11 +194,11 @@ BuildArch: noarch
%description -n %{name}+cc-devel %{_description}
This package contains library source intended for building other packages
which use "cc" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "cc" feature of the "%{crate}" crate.
%files -n %{name}+cc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+channel-api-devel
Summary: %{summary}
@ -218,11 +206,11 @@ BuildArch: noarch
%description -n %{name}+channel-api-devel %{_description}
This package contains library source intended for building other packages
which use "channel-api" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "channel-api" feature of the "%{crate}" crate.
%files -n %{name}+channel-api-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+check_asm-devel
Summary: %{summary}
@ -230,11 +218,11 @@ BuildArch: noarch
%description -n %{name}+check_asm-devel %{_description}
This package contains library source intended for building other packages
which use "check_asm" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "check_asm" feature of the "%{crate}" crate.
%files -n %{name}+check_asm-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+clap-devel
Summary: %{summary}
@ -242,11 +230,11 @@ BuildArch: noarch
%description -n %{name}+clap-devel %{_description}
This package contains library source intended for building other packages
which use "clap" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "clap" feature of the "%{crate}" crate.
%files -n %{name}+clap-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+console-devel
Summary: %{summary}
@ -254,11 +242,11 @@ BuildArch: noarch
%description -n %{name}+console-devel %{_description}
This package contains library source intended for building other packages
which use "console" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "console" feature of the "%{crate}" crate.
%files -n %{name}+console-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+crossbeam-devel
Summary: %{summary}
@ -266,11 +254,11 @@ BuildArch: noarch
%description -n %{name}+crossbeam-devel %{_description}
This package contains library source intended for building other packages
which use "crossbeam" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "crossbeam" feature of the "%{crate}" crate.
%files -n %{name}+crossbeam-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dav1d-sys-devel
Summary: %{summary}
@ -278,11 +266,11 @@ BuildArch: noarch
%description -n %{name}+dav1d-sys-devel %{_description}
This package contains library source intended for building other packages
which use "dav1d-sys" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "dav1d-sys" feature of the "%{crate}" crate.
%files -n %{name}+dav1d-sys-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+decode_test-devel
Summary: %{summary}
@ -290,11 +278,11 @@ BuildArch: noarch
%description -n %{name}+decode_test-devel %{_description}
This package contains library source intended for building other packages
which use "decode_test" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "decode_test" feature of the "%{crate}" crate.
%files -n %{name}+decode_test-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+decode_test_dav1d-devel
Summary: %{summary}
@ -302,11 +290,11 @@ BuildArch: noarch
%description -n %{name}+decode_test_dav1d-devel %{_description}
This package contains library source intended for building other packages
which use "decode_test_dav1d" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "decode_test_dav1d" feature of the "%{crate}" crate.
%files -n %{name}+decode_test_dav1d-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+desync_finder-devel
Summary: %{summary}
@ -314,11 +302,11 @@ BuildArch: noarch
%description -n %{name}+desync_finder-devel %{_description}
This package contains library source intended for building other packages
which use "desync_finder" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "desync_finder" feature of the "%{crate}" crate.
%files -n %{name}+desync_finder-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dump_ivf-devel
Summary: %{summary}
@ -326,11 +314,11 @@ BuildArch: noarch
%description -n %{name}+dump_ivf-devel %{_description}
This package contains library source intended for building other packages
which use "dump_ivf" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "dump_ivf" feature of the "%{crate}" crate.
%files -n %{name}+dump_ivf-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dump_lookahead_data-devel
Summary: %{summary}
@ -338,11 +326,11 @@ BuildArch: noarch
%description -n %{name}+dump_lookahead_data-devel %{_description}
This package contains library source intended for building other packages
which use "dump_lookahead_data" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "dump_lookahead_data" feature of the "%{crate}" crate.
%files -n %{name}+dump_lookahead_data-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fern-devel
Summary: %{summary}
@ -350,11 +338,11 @@ BuildArch: noarch
%description -n %{name}+fern-devel %{_description}
This package contains library source intended for building other packages
which use "fern" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "fern" feature of the "%{crate}" crate.
%files -n %{name}+fern-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+image-devel
Summary: %{summary}
@ -362,11 +350,11 @@ BuildArch: noarch
%description -n %{name}+image-devel %{_description}
This package contains library source intended for building other packages
which use "image" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "image" feature of the "%{crate}" crate.
%files -n %{name}+image-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ivf-devel
Summary: %{summary}
@ -374,11 +362,11 @@ BuildArch: noarch
%description -n %{name}+ivf-devel %{_description}
This package contains library source intended for building other packages
which use "ivf" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "ivf" feature of the "%{crate}" crate.
%files -n %{name}+ivf-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+nasm-rs-devel
Summary: %{summary}
@ -386,11 +374,11 @@ BuildArch: noarch
%description -n %{name}+nasm-rs-devel %{_description}
This package contains library source intended for building other packages
which use "nasm-rs" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "nasm-rs" feature of the "%{crate}" crate.
%files -n %{name}+nasm-rs-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+quick_test-devel
Summary: %{summary}
@ -398,11 +386,11 @@ BuildArch: noarch
%description -n %{name}+quick_test-devel %{_description}
This package contains library source intended for building other packages
which use "quick_test" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "quick_test" feature of the "%{crate}" crate.
%files -n %{name}+quick_test-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+regex-devel
Summary: %{summary}
@ -410,11 +398,11 @@ BuildArch: noarch
%description -n %{name}+regex-devel %{_description}
This package contains library source intended for building other packages
which use "regex" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "regex" feature of the "%{crate}" crate.
%files -n %{name}+regex-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+scan_fmt-devel
Summary: %{summary}
@ -422,11 +410,11 @@ BuildArch: noarch
%description -n %{name}+scan_fmt-devel %{_description}
This package contains library source intended for building other packages
which use "scan_fmt" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "scan_fmt" feature of the "%{crate}" crate.
%files -n %{name}+scan_fmt-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+scenechange-devel
Summary: %{summary}
@ -434,11 +422,11 @@ BuildArch: noarch
%description -n %{name}+scenechange-devel %{_description}
This package contains library source intended for building other packages
which use "scenechange" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "scenechange" feature of the "%{crate}" crate.
%files -n %{name}+scenechange-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
@ -446,11 +434,11 @@ BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages
which use "serde" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serialize-devel
Summary: %{summary}
@ -458,11 +446,11 @@ BuildArch: noarch
%description -n %{name}+serialize-devel %{_description}
This package contains library source intended for building other packages
which use "serialize" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "serialize" feature of the "%{crate}" crate.
%files -n %{name}+serialize-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+signal-hook-devel
Summary: %{summary}
@ -470,11 +458,11 @@ BuildArch: noarch
%description -n %{name}+signal-hook-devel %{_description}
This package contains library source intended for building other packages
which use "signal-hook" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "signal-hook" feature of the "%{crate}" crate.
%files -n %{name}+signal-hook-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+signal_support-devel
Summary: %{summary}
@ -482,11 +470,11 @@ BuildArch: noarch
%description -n %{name}+signal_support-devel %{_description}
This package contains library source intended for building other packages
which use "signal_support" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "signal_support" feature of the "%{crate}" crate.
%files -n %{name}+signal_support-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+toml-devel
Summary: %{summary}
@ -494,11 +482,11 @@ BuildArch: noarch
%description -n %{name}+toml-devel %{_description}
This package contains library source intended for building other packages
which use "toml" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "toml" feature of the "%{crate}" crate.
%files -n %{name}+toml-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tracing-devel
Summary: %{summary}
@ -506,11 +494,11 @@ BuildArch: noarch
%description -n %{name}+tracing-devel %{_description}
This package contains library source intended for building other packages
which use "tracing" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "tracing" feature of the "%{crate}" crate.
%files -n %{name}+tracing-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unstable-devel
Summary: %{summary}
@ -518,11 +506,11 @@ BuildArch: noarch
%description -n %{name}+unstable-devel %{_description}
This package contains library source intended for building other packages
which use "unstable" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "unstable" feature of the "%{crate}" crate.
%files -n %{name}+unstable-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+wasm-devel
Summary: %{summary}
@ -530,11 +518,11 @@ BuildArch: noarch
%description -n %{name}+wasm-devel %{_description}
This package contains library source intended for building other packages
which use "wasm" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "wasm" feature of the "%{crate}" crate.
%files -n %{name}+wasm-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+wasm-bindgen-devel
Summary: %{summary}
@ -542,11 +530,11 @@ BuildArch: noarch
%description -n %{name}+wasm-bindgen-devel %{_description}
This package contains library source intended for building other packages
which use "wasm-bindgen" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "wasm-bindgen" feature of the "%{crate}" crate.
%files -n %{name}+wasm-bindgen-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+y4m-devel
Summary: %{summary}
@ -554,11 +542,11 @@ BuildArch: noarch
%description -n %{name}+y4m-devel %{_description}
This package contains library source intended for building other packages
which use "y4m" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "y4m" feature of the "%{crate}" crate.
%files -n %{name}+y4m-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
@ -590,12 +578,8 @@ rm -v %{buildroot}%{_libdir}/librav1e.a
%if %{with check}
%check
# * work around codegen issues when compiling doctests with LLVM 13:
# https://bugzilla.redhat.com/show_bug.cgi?id=2045116
%ifnarch %{arm}
%cargo_test
%endif
%endif
%changelog
%autochangelog

View File

@ -1 +1 @@
SHA512 (rav1e-0.5.0.crate) = 7ffec9130c94c4eb2c8a5ab44894cc733abacf3cbf7951c5d7203802bd4b8a23dbf7874ab7b29ecec29ebeb98a1acfdd7a7fc15d7efb41dc1127e3340f58e4b8
SHA512 (rav1e-0.5.1.crate) = 83a5117f82840575fe6d62b7d959cec94d0e86a9b6f89e400b261ac681f821b6be1a65689b75c12fd2f2e4f0f49daa05a1e0d020612ef790ba66722288115365