Update to 0.5.0 Close: rhbz#1991588

This commit is contained in:
Robert-André Mauchin 2021-11-21 15:54:59 +01:00
parent 904b12931c
commit 6ef633730a
5 changed files with 12 additions and 58 deletions

1
.gitignore vendored
View File

@ -5,3 +5,4 @@
/rav1e-0.4.0-alpha.crate
/rav1e-0.4.0.crate
/rav1e-0.4.1.crate
/rav1e-0.5.0.crate

View File

@ -1,42 +0,0 @@
From f553646d70fba8e265d436103a73520eb7adec8c Mon Sep 17 00:00:00 2001
From: David Michael Barr <b@rr-dav.id.au>
Date: Thu, 8 Jul 2021 13:39:59 +0900
Subject: [PATCH] Initialise residual when less than the transform width is
visible
The input stride for forward transforms did not match the output
stride of residual computation in this case. Extend the residual
stride to the transform width and zero the non-visible portion.
Fixes #2662. Fixes #2757.
---
src/encoder.rs | 14 +++++++++++---
1 file changed, 11 insertions(+), 3 deletions(-)
diff --git a/src/encoder.rs b/src/encoder.rs
index 564d78d7e..1ccf8c831 100644
--- a/src/encoder.rs
+++ b/src/encoder.rs
@@ -1209,12 +1209,20 @@ pub fn encode_tx_block<T: Pixel, W: Writer>(
residual,
&ts.input_tile.planes[p].subregion(area),
&rec.subregion(area),
- visible_tx_w,
+ tx_size.width(),
visible_tx_h,
);
+ if visible_tx_w < tx_size.width() {
+ for row in residual.chunks_mut(tx_size.width()).take(visible_tx_h) {
+ for a in &mut row[visible_tx_w..] {
+ *a = 0;
+ }
+ }
+ }
}
- let visible_area = visible_tx_w * visible_tx_h;
- for a in residual[visible_area..].iter_mut() {
+ let initialized_area =
+ if visible_tx_w == 0 { 0 } else { tx_size.width() * visible_tx_h };
+ for a in residual[initialized_area..].iter_mut() {
*a = 0;
}

View File

@ -1,9 +1,10 @@
--- rav1e-0.4.1/Cargo.toml 1970-01-01T00:00:00+00:00
+++ rav1e-0.4.1/Cargo.toml 2021-04-07T15:05:56.198967+00:00
@@ -232,20 +232,6 @@
tracing = ["rust_hawktracer/profiling_enabled"]
--- rav1e-0.5.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ rav1e-0.5.0/Cargo.toml 2021-11-21T03:36:51.742045+00:00
@@ -233,21 +233,7 @@
unstable = []
wasm = ["wasm-bindgen"]
[target."cfg(any(decode_test, decode_test_dav1d))".dependencies.system-deps]
-version = "~3.1.2"
-[target."cfg(fuzzing)".dependencies.arbitrary]
-version = "0.4"
-
@ -18,6 +19,7 @@
-
-[target."cfg(fuzzing)".dependencies.rand_chacha]
-version = "0.3"
+version = "3.1.2"
[target."cfg(unix)".dependencies.signal-hook]
version = "0.3"
optional = true

View File

@ -1,4 +1,4 @@
# Generated by rust2rpm 16
# Generated by rust2rpm 18
%bcond_without check
# Install all deps (without check), grab their licenses and make it simple
@ -16,7 +16,7 @@
%global crate rav1e
Name: rust-%{crate}
Version: 0.4.1
Version: 0.5.0
Release: %autorelease
Summary: Fastest and safest AV1 encoder
@ -27,9 +27,8 @@ URL: https://crates.io/crates/rav1e
Source: %{crates_source}
# Initial patched metadata
# * Remove fuzzing dependencies
# * Relax system-deps dependency
Patch0: rav1e-fix-metadata.diff
# Patch to fix https://github.com/xiph/rav1e/issues/2662
Patch1: https://github.com/xiph/rav1e/commit/f553646d70fba8e265d436103a73520eb7adec8c.patch
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
@ -51,7 +50,7 @@ License: %{binary_license}
%description -n %{crate} %{_description}
%files -n %{crate}
%license LICENSE PATENTS
%license PATENTS LICENSE
%doc README.md
%{_bindir}/rav1e
@ -591,14 +590,8 @@ rm -v %{buildroot}%{_libdir}/librav1e.a
%if %{with check}
%check
# FIXME: doctests fail to compile on aarch64
# FIXME: transform::test::roundtrips_u8 fails on aarch64 since 0.3.4
%ifarch aarch64
%cargo_test -- --lib -- --skip transform::test::roundtrips_u8
%else
%cargo_test
%endif
%endif
%changelog
%autochangelog

View File

@ -1 +1 @@
SHA512 (rav1e-0.4.1.crate) = 6ad1651e27f5305294bfcf55520b7d4c326aba534a945c933e056490a6582333df5794d586f6e660636b6d9f2719729ead65b3795e1513462a8cfea012bf21cc
SHA512 (rav1e-0.5.0.crate) = 7ffec9130c94c4eb2c8a5ab44894cc733abacf3cbf7951c5d7203802bd4b8a23dbf7874ab7b29ecec29ebeb98a1acfdd7a7fc15d7efb41dc1127e3340f58e4b8