Bump paste to 1.0

This commit is contained in:
Josh Stone 2020-08-26 07:57:34 -07:00
parent d3e1d7b20d
commit 36559aa84c
3 changed files with 52 additions and 3 deletions

View File

@ -0,0 +1,35 @@
From a811e9ef43e36ca9334146ca3a993a964ae45168 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Sebastian=20Dr=C3=B6ge?= <slomo@coaxion.net>
Date: Mon, 10 Aug 2020 20:44:18 +0300
Subject: [PATCH] Update paste dependency to 1.0, arbitrary to 0.4, console to
0.12 and semver to 0.10 (#2489)
---
src/test_encode_decode/mod.rs | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/test_encode_decode/mod.rs b/src/test_encode_decode/mod.rs
index 884a11da5bb8..ceba8109790d 100644
--- a/src/test_encode_decode/mod.rs
+++ b/src/test_encode_decode/mod.rs
@@ -678,7 +678,7 @@ fn high_bit_depth(decoder: &str, depth: usize) {
macro_rules! test_high_bit_depth {
($($B:expr),+) => {
$(
- paste::item_with_macros!{
+ paste::item!{
#[cfg_attr(feature = "decode_test", interpolate_test(aom, "aom"))]
#[cfg_attr(feature = "decode_test_dav1d", interpolate_test(dav1d, "dav1d"))]
#[ignore]
@@ -709,7 +709,7 @@ fn chroma_sampling(decoder: &str, cs: ChromaSampling) {
macro_rules! test_chroma_sampling {
($(($S:expr, $I:expr)),+) => {
$(
- paste::item_with_macros!{
+ paste::item!{
#[cfg_attr(feature = "decode_test", interpolate_test(aom, "aom"))]
#[cfg_attr(feature = "decode_test_dav1d", interpolate_test(dav1d, "dav1d"))]
#[ignore]
--
2.26.2

View File

@ -1,5 +1,14 @@
--- rav1e-0.3.3/Cargo.toml 2020-06-07T10:15:36+00:00
+++ rav1e-0.3.3/Cargo.toml 2020-06-11T00:43:39.731326+00:00
+++ rav1e-0.3.3/Cargo.toml 2020-08-26T14:46:38.834655+00:00
@@ -120,7 +120,7 @@
version = "0.2"
[dependencies.paste]
-version = "0.1"
+version = "1.0"
[dependencies.rayon]
version = "1.0"
@@ -151,7 +151,7 @@
optional = true

View File

@ -17,7 +17,7 @@
Name: rust-%{crate}
Version: 0.3.3
Release: 2%{?dist}
Release: 3%{?dist}
Summary: Fastest and safest AV1 encoder
# Upstream license specification: BSD-2-Clause
@ -26,11 +26,13 @@ License: BSD and ISC
URL: https://crates.io/crates/rav1e
Source: %{crates_source}
# Initial patched metadata
# * Bump y4m to 0.6, https://github.com/xiph/rav1e/pull/2321/files
# * Bump y4m to 0.6, https://github.com/xiph/rav1e/pull/2321
# * Bump paste to 1.0, https://github.com/xiph/rav1e/pull/2489
# * Remove fuzzing dependencies
Patch0: rav1e-fix-metadata.diff
Patch1: 0001-Update-the-y4m-dependency.patch
Patch2: 0002-Avoid-some-indirection-now-that-we-can-directly-stor.patch
Patch3: 0001-Update-paste-dependency-to-1.0-arbitrary-to-0.4-cons.patch
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
@ -512,6 +514,9 @@ rm -v %{buildroot}%{_libdir}/librav1e.a
%endif
%changelog
* Wed Aug 26 2020 Josh Stone <jistone@redhat.com> - 0.3.3-3
- Bump paste to 1.0
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild