Update to 0.3.1

Signed-off-by: Igor Raits <ignatenkobrain@fedoraproject.org>
This commit is contained in:
Igor Raits 2020-02-20 21:17:43 +01:00
parent 715012fce8
commit 07da219760
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C
4 changed files with 40 additions and 29 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
/rav1e-0.3.0.crate
/rav1e-0.3.1.crate

13
rav1e-fix-metadata.diff Normal file
View File

@ -0,0 +1,13 @@
--- rav1e-0.3.1/Cargo.toml 2020-02-20T06:41:37+00:00
+++ rav1e-0.3.1/Cargo.toml 2020-02-20T20:15:46.972264+00:00
@@ -99,8 +99,8 @@
optional = true
[dependencies.image]
-version = "0.22.1"
-features = ["png_codec"]
+version = "0.23"
+features = ["png"]
optional = true
default-features = false

View File

@ -1,41 +1,33 @@
# Generated by rust2rpm 13
%bcond_without check
# Install all deps (without check), grab their licenses and make it simple
# * ASL 2.0
# * ASL 2.0 or MIT
# * BSD
# * ISC
# * MIT
# * MIT or ASL 2.0
# * (MIT or ASL 2.0) and BSD
# * Unlicense or MIT
# * zlib
%global binary_license BSD and ASL 2.0 and ISC and MIT and zlib
%global crate rav1e
Name: rust-%{crate}
Version: 0.3.0
Version: 0.3.1
Release: 1%{?dist}
Summary: Fastest and safest AV1 encoder
# Upstream license specification: BSD-2-Clause
# Apache-2.0 AND BSD-2-Clause OR MIT (1): crossbeam-queue
# Apache-2.0 OR Apache-2.0 WITH LLVM-exception OR MIT (1): wasi
# Apache-2.0 OR BSL-1.0 (1): ryu
# Apache-2.0 OR MIT (79): proc-macro-hack, num-integer, err-derive, num-traits,
# winapi, winapi-i686-pc-windows-gnu, regex-syntax, time, rustversion, cast,
# paste, itoa, nasm-rs, jobserver, arbitrary, serde_derive, syn-mid, scopeguard,
# cc, autocfg, regex, proc-macro2, criterion-plot, bstr, itertools, rustc_version,
# encode_unicode, vergen, rand, crossbeam-deque, signal-hook-registry, rand_core,
# paste-impl, bitstream-io, backtrace, hermit-abi, semver-parser, criterion,
# unicode-width, winapi-x86_64-pc-windows-gnu, c2-chacha, rand_xoshiro,
# unicode-xid, crossbeam-utils, rand_os, cfg-if, syn, log, pretty_assertions,
# proc-macro-error-attr, arc-swap, lazy_static, rand_chacha, rayon-core, serde,
# bitflags, tinytemplate, rayon, serde_json, num_cpus, ctor, signal-hook,
# ppv-lite86, either, thread_local, crossbeam-epoch, autocfg, getrandom, quote,
# arrayvec, rand_hc, backtrace-sys, num-derive, chrono, libc, proc-macro-error,
# better-panic, semver, rustc-demangle
# BSD-2-Clause (2): rav1e, ivf
# MIT (19): ansi_term, y4m, noop_proc_macro, atty, output_vt100, textwrap, clap,
# arg_enum_proc_macro, synstructure, memoffset, difference, simd_helpers,
# redox_syscall, console, clicolors-control, interpolate_name, termios, fern,
# scan_fmt
# MIT OR Unlicense (9): walkdir, same-file, csv, regex-automata, csv-core,
# winapi-util, memchr, byteorder, aho-corasick
# ISC: src/ext/x86/x86inc.asm
License: BSD and (ASL 2.0 or MIT and BSD) and (ASL 2.0 or Boost) and (ASL 2.0 or MIT) and MIT and (MIT or Unlicense) and ISC
# src/ext/x86/x86inc.asm is under ISC, https://github.com/xiph/rav1e/issues/2181
License: BSD and ISC
URL: https://crates.io/crates/rav1e
Source: %{crates_source}
# Initial patched metadata
# * Update image to 0.23, https://github.com/xiph/rav1e/pull/2178
Patch0: rav1e-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
@ -52,6 +44,7 @@ Fastest and safest AV1 encoder.}
%if ! %{__cargo_skip_build}
%package -n %{crate}
Summary: %{summary}
License: %{binary_license}
%description -n %{crate} %{_description}
@ -62,6 +55,7 @@ Summary: %{summary}
%package -n %{crate}-libs
Summary: Library files for rav1e
License: %{binary_license}
%description -n %{crate}-libs
Library files for rav1e, the fastest and safest AV1 encoder.
@ -78,7 +72,7 @@ Requires: %{crate}-libs%{?_isa} = %{version}-%{release}
Development files for rav1e, the fastest and safest AV1 encoder.
%files -n %{crate}-devel
%{_includedir}/rav1e
%{_includedir}/rav1e/
%{_libdir}/librav1e.so
%{_libdir}/pkgconfig/rav1e.pc
%endif
@ -514,7 +508,7 @@ cargo cinstall --release \
--libdir=%{_libdir} \
--includedir=%{_includedir} \
--pkgconfigdir=%{_libdir}/pkgconfig
rm -f %{buildroot}%{_libdir}/librav1e.a
rm -v %{buildroot}%{_libdir}/librav1e.a
%if %{with check}
%check
@ -522,5 +516,8 @@ rm -f %{buildroot}%{_libdir}/librav1e.a
%endif
%changelog
* Thu Feb 20 21:15:47 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.3.1-1
- Update to 0.3.1
* Tue Feb 11 01:28:07 CET 2020 Robert-André Mauchin <zebob.m@gmail.com> - 0.3.0-1
- Initial package

View File

@ -1 +1 @@
SHA512 (rav1e-0.3.0.crate) = 73cb6312481c800e9984e03cbadf25253f43c9fbf03a80c3677a98b165f3799b0849a18fab1e11c761254b3380a29b59ca8cfdf7c01a41adae2ce70dabb9444b
SHA512 (rav1e-0.3.1.crate) = 7e3b958ef0ac609599044f89631ce045e7a299fb4a7b6f3f5bfc3ab603befa037ba00a0973421db5eaa6a7109b3f8961febb5faa6738d3c71b98aff4b6aa4178