rust-procs/procs-fix-metadata.diff

57 lines
1.4 KiB
Diff

--- procs-0.10.3/Cargo.toml 2020-05-11T04:13:58+00:00
+++ procs-0.10.3/Cargo.toml 2020-05-22T09:35:48.023171+00:00
@@ -81,10 +81,6 @@
[dependencies.directories]
version = "2.0"
-[dependencies.dockworker]
-version = "0.0.15"
-optional = true
-
[dependencies.getch]
version = "0.2"
@@ -108,10 +104,6 @@
[dependencies.unicode-width]
version = "0.1"
-
-[features]
-default = ["docker"]
-docker = ["dockworker"]
[target."cfg(target_os = \"linux\")".dependencies.pager]
version = "0.15"
@@ -122,30 +114,10 @@
version = "0.7.1"
[target."cfg(target_os = \"linux\")".dependencies.users]
-version = "0.9"
+version = "0.10"
[target."cfg(target_os = \"linux\")".dependencies.which]
version = "3"
-[target."cfg(target_os = \"macos\")".dependencies.errno]
-version = "0.2"
-
-[target."cfg(target_os = \"macos\")".dependencies.libproc]
-version = "0.5"
-
-[target."cfg(target_os = \"macos\")".dependencies.pager]
-version = "0.15"
-
-[target."cfg(target_os = \"macos\")".dependencies.process_path]
-version = "0.1"
-
-[target."cfg(target_os = \"macos\")".dependencies.users]
-version = "0.9"
-
-[target."cfg(target_os = \"macos\")".dependencies.which]
-version = "3"
-[target."cfg(target_os = \"windows\")".dependencies.winapi]
-version = "0.3"
-features = ["handleapi", "minwindef", "psapi", "securitybaseapi", "tlhelp32", "winbase", "winnt"]
[badges.codecov]
branch = "master"
repository = "dalance/procs"