61 lines
1.5 KiB
Diff
61 lines
1.5 KiB
Diff
--- procs-0.10.3/Cargo.toml 2020-05-11T04:13:58+00:00
|
|
+++ procs-0.10.3/Cargo.toml 2020-09-30T12:43:30.233949+00:00
|
|
@@ -81,10 +81,6 @@
|
|
[dependencies.directories]
|
|
version = "2.0"
|
|
|
|
-[dependencies.dockworker]
|
|
-version = "0.0.15"
|
|
-optional = true
|
|
-
|
|
[dependencies.getch]
|
|
version = "0.2"
|
|
|
|
@@ -109,9 +105,6 @@
|
|
[dependencies.unicode-width]
|
|
version = "0.1"
|
|
|
|
-[features]
|
|
-default = ["docker"]
|
|
-docker = ["dockworker"]
|
|
[target."cfg(target_os = \"linux\")".dependencies.pager]
|
|
version = "0.15"
|
|
|
|
@@ -119,33 +112,14 @@
|
|
version = "0.1"
|
|
|
|
[target."cfg(target_os = \"linux\")".dependencies.procfs]
|
|
-version = "0.7.1"
|
|
+version = "0.8.0"
|
|
|
|
[target."cfg(target_os = \"linux\")".dependencies.users]
|
|
-version = "0.9"
|
|
+version = "0.10"
|
|
|
|
[target."cfg(target_os = \"linux\")".dependencies.which]
|
|
-version = "3"
|
|
-[target."cfg(target_os = \"macos\")".dependencies.errno]
|
|
-version = "0.2"
|
|
+version = "4"
|
|
|
|
-[target."cfg(target_os = \"macos\")".dependencies.libproc]
|
|
-version = "0.5"
|
|
-
|
|
-[target."cfg(target_os = \"macos\")".dependencies.pager]
|
|
-version = "0.15"
|
|
-
|
|
-[target."cfg(target_os = \"macos\")".dependencies.process_path]
|
|
-version = "0.1"
|
|
-
|
|
-[target."cfg(target_os = \"macos\")".dependencies.users]
|
|
-version = "0.9"
|
|
-
|
|
-[target."cfg(target_os = \"macos\")".dependencies.which]
|
|
-version = "3"
|
|
-[target."cfg(target_os = \"windows\")".dependencies.winapi]
|
|
-version = "0.3"
|
|
-features = ["handleapi", "minwindef", "psapi", "securitybaseapi", "tlhelp32", "winbase", "winnt"]
|
|
[badges.codecov]
|
|
branch = "master"
|
|
repository = "dalance/procs"
|