Update to version 0.12.3

This commit is contained in:
Kevin Agwaze 2022-07-26 23:07:29 +01:00
parent d499d9cef7
commit 9b260d3103
No known key found for this signature in database
GPG Key ID: 62BD207402FD989A
4 changed files with 89 additions and 26 deletions

1
.gitignore vendored
View File

@ -6,3 +6,4 @@
/procs-0.10.3.crate
/procs-0.10.5.crate
/procs-0.10.10.crate
/procs-0.12.3.crate

View File

@ -1,35 +1,64 @@
--- procs-0.10.10/Cargo.toml 2020-11-26T01:18:03+00:00
+++ procs-0.10.10/Cargo.toml 2020-12-15T20:47:21.423279+00:00
@@ -81,10 +81,6 @@
--- procs-0.12.3/Cargo.toml 1970-01-01T00:00:01+00:00
+++ procs-0.12.3/Cargo.toml 2022-06-24T14:46:26.578443+00:00
@@ -94,20 +94,16 @@
features = ["derive"]
[dependencies.clap_complete]
-version = "3.1.4"
+version = "3.0.6"
[dependencies.console]
version = "0.15.0"
[dependencies.directories]
version = "3"
-[dependencies.dockworker]
-version = "0.0.19"
-optional = true
-version = "4.0.1"
-
[dependencies.getch]
version = "0.2"
-[dependencies.dockworker]
-version = "0.0.23"
-optional = true
+version = "3.0.2"
@@ -109,9 +105,6 @@
[dependencies.getch]
-version = "0.3.1"
+version = "0.2.1"
[dependencies.lazy_static]
version = "1.2"
@@ -122,7 +118,7 @@
version = "1.0"
[dependencies.termbg]
-version = "0.4.1"
+version = "0.4.0"
[dependencies.toml]
version = "0.5"
@@ -130,48 +126,17 @@
[dependencies.unicode-width]
version = "0.1"
-[features]
-default = ["docker"]
-docker = ["dockworker"]
[target."cfg(target_os = \"linux\")".dependencies.pager]
-
[target."cfg(any(target_os = \"linux\", target_os = \"android\"))".dependencies.pager]
version = "0.16"
@@ -123,23 +116,7 @@
[target."cfg(any(target_os = \"linux\", target_os = \"android\"))".dependencies.procfs]
-version = "0.12.0"
+version = "0.9.1"
[target."cfg(target_os = \"linux\")".dependencies.which]
[target."cfg(any(target_os = \"linux\", target_os = \"android\"))".dependencies.users]
version = "0.11"
[target."cfg(any(target_os = \"linux\", target_os = \"android\"))".dependencies.which]
version = "4"
-
-[target."cfg(target_os = \"macos\")".dependencies.errno]
-version = "0.2"
-
-[target."cfg(target_os = \"macos\")".dependencies.libproc]
-version = "0.9"
-version = "0.12"
-
-[target."cfg(target_os = \"macos\")".dependencies.pager]
-version = "0.16"
@ -39,9 +68,43 @@
-
-[target."cfg(target_os = \"macos\")".dependencies.which]
-version = "4"
-
-[target."cfg(target_os = \"windows\")".dependencies.winapi]
-version = "0.3"
-features = ["handleapi", "minwindef", "psapi", "securitybaseapi", "tlhelp32", "winbase", "winnt"]
-features = [
- "handleapi",
- "minwindef",
- "psapi",
- "securitybaseapi",
- "tlhelp32",
- "winbase",
- "winnt",
-]
[badges.codecov]
branch = "master"
repository = "dalance/procs"
--- procs-0.12.3/src/columns/usage_mem.rs 1973-11-29 21:33:09.000000000 +0000
+++ procs-0.12.3/src/columns/usage_mem.rs 2022-06-24 15:53:12.970311182 +0100
@@ -81,7 +81,7 @@
impl Column for UsageMem {
fn add(&mut self, proc: &ProcessInfo) {
let usage =
- proc.curr_proc.stat().rss_bytes().unwrap_or(0) as f64 * 100.0 / self.mem_total as f64;
+ proc.curr_proc.stat().rss_bytes() as f64 * 100.0 / self.mem_total as f64;
let fmt_content = format!("{:.1}", usage);
let raw_content = (usage * 1000.0) as u32;
--- procs-0.12.3/src/columns/vm_rss.rs 1973-11-29 21:33:09.000000000 +0000
+++ procs-0.12.3/src/columns/vm_rss.rs 2022-06-24 15:55:24.473944994 +0100
@@ -29,7 +29,7 @@
#[cfg(any(target_os = "linux", target_os = "android"))]
impl Column for VmRss {
fn add(&mut self, proc: &ProcessInfo) {
- let raw_content = proc.curr_proc.stat().rss_bytes().unwrap_or(0) as u64;
+ let raw_content = proc.curr_proc.stat().rss_bytes() as u64;
let fmt_content = bytify(raw_content);
self.fmt_contents.insert(proc.pid, fmt_content);

View File

@ -1,12 +1,11 @@
# Generated by rust2rpm 16
# Generated by rust2rpm 21
%bcond_without check
%global __cargo_skip_build 0
%global crate procs
Name: rust-%{crate}
Version: 0.10.10
Release: 6%{?dist}
Version: 0.12.3
Release: 1%{?dist}
Summary: Modern replacement for ps
# Upstream license specification: MIT
@ -20,7 +19,7 @@ Patch0: procs-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Modern replacement for ps.}
@ -63,8 +62,8 @@ License: MIT and ASL 2.0 and zlib
%endif
%changelog
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.10-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Fri Jul 26 2022 Kevin Agwaze <kevin-agwaze@proton.me> - 0.12.3-1
- Update to version 0.12.3
* Tue Feb 15 2022 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 0.10.10-5
- Rebuild with package notes

View File

@ -1 +1 @@
SHA512 (procs-0.10.10.crate) = fd821e43473e10842337172dac0a6b0886d7e6d7c8d9e25da0425157da2e36b16414c987c3bcb7ea34ff931244210ce6b996309aa1592acd383e19f7fd21d66b
SHA512 (procs-0.12.3.crate) = fe5c476c4f0d2fc1c86e2c3beb740db20330579ea34521866766d2b87e8188f5f65ffb944f3598413da58bc06ec0804c557b28e5c14ce0f2982681f06cc893e4